Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 24-03-2010, 16:13   #16
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
This is what I get when compiling
Quote:
checking for __WXX11__... no
checking for __WXGTK__... yes
Check your wx installation again as your system can't find it.
__________________

__________________
cagney is offline   Reply With Quote
Old 24-03-2010, 16:45   #17
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
Well, I'd bet for some configure/automake caching error. Did you try
Code:
make clean
or
Code:
make distclean
after installing wxGTK-devel? Then re-run ./configure with any appropriate option.

I currently have these packages on Fedora12:
Code:
$ rpm -qa wx\*
wxGTK-2.8.10-7.fc12.i686
wxGTK-media-2.8.10-7.fc12.i686
wxBase-2.8.10-7.fc12.i686
wxGTK-devel-2.8.10-7.fc12.i686
wxGTK-gl-2.8.10-7.fc12.i686
__________________

__________________
SethDart is offline   Reply With Quote
Old 24-03-2010, 17:19   #18
Registered User

Join Date: Mar 2010
Posts: 9
Thank you all:
I have the same return for rpm -qa as you SethDart, and did distclean after make. I still get "checking for __WXGTK__... no" despite my system assuring me that wx is happily installed.
I'm sure I'm missing something simple, so please don't assume that I haven't made a complete rookie error!
__________________
snicco is offline   Reply With Quote
Old 25-03-2010, 02:14   #19
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
Quote:
Originally Posted by snicco View Post
I'm sure I'm missing something simple, so please don't assume that I haven't made a complete rookie error!
Well, that's my first thinking, just to make sure. I often make such mistakes No offence intended.

Did you check config.status content? This is what I get:
Code:
$ grep -E "(WX_RELEASE|WX_LIBS|CPPFLAGS)" config.status 
S["WX_RELEASE"]="2.8"
S["WX_LIBS"]="-pthread   -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2."\
S["CPPFLAGS"]=" -I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__"
What is the result of:
Code:
$ /usr/bin/wx-config --cppflags
-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXGTK__
$ /usr/bin/wx-config --libs
-pthread   -lwx_gtk2u_richtext-2.8 -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8
Do you have gtk2-devel installed?
Code:
 $ rpm -q gtk2-devel
gtk2-devel-2.18.7-1.fc12.i686
It's also required to compile OpenCPN.

Can you have a look at config.log around line 290? What does it tell about wxGTK and GTK+?

That's the only things I'm thinking about. If all the above is correct, you can post your config.log and config.status, maybe someone will have others suggestions.
__________________
SethDart is offline   Reply With Quote
Old 25-03-2010, 18:00   #20
Registered User

Join Date: Mar 2010
Posts: 9
Here we go again!
The good news:
PHP Code:
$ /usr/bin/wx-config --cppflags 
and
PHP Code:
$ /usr/bin/wx-config --libs 
return exactly what you have, and yes, gtk2-devel is installed and of the right flavour, but
PHP Code:
grep -"(WX_RELEASE|WX_LIBS|CPPFLAGS)" config.status
s
,@CPPFLAGS@,|#_!!_#| -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__,g
s,@WX_LIBS@,|#_!!_#|-L/usr/local/lib -pthread   -lwx_x11univ_richtext-2.8 -lwx_x11univ_aui-2.8 -lwx_x11univ_xrc-2.8 -lwx_x11univ_qa-2.8 -lwx_x11univ_html-2.8 -lwx_x11univ_adv-2.8 -lwx_x11univ_core-2.8 -lwx_base_xml-2.8 -lwx_base_net-2.8 -lwx_base-2.8 ,g
s,@WX_RELEASE@,|#_!!_#|2.8,g 
Long shot, but I'm seeing WXX11 still in there.

Lines around 290 in config.log are:
PHP Code:
conftest.cpp:12:22errorwx/setup.hNo such file or directory
conftest
.cppIn function 'int main()':
conftest.cpp:18error'Some' was not declared in this scope
conftest
.cpp:18errorexpected ';' before 'error'
configure:5325: $? = 1
configure
failed program was:
/* confdefs.h.  */ 
__________________
snicco is offline   Reply With Quote
Old 25-03-2010, 20:27   #21
Registered User

Join Date: Sep 2007
Location: FL
Boat: Pacific Seacraft 31 - Cielo Azul
Posts: 359
Images: 3
re: snicco

I had a same problem, there was some leftover wx stuff from
where I did a install via my own build instead of rpms. Once
I cleaned it up, it found my setup.h, compiles up to:
PHP Code:
In file included from /usr/include/wx-2.8/wx/sckaddr.h:20,
                 
from /usr/include/wx-2.8/wx/socket.h:24,
                 
from ././include/nmea.h:116,
                 
from src/chart1.cpp:255:
/
usr/include/wx-2.8/wx/gsocket.h:40errorusing typedef-name ‘GSocket’ after ‘class’
/usr/include/glib-2.0/gio/giotypes.h:120error‘GSocket’ has a previous declaration here
In file included from 
/usr/include/wx-2.8/wx/gsocket.h:179,
                 
from /usr/include/wx-2.8/wx/sckaddr.h:20,
                 
from /usr/include/wx-2.8/wx/socket.h:24,
                 
from ././include/nmea.h:116,
                 
from src/chart1.cpp:255:
/
usr/include/wx-2.8/wx/unix/gsockunx.h:40errorusing typedef-name ‘GSocket’ after ‘class’
/usr/include/glib-2.0/gio/giotypes.h:120error‘GSocket’ has a previous declaration here
In file included from 
././include/nmea.h:116,
                 
from src/chart1.cpp:255:
/
usr/include/wx-2.8/wx/socket.hIn member function ‘wxSocketError wxSocketBase::LastError() const’:
/
usr/include/wx-2.8/wx/socket.h:118error‘struct _GSocket’ has no member named ‘GetError’
In file included from src
/chart1.cpp:265:
././include/
grib.hAt global scope:
././include/
grib.h:83warning‘typedef’ was ignored in this declaration
make
: *** [chart1.oError 1 
Tom
__________________
teejayevans is online now   Reply With Quote
Old 26-03-2010, 10:45   #22
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,247
teejayevans

Your output is consistent with the "glib 2.21/wxWidgets 2.8." -bug.
A workaround is described here: OpenCPN Version 1.3.5 Beta Technical

An alternative is to use the latest CVS code for compiling, were this bug is fixed. I assume that you are compiling the 1.3.6 source code from Source Forge?

Thomas
__________________
cagney is offline   Reply With Quote
Old 26-03-2010, 11:28   #23
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
Quote:
Originally Posted by snicco View Post
Long shot, but I'm seeing WXX11 still in there.
May I suggest you to remove everything related to wxX11

Quote:
Originally Posted by snicco View Post
conftest.cpp:12:22: error: wx/setup.h: No such file or directory
Code:
$ locate wx/setup.h
/usr/lib/wx/include/gtk2-unicode-release-2.8/wx/setup.h
Code:
$ rpm -q --whatprovides /usr/lib/wx/include/gtk2-unicode-release-2.8/wx/setup.h
wxGTK-devel-2.8.10-7.fc12.i686
If the above does not solve you problem, would you mind sending your config.log please.

One more question: are you trying to compile the tar.gz archive or CVS version? There are differences between both and I'm compiling CVS version with success here.
__________________
SethDart is offline   Reply With Quote
Old 26-03-2010, 21:12   #24
Registered User

Join Date: Mar 2010
Posts: 9
Thank you all. I think my best approach at this stage is removing all vestiges of both wx widgets and opencpn and then:
1. Install gtk2wxwidgets (with the necessary devels)
2. Find and compile the CVS version of opencpn,
and yes, I was trying to compile the tar.gz version.
__________________
snicco is offline   Reply With Quote
Old 28-03-2010, 22:41   #25
Registered User

Join Date: Mar 2010
Posts: 9
Sorry for the delay in posting. I've attempted to follow up everyone's suggestions; so here's my config.log from the last attempt:

PHP Code:
 $ ./configure 

## --------- ##
## Platform. ##
## --------- ##

hostname = *********.localdomain
uname 
-i686
uname 
-2.6.31.12-174.2.22.fc12.i686.PAE
uname 
-Linux
uname 
-#1 SMP Fri Feb 19 19:10:04 UTC 2010

/usr/bin/uname -unknown
/bin/uname -X     unknown

/bin/arch              i686
/usr/bin/arch -k       unknown
/usr/convex/getsysinfo unknown
/usr/bin/hostinfo      unknown
/bin/machine           unknown
/usr/bin/oslevel       unknown
/bin/universe          unknown

PATH
: /usr/kerberos/sbin
PATH
: /usr/kerberos/bin
PATH
: /usr/local/bin
PATH
: /usr/bin
PATH
: /bin
PATH
: /usr/local/sbin
PATH
: /usr/sbin
PATH
: /sbin
PATH
: /home/nick/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1777checking for a BSD-compatible install
configure
:1833result: /usr/bin/install -c
configure
:1844checking whether build environment is sane
configure
:1887resultyes
configure
:1915checking for a thread-safe mkdir -p
configure
:1954result: /bin/mkdir -p
configure
:1967checking for gawk
configure
:1983found /usr/bin/gawk
configure
:1994resultgawk
configure
:2005checking whether make sets $(MAKE)
configure:2026resultyes
configure
:2264checking for gcc
configure
:2280found /usr/bin/gcc
configure
:2291resultgcc
configure
:2529checking for C compiler version
configure
:2536gcc --version >&5
gcc 
(GCC4.4.3 20100127 (Red Hat 4.4.3-4)
Copyright (C2010 Free Software FoundationInc.
This is free softwaresee the source for copying conditions.  There is NO
warranty
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2539: $? = 0
configure
:2546gcc ->&5
Using built
-in specs.
Targeti686-redhat-linux
Configured with
: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch=i686 --build=i686-redhat-linux
Thread modelposix
gcc version 4.4.3 20100127 
(Red Hat 4.4.3-4) (GCC
configure:2549: $? = 0
configure
:2556gcc ->&5
gcc
'-V' option must have argument
configure
:2559: $? = 1
configure
:2582checking for C compiler default output file name
configure
:2609gcc    conftest.c  >&5
configure
:2612: $? = 0
configure
:2650resulta.out
configure
:2667checking whether the C compiler works
configure
:2677: ./a.out
configure
:2680: $? = 0
configure
:2697resultyes
configure
:2704checking whether we are cross compiling
configure
:2706resultno
configure
:2709checking for suffix of executables
configure
:2716gcc -o conftest    conftest.c  >&5
configure
:2719: $? = 0
configure
:2743result
configure:2749checking for suffix of object files
configure
:2775gcc -c   conftest.>&5
configure
:2778: $? = 0
configure
:2801resulto
configure
:2805checking whether we are using the GNU C compiler
configure
:2834gcc -c   conftest.>&5
configure
:2840: $? = 0
configure
:2857resultyes
configure
:2862checking whether gcc accepts -g
configure
:2892gcc --g  conftest.>&5
configure
:2898: $? = 0
configure
:2997resultyes
configure
:3014checking for gcc option to accept ISO C89
configure
:3088gcc  ---O2  conftest.>&5
configure
:3094: $? = 0
configure
:3117resultnone needed
configure
:3146checking for style of include used by make
configure
:3174resultGNU
configure
:3199checking dependency style of gcc
configure
:3290resultgcc3
configure
:3311checking how to run the C preprocessor
configure
:3351gcc -E  conftest.c
configure
:3357: $? = 0
configure
:3388gcc -E  conftest.c
conftest
.c:10:28errorac_nonexistent.hNo such file or directory
configure
:3394: $? = 1
configure
failed program was:
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
/* end confdefs.h.  */
#include <ac_nonexistent.h>
configure:3427resultgcc -E
configure
:3456gcc -E  conftest.c
configure
:3462: $? = 0
configure
:3493gcc -E  conftest.c
conftest
.c:10:28errorac_nonexistent.hNo such file or directory
configure
:3499: $? = 1
configure
failed program was:
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
/* end confdefs.h.  */
#include <ac_nonexistent.h>
configure:3537checking for grep that handles long lines and -e
configure
:3611result: /bin/grep
configure
:3616checking for egrep
configure
:3694result: /bin/grep -E
configure
:3700checking whether gcc needs -traditional
configure
:3742resultno
configure
:3813checking for g++
configure:3829found /usr/bin/g++
configure:3840resultg++
configure:3871checking for C++ compiler version
configure
:3878g++ --version >&5
g
++ (GCC4.4.3 20100127 (Red Hat 4.4.3-4)
Copyright (C2010 Free Software FoundationInc.
This is free softwaresee the source for copying conditions.  There is NO
warranty
not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3881: $? = 0
configure
:3888g++ ->&5
Using built
-in specs.
Targeti686-redhat-linux
Configured with
: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch=i686 --build=i686-redhat-linux
Thread modelposix
gcc version 4.4.3 20100127 
(Red Hat 4.4.3-4) (GCC
configure:3891: $? = 0
configure
:3898g++ ->&5
g
++: '-V' option must have argument
configure
:3901: $? = 1
configure
:3904checking whether we are using the GNU C++ compiler
configure
:3933g++ -c   conftest.cpp >&5
configure
:3939: $? = 0
configure
:3956resultyes
configure
:3961checking whether g++ accepts -g
configure
:3991g++ --g  conftest.cpp >&5
configure
:3997: $? = 0
configure
:4096resultyes
configure
:4121checking dependency style of g++
configure:4212resultgcc3
configure
:4232checking how to run the C++ preprocessor
configure
:4268g++ -E  conftest.cpp
configure
:4274: $? = 0
configure
:4305g++ -E  conftest.cpp
conftest
.cpp:10:28errorac_nonexistent.hNo such file or directory
configure
:4311: $? = 1
configure
failed program was:
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
/* end confdefs.h.  */
#include <ac_nonexistent.h>
configure:4344resultg++ -E
configure
:4373g++ -E  conftest.cpp
configure
:4379: $? = 0
configure
:4410g++ -E  conftest.cpp
conftest
.cpp:10:28errorac_nonexistent.hNo such file or directory
configure
:4416: $? = 1
configure
failed program was:
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
/* end confdefs.h.  */
#include <ac_nonexistent.h>
configure:4458checking how to run the C preprocessor
configure
:4574resultgcc -E
configure
:4603gcc -E  conftest.c
configure
:4609: $? = 0
configure
:4640gcc -E  conftest.c
conftest
.c:10:28errorac_nonexistent.hNo such file or directory
configure
:4646: $? = 1
configure
failed program was:
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
/* end confdefs.h.  */
#include <ac_nonexistent.h>
configure:4696checking for a BSD-compatible install
configure
:4752result: /usr/bin/install -c
configure
:4771checking for SSP support/disable
configure
:4795g++ -c  -Wall --fexceptions -fno-stack-protector  conftest.cpp >&5
configure
:4801: $? = 0
configure
:4816resultyes
configure
:4864checking build system type
configure
:4882resulti686-pc-linux-gnu
configure
:4904checking host system type
configure
:4919resulti686-pc-linux-gnu
configure
:4975checking for gluNewTess in -lGLU
configure
:5010g++ -o conftest  -Wall --fexceptions -fno-stack-protector   conftest.cpp -lGLU   >&5
configure
:5016: $? = 0
configure
:5034resultyes
configure
:5111checking wxWidgets wx-config
configure
:5113resultwx-config
configure
:5115checking wxWidgets version
configure
:5118result2.8.10
configure
:5135checking for wxWidgets location
configure
:5137result: /usr/local
configure
:5140checking for wxWidgets release (majorminornumber
configure
:5142result2.8
configure
:5159checking for wxWidgets setup header
configure
:5161result: /usr/local/lib/wx/include/x11univ-ansi-release-2.8/wx/setup.h
configure
:5165checking for __WXX11__
configure
:5192g++ -c  -Wall --fexceptions -fno-stack-protector  -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__ conftest.cpp >&5
conftest
.cpp:12:22errorwx/setup.hNo such file or directory
configure
:5198: $? = 1
configure
failed program was:
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
#define INSTALL_PREFIX "/usr/local"
/* end confdefs.h.  */

#include    "wx/setup.h"
int
main ()
| {
|  
#ifdef __WXX11__
#else
cause an error
#endif
|   ;
|   return 
0;
| }
configure:5213resultno
configure
:5292checking for __WXGTK__
configure
:5319g++ -c  -Wall --fexceptions -fno-stack-protector  -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__ conftest.cpp >&5
conftest
.cpp:12:22errorwx/setup.hNo such file or directory
conftest
.cppIn function 'int main()':
conftest.cpp:18error'Some' was not declared in this scope
conftest
.cpp:18errorexpected ';' before 'error'
configure:5325: $? = 1
configure
failed program was:
/* confdefs.h.  */
#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
#define INSTALL_PREFIX "/usr/local"
/* end confdefs.h.  */

#include    "wx/setup.h"
int
main ()
| {
|  
#ifdef __WXGTK__
#else
Some error
#endif
|   ;
|   return 
0;
| }
configure:5339resultno
configure
:5363checking for pkg-config
configure
:5381found /usr/bin/pkg-config
configure
:5394result: /usr/bin/pkg-config
configure
:5416checking for GTK+ - version >= 2.0.0
configure
:5428resultyes
configure
:5444checking for libgtk2.0-dev include files
configure
:5467g++ -c  -Wall --fexceptions -fno-stack-protector -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman--I/usr/include/freetype2 -I/usr/include/libpng12    -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__ conftest.cpp >&5
configure
:5473: $? = 0
configure
:5487resultyes
configure
:5492checking for cairo.h in include path
configure
:5515g++ -c  -Wall --fexceptions -fno-stack-protector -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman--I/usr/include/freetype2 -I/usr/include/libpng12    -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__ conftest.cpp >&5
configure
:5521: $? = 0
configure
:5535resultyes
configure
:6722creating ./config.status

## ---------------------- ##
## Running config.status. ##
## ---------------------- ##

This file was extended by config.statuswhich was
generated by GNU Autoconf 2.61
.  Invocation command line was

  CONFIG_FILES    

  
CONFIG_HEADERS  
  
CONFIG_LINKS    
  
CONFIG_COMMANDS 
  $ ./
config.status 

on 
********.localdomain

config
.status:665creating Makefile
config
.status:856executing depfiles commands

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=i686-pc-linux-gnu
ac_cv_c_compiler_gnu
=yes
ac_cv_cxx_compiler_gnu
=yes
ac_cv_env_CCC_set
=
ac_cv_env_CCC_value=
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=
ac_cv_env_CXXFLAGS_value=
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=i686-pc-linux-gnu
ac_cv_lib_GLU_gluNewTess
=yes
ac_cv_objext
=o
ac_cv_path_EGREP
='/bin/grep -E'
ac_cv_path_GREP=/bin/grep
ac_cv_path_MY_PKG_CONFIG
=/usr/bin/pkg-config
ac_cv_path_install
='/usr/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK
=gawk
ac_cv_prog_CPP
='gcc -E'
ac_cv_prog_CXXCPP='g++ -E'
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_ac_ct_CXX
=g++
ac_cv_prog_cc_c89=
ac_cv_prog_cc_g=yes
ac_cv_prog_cxx_g
=yes
ac_cv_prog_gcc_traditional
=no
ac_cv_prog_make_make_set
=yes
am_cv_CC_dependencies_compiler_type
=gcc3
am_cv_CXX_dependencies_compiler_type
=gcc3

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/*****/OpenCPN-OpenCPN-218cc88/missing --run aclocal-1.10'
AMDEPBACKSLASH='\'
AMDEP_FALSE='
#'
AMDEP_TRUE=''
AMTAR='${SHELL} /home/*****/OpenCPN-OpenCPN-218cc88/missing --run tar'
AUTOCONF='${SHELL} /home/*****/OpenCPN-OpenCPN-218cc88/missing --run autoconf'
AUTOHEADER='${SHELL} /home/****/OpenCPN-OpenCPN-218cc88/missing --run autoheader'
AUTOMAKE='${SHELL} /home/*****/OpenCPN-OpenCPN-218cc88/missing --run automake-1.10'
AWK='gawk'
BUILD_FOR_DARWIN=''
BUILD_FOR_DARWIN_FALSE=''
BUILD_FOR_DARWIN_TRUE='#'
BUILD_WITH_GLU_TESS=''
BUILD_WITH_GLU_TESS_FALSE='#'
BUILD_WITH_GLU_TESS_TRUE=''
BUILD_WITH_GTK_OPTIMIZATION=''
BUILD_WITH_GTK_OPTIMIZATION_FALSE='#'
BUILD_WITH_GTK_OPTIMIZATION_TRUE=''
BUILD_WITH_INTERNAL_TESS=''
BUILD_WITH_INTERNAL_TESS_FALSE=''
BUILD_WITH_INTERNAL_TESS_TRUE='#'
BUILD_WITH_S57=''
BUILD_WITH_S57_FALSE='#'
BUILD_WITH_S57_TRUE=''
BUILD_WITH_WIFI_CLIENT=''
BUILD_WITH_WIFI_CLIENT_FALSE=''
BUILD_WITH_WIFI_CLIENT_TRUE='#'
CC='gcc'
CCDEPMODE='depmode=gcc3'
CFLAGS='-g -O2'
CPP='gcc -E'
CPPFLAGS=' -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__'
CXX='g++'
CXXCPP='g++ -E'
CXXDEPMODE='depmode=gcc3'
CXXFLAGS=' -Wall -g -fexceptions -fno-stack-protector -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12  '
CYGPATH_W='echo'
DEFS='-DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"opencpn\" -DVERSION=\"0.1\" -DINSTALL_PREFIX=\"/usr/local\"'
DEPDIR='.deps'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP='/bin/grep -E'
EXEEXT=''
GL_CFLAGS='-DUSE_GLU_TESS'
GL_LIBS='-lGL -lGLU'
GREP='/bin/grep'
GTK_CFLAGS=''
GTK_CONFIG=''
GTK_LIBS=''
HOST_OS='linux-gnu'
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LDFLAGS=''
LIBOBJS=''
LIBS=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /home/nick/OpenCPN-OpenCPN-218cc88/missing --run makeinfo'
MY_PKG_CONFIG='/usr/bin/pkg-config'
OBJEXT='o'
PACKAGE='opencpn'
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
PKG_CONFIG=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION='0.1'
WX_HOME='/usr/local'
WX_LIBS='-L/usr/local/lib -pthread   -lwx_x11univ_richtext-2.8 -lwx_x11univ_aui-2.8 -lwx_x11univ_xrc-2.8 -lwx_x11univ_qa-2.8 -lwx_x11univ_html-2.8 -lwx_x11univ_adv-2.8 -lwx_x11univ_core-2.8 -lwx_base_xml-2.8 -lwx_base_net-2.8 -lwx_base-2.8 '
WX_RELEASE='2.8'
ac_ct_CC='gcc'
ac_ct_CXX='g++'
am__fastdepCC_FALSE='#'
am__fastdepCC_TRUE=''
am__fastdepCXX_FALSE='#'
am__fastdepCXX_TRUE=''
am__include='include'
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build='i686-pc-linux-gnu'
build_alias=''
build_cpu='i686'
build_os='linux-gnu'
build_vendor='pc'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE}'
dvidir='${docdir}'
exec_prefix='${prefix}'
host='i686-pc-linux-gnu'
host_alias=''
host_cpu='i686'
host_os='linux-gnu'
host_vendor='pc'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='$(SHELL) /home/*****/OpenCPN-OpenCPN-218cc88/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='/usr/local'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define PACKAGE_STRING ""
#define PACKAGE_BUGREPORT ""
#define PACKAGE "opencpn"
#define VERSION "0.1"
#define INSTALL_PREFIX "/usr/local"

configure: exit 
Thank you all for your help
__________________
snicco is offline   Reply With Quote
Old 29-03-2010, 04:15   #26
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
Quote:
configure:5319: g++ -c -Wall -g -fexceptions -fno-stack-protector -I/usr/local/lib/wx/include/x11univ-ansi-release-2.8 -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXUNIVERSAL__ -D__WXX11__ conftest.cpp >&5
conftest
.cpp:12:22: error: wx/setup.h: No such file or directory


This /
usr/local/lib/wx/
is probably remaining from a previous test you did. You should remove it completly.

You may also try:
Code:
$ CPPFLAGS="-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8" ./configure

__________________
SethDart is offline   Reply With Quote
Old 30-03-2010, 15:46   #27
Registered User

Join Date: Mar 2010
Posts: 9
Perseverance furthers! Configuring now sees _WXGTK_ and make completes.
Make install worked and after an embarrassing interval I discovered opencpn hidingin the "other" section of the application menu.
Installing a collection of vector charts has me viewing familiar and foreign waters.
I haven't connected GPS yet (my computer still has a com port), but I'll check it out on the boat today.
The only slight problem I've noticed in running the program is that the print function doesn't seem to create files either for the printer or for .ps or.pdf files.
SethDart thankyou for your patience! Would it be possible for you to give me a brief explanation of:
PHP Code:
CPPFLAGS="-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8" ./configure 
It may help me to help myself in the future.
Congratulations to the opencpn team for putting a powerful maritime safety tool in the reach of everyone.
__________________
snicco is offline   Reply With Quote
Old 31-03-2010, 22:13   #28
Registered User

Join Date: Sep 2007
Location: FL
Boat: Pacific Seacraft 31 - Cielo Azul
Posts: 359
Images: 3
FYI
After some cleanup, I used to the command:
git clone git://github.com/OpenCPN/OpenCPN.git
and was able to compile and run with no problem.
The documented cvs command fails to login (connection
refused).
Tom
__________________
teejayevans is online now   Reply With Quote
Old 01-04-2010, 00:34   #29
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
Quote:
Originally Posted by snicco View Post
Would it be possible for you to give me a brief explanation of:
PHP Code:
CPPFLAGS="-I/usr/lib/wx/include/gtk2-unicode-release-2.8 -I/usr/include/wx-2.8" ./configure 
It may help me to help myself in the future.
This command sets an environment variable CPPFLAGS that tells configure to include these two path while searching for tools, devel headers (this is exactly the purpose here), etc.
__________________
SethDart is offline   Reply With Quote
Old 01-04-2010, 01:34   #30
Senior Cruiser
 
idpnd's Avatar

Cruisers Forum Supporter

Join Date: Sep 2007
Location: Almería, ES
Boat: Chiquita 46 - Libertalia
Posts: 1,551
Quote:
Originally Posted by teejayevans View Post
FYI
After some cleanup, I used to the command:
git clone git://github.com/OpenCPN/OpenCPN.git
and was able to compile and run with no problem.
The documented cvs command fails to login (connection
refused).
Tom
SF.net CVS is down for maintenance
__________________

__________________
sv Libertalia
idpnd is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiling OpenCPN on Fedora 12 inSaNo OpenCPN 9 08-12-2009 05:09



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 06:40.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.