Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 17-09-2015, 13:17   #1
Registered User

Join Date: Dec 2013
Posts: 22
CM 93 Rendering

I thinking of trying to get ride of the gray areas, when
rendering detailed cm93 charts.
Click image for larger version

Name:	Screen_2015-09-16-22-14-27.jpg
Views:	113
Size:	274.1 KB
ID:	109225

Anyone have input on this, where to start looking in code?
OpenGl ,chart ,render mydal ....?
__________________

__________________
curl is offline   Reply With Quote
Old 17-09-2015, 13:24   #2
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: CM 93 Rendering

curl...

Doesn't look right to me...
What version is this, and how to reproduce? Lat/Lon/Scale? cm93 version?

Thanks
Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Old 18-09-2015, 02:57   #3
Registered User

Join Date: Dec 2013
Posts: 22
Re: CM 93 Rendering

Picture showing opencpn_4.1.915.apk

I was more thinking of trying to contribute to Opencpn, by trying to fix it.
I can put up a Flyspray later if that's the way to go.
__________________
curl is offline   Reply With Quote
Old 18-09-2015, 03:02   #4
Registered User

Join Date: Dec 2011
Boat: MC-Tec, Akilaria 950
Posts: 233
Re: CM 93 Rendering

Looks similar to what I found here ...
OpenCPN for Android Beta test 4.1.909

(Post 64)

For me it's clearly related to OpenGL, when switching forth and back (OpenGL on/off).

I don't think it's related to a specific lat/lon, I have it everywhere, since some time with OpenGL on. Can't tell you exactly since when, but after the Android implementation started, I noticed that the current track only shows the "old-track-colour" but not red with OpenGL on.
So I turned OpenGL off at that time ...
And I really noticed it 2 days ago, see above.

My chart set is unchanged ever since I have it.

I run Win7 with onboard intel graphics, VC2013 and wxWidgets 3.02

Thomas
__________________
tom_BigSpeedy is offline   Reply With Quote
Old 18-09-2015, 03:17   #5
Registered User

Join Date: Dec 2013
Posts: 22
Re: CM 93 Rendering

Quote:
Originally Posted by tom_BigSpeedy View Post
Looks similar to what I found here ...
OpenCPN for Android Beta test 4.1.909
Then I think OpenGL is the clue I was looking for, thanks.
Have no problem producing the gray chart as yours on android.
__________________
curl is offline   Reply With Quote
Old 18-09-2015, 08:41   #6
Registered User
 
boat_alexandra's Avatar

Join Date: Aug 2009
Location: chesapeake bay
Boat: bristol 27
Posts: 2,813
Re: CM 93 Rendering

could you try older versions to determine which change caused the problem (ie: git bisect)
__________________
boat_alexandra is offline   Reply With Quote
Old 18-09-2015, 08:56   #7
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: CM 93 Rendering

@Thomas....

I just pushed a fix for the Windows cm93 grey areas to github master.
Root cause: An error in refactoring of options.cpp caused the OpenGL switch change to be unrecognised at the right time, meaning that the OpenGL data structures for the charts were not initialized properly. Clean fix. This will be in the next Beta due early next week.

@curl...
Still cannot reproduce on Android. Can you give me a hint, or some UI actions to show the effect?

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 18-09-2015, 14:59   #8
Registered User

Join Date: Dec 2011
Boat: MC-Tec, Akilaria 950
Posts: 233
Re: CM 93 Rendering

Quote:
Originally Posted by bdbcat View Post
@Thomas....

I just pushed a fix for the Windows cm93 grey areas to github master.
...
Thanks
Dave
Dave,

it fixes my problem on Win7, VC2013.
No more grey charts

Thanks,

Thomas
__________________

__________________
tom_BigSpeedy is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
StatusBar PI - degree rendering error bcn OpenCPN 2 23-01-2015 12:55
rendering glitch.. has anyone seen this? boat_alexandra OpenCPN 0 22-01-2014 22:00
S-57 Rendering Problem twal OpenCPN 5 06-07-2010 14:06
Comparison of Chart Rendering in Various Nav Programs JesperWe Navigation 21 14-02-2010 09:01



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 15:41.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.