Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 17-05-2015, 20:22   #1411
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Re: Beta Test / Technical

Håkan...

I can reproduce your situation for raster cache color troubles.
Solution is clear, I think. I have made a correction for resolve this problem.

Please try building from current github master branch to verify.

Thanks
Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Old 18-05-2015, 00:13   #1412
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 3,905
Re: Beta Test / Technical

Quote:
Originally Posted by rgleason View Post
Will ugrading a Win7 machine with VS2013, most current cmake, poedit, etc + wxwidgets 3.0.2 result in not being able to compile plugins for 3.2.2 or 4.0?

Is there backward compatibility to wxWidgets 3.0.2?

I need to know this before I go willy nilly change stuff.

Thanks.
Rick...
You will migrate to a completely different toolchain and there is no backward binary compatibility between wx3 and wx2.8.
You will NOT be able to build anything compatible with OpenCPN 3.2 and 4.0 after you switch to it.

Pavel
__________________

__________________
nohal is online now   Reply With Quote
Old 18-05-2015, 01:10   #1413
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,645
Re: Beta Test / Technical

Quote:
Originally Posted by bdbcat View Post
Håkan...

I can reproduce your situation for raster cache color troubles.
Solution is clear, I think. I have made a correction for resolve this problem.

Please try building from current github master branch to verify.

Thanks
Dave
Dave...
Tested and now it's mostly solved.
If I delete the old cache and let OCPN build the new cache by moving and zooming around all colors are fine. Then I can switch between vector and raster and transverse Merc./ normal Merc. and the colors are still fine.

Though, if I let the tools function "recreate cache" (or how it's named in English) build the new cache the bad colors are partly there again. At least for some transverse M charts. This is repeatable for this chart: https://dl.dropboxusercontent.com/u/...4/hg932-02.kap

Thanks
Håkan
__________________
Hakan is offline   Reply With Quote
Old 20-05-2015, 00:35   #1414
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,645
Re: Beta Test / Technical

OCPN 4.1.427, recent code, Win XP/7, both vector and raster charts, all different boat symbols, with or without OpenGl.

When I move the chart so the boat is outside canvas the heading and COG lines disappears even if the length of the lines should have reached in to the viewed part.
I suppose this is not intentional, in 4.0 the lines are still drawn.
Håkan
__________________
Hakan is offline   Reply With Quote
Old 20-05-2015, 11:16   #1415
Registered User

Join Date: Sep 2012
Location: Baikal
Posts: 239
Re: Beta Test / Technical

Particle map in grib plugin do not work OCPN 4.1.427
__________________
Baikal is offline   Reply With Quote
Old 20-05-2015, 11:58   #1416
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,125
Re: Beta Test / Technical

Quote:
Originally Posted by Baikal View Post
Particle map in grib plugin do not work OCPN 4.1.427
I have no such problem on Linux.
/Thomas
__________________
cagney is offline   Reply With Quote
Old 21-05-2015, 04:33   #1417
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,645
Re: Beta Test / Technical

Win XP. O: 4.1.427 recent code.
Anyone aware of this, for me new, logfile message:"Warning: iCCP: known incorrect sRGB profile"?

Extract from my logfile:
Code:
12:27:49: OpenGL-> Texture rectangle format: 0
12:27:49: OpenGL-> glGenerateMipmap unavailable
12:27:49: OpenGL-> Using Vertexbuffer Objects
12:27:49: OpenGL-> Framebuffer Objects unavailable
12:27:49: OpenGL-> Using Stencil buffer clipping
12:27:49: OpenGL-> Using s3tc dxt1 compression
12:27:49: OpenGL-> Compressed tile size: 128kb (6:1)
12:27:49: OpenGL-> Minimum cartographic line width:  1.0
12:27:49: OpenGL-> Minimum symbol line width:  1.0
12:27:49: Warning: iCCP: known incorrect sRGB profile
12:27:50: Warning: Color not found CHDRD
12:27:50: Loading navobjects from navobj.xml
12:27:50: Done loading navobjects
Håkan
__________________
Hakan is offline   Reply With Quote
Old 21-05-2015, 05:07   #1418
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,645
Re: Beta Test / Technical

The two files: "dbghelp.dll" and "ocpn_gltest1.exe " called for in CmakeList are no longer included in github.com/OpenCPN/OpenCPN master. Is there a reason or is it just me talking trough my hat?

CmakeList.txt: 1576
Code:
INSTALL(FILES ${CMAKE_SOURCE_DIR}/buildwin/crashrpt/dbghelp.dll DESTINATION ${PREFIX_PKGDATA} PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
INSTALL(FILES ${CMAKE_SOURCE_DIR}/buildwin/crashrpt/PrivacyPolicy.txt DESTINATION ${PREFIX_PKGDATA} PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
INSTALL(FILES ${CMAKE_SOURCE_DIR}/buildwin/ocpn_gltest1.exe DESTINATION ${PREFIX_PKGDATA} PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
Håkan
__________________
Hakan is offline   Reply With Quote
Old 21-05-2015, 05:12   #1419
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Westerly Pentland
Posts: 1,515
Re: Beta Test / Technical

Quote:
Originally Posted by Hakan View Post
Win XP. O: 4.1.427 recent code.
Anyone aware of this, for me new, logfile message:"Warning: iCCP: known incorrect sRGB profile"?

Extract from my logfile:
Code:
12:27:49: OpenGL-> Texture rectangle format: 0
12:27:49: OpenGL-> glGenerateMipmap unavailable
12:27:49: OpenGL-> Using Vertexbuffer Objects
12:27:49: OpenGL-> Framebuffer Objects unavailable
12:27:49: OpenGL-> Using Stencil buffer clipping
12:27:49: OpenGL-> Using s3tc dxt1 compression
12:27:49: OpenGL-> Compressed tile size: 128kb (6:1)
12:27:49: OpenGL-> Minimum cartographic line width:  1.0
12:27:49: OpenGL-> Minimum symbol line width:  1.0
12:27:49: Warning: iCCP: known incorrect sRGB profile
12:27:50: Warning: Color not found CHDRD
12:27:50: Loading navobjects from navobj.xml
12:27:50: Done loading navobjects
Håkan
Look here: Free OpenCPN Icons

After finally switching to wxWidgets 3.0 which uses a newer png lib old png files with embedded old iCCP profiles popups this message. Solution is to strip any such profile informations from png files.

Gerhard
__________________
CarCode is online now   Reply With Quote
Old 21-05-2015, 05:35   #1420
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,645
Re: Beta Test / Technical

Gerhard...
Thanks for the tip. I could maybe fix that for user icons if I find a suitable function for that to use in Windows.
But... I first suspected icons for being the source so I took away the "UserIcons" folder and then a mass of iCCP message disappeared but there's still one left. And there's around 800 png files in the OpenCPN directory, so it's not easy to find the source??
And... The referred method seems like huge workaround for something that may be solved in a more systematic way. When implementing wx3.0 in a stable O version this would else lead to user troubles?

Håkan
__________________
Hakan is offline   Reply With Quote
Old 21-05-2015, 06:19   #1421
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Westerly Pentland
Posts: 1,515
Re: Beta Test / Technical

Håkan,
I have had a discussion with the wxWidgets developers years ago when this problem first comes up. There is no other way as to clean the affected png files to get rid of these warnings. However it is harmless to use such old png files further on if you don't care about the messages.
The needed cleaning tools are avalable for any OS.

Gerhard
__________________
CarCode is online now   Reply With Quote
Old 21-05-2015, 06:35   #1422
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Re: Beta Test / Technical

Hakan...

Please note the build instructions for Windows has changed slightly. You will need to download the required binary data blobs as described.

Compiling - Windows | Official OpenCPN Homepage

Section 3.1

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 21-05-2015, 06:45   #1423
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 7,649
Re: Beta Test / Technical

Found out ocpn_draw enabled was causing v4.1.427 instant crash, disable it and opencpn 4.1.427 loads ok using v4.0 opencpn.ini. So I don't believe dedicated opencpn.ini for the two versions is needed.
Ocpn_draw failing on changes in log file

Sent from my SCH-I545 using Cruisers Sailing Forum mobile app
__________________
rgleason is offline   Reply With Quote
Old 21-05-2015, 07:08   #1424
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,645
Re: Beta Test / Technical

Quote:
Originally Posted by bdbcat View Post
Hakan...

Please note the build instructions for Windows has changed slightly. You will need to download the required binary data blobs as described.

Compiling - Windows | Official OpenCPN Homepage

Section 3.1

Thanks
Dave
Dave... Yes, I've downloaded the update before but didn't remember these files where included there.
I've also used the wx3.0 compiling for some weeks but today these files where missing for any reason I can't understand. Since I didn't remembered where the files originated I got the idea that a git master fetch was involved in some way.
Well... Newer mind - now solved and thanks for the reminder.
Håkan
__________________
Hakan is offline   Reply With Quote
Old 21-05-2015, 07:13   #1425
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Re: Beta Test / Technical

Rick...

re:
Code:
Found out ocpn_draw enabled was causing v4.1.427 instant crash, disable it and opencpn 4.1.427 loads ok using v4.0 opencpn.ini. So I don't believe dedicated opencpn.ini for the two versions is needed.
Ocpn_draw failing on changes in log file
Need more info, please. Where does ocpn_draw fail?

Thanks
Dave
__________________

__________________
bdbcat is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta Marine Diesel michaelmrc Engines and Propulsion Systems 48 23-03-2016 14:44
Need some technical advice....antennas. Just a Tinch Marine Electronics 15 01-12-2007 16:57
Blue Sea Systems Technical Brief GordMay Electrical: Batteries, Generators & Solar 0 16-03-2007 05:16
technical difficulties witchcraft The Sailor's Confessional 1 30-05-2005 15:09
Dow Corning Technical Manual GordMay The Library 0 12-04-2005 17:25


Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 12:22.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.