Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 28-03-2012, 18:55   #811
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,371
Re: Beta Test / Technical

...humour me a little further? ... if you close the toolbox and immediately use the keyboard's +, -, arrow keys, F6, etc, and whatever, they work....?
__________________

__________________
HappySeagull is offline   Reply With Quote
Old 28-03-2012, 19:14   #812
Registered User
 
Viking Sailor's Avatar

Join Date: Nov 2006
Location: San Francisco Bay
Boat: Fantasia 35 - s/v Feeling Good
Posts: 983
Re: Beta Test / Technical

Happy, I can confirm your results on XP.

__________________

__________________
Viking Sailor is offline   Reply With Quote
Old 29-03-2012, 00:36   #813
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,231
Re: Beta Test / Technical

Well in my case the shortcuts from keyboard work after leaving the toolbox (ok or cancel).
2.5 under XP and W7.

Hubert
__________________
bcn is offline   Reply With Quote
Old 29-03-2012, 09:21   #814
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,231
Re: Beta Test / Technical

And 2.6 on W7 is working ok as well with the short cuts after leaving the tools.

Hubert
__________________
bcn is offline   Reply With Quote
Old 29-03-2012, 09:47   #815
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,371
Re: Beta Test / Technical

Thanks, bcn.
.. an XP quirk but I think I've found the best solution.

Right-Click (mouse) +Esc.
will refocus and consequent keyboard shortcuts work.

Also,this allows Autofollow to remain engaged ...and the chart stays as it was before I opened the toolbox...
__________________
HappySeagull is offline   Reply With Quote
Old 29-03-2012, 12:58   #816
Registered User
 
Viking Sailor's Avatar

Join Date: Nov 2006
Location: San Francisco Bay
Boat: Fantasia 35 - s/v Feeling Good
Posts: 983
Re: Beta Test / Technical

Happy,

It seems that the loss of focus on XP is a new "feature" in the 2.6.xxxx releases. I installed the 2.3.1 version and the focus returned to the chart window after closing the tool box. This is not a big deal but it is a minor bug and a curiosity.

__________________
Viking Sailor is offline   Reply With Quote
Old 29-03-2012, 19:33   #817
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,371
Re: Beta Test / Technical

Thanks Viking! That will save me from (ahem) trying to "fix" it !

- good idea trying earlier versions!
__________________
HappySeagull is offline   Reply With Quote
Old 01-04-2012, 18:11   #818
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Re: Beta Test / Technical

Happy....

I found that on XP, if the toolbar intersects the opened toolbox rectangle, then focus is lost on closure of the toolbox.

However, if the toolbar does not intersect the open toolbox rectangle (i.e. the toolbar is docked on the left side vertically, say), then all is well.

Is this your observation as well?

I can fix this for the next Beta.

Do you still have the problem of lost focus after restore from minimized in XP taskbar?

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 01-04-2012, 20:17   #819
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,371
Re: Beta Test / Technical

Dave, the side-docked toolbar is a fix! Too-cool,man!

From a minimised-to-taskbar, O comes up focussed just fine with Alt+Tab or mouse click.



clucking on, in case it's mildly useful... with the toolbar across the top, on a 1024x780 screen, the toolbox always covers where the toolbar would be if it hadn't disappeared whenever the toolbox is opened. Resizing the toolbox dialogue window makes no diff. I suppose the GUI -ram damage has already been done,eh ?
.. if a fix is a pain, we x-pee'ers will probably dry up soon anyways.
__________________
HappySeagull is offline   Reply With Quote
Old 01-04-2012, 20:37   #820
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Re: Beta Test / Technical

Happy...

Thanks for the test.

Top toolbar fix is no pain. Simple one-liner, which you shall see in the next Beta.

And I hope x-pee'ers will stick around at least until Win20.
Better the beast we know and love....

Dave
__________________
bdbcat is offline   Reply With Quote
Old 02-04-2012, 18:13   #821
Registered User
 
LeaseOnLife's Avatar

Join Date: Apr 2008
Location: Around once, back to work, for a while :-(
Boat: Sailboat
Posts: 966
Re: Beta Test / Technical

Quote:
Originally Posted by bdbcat View Post
....

And I hope x-pee'ers will stick around at least until Win20.
Better the beast we know and love....

Dave
I am probably one of 'em, can't get a wddm driver for my mobility radeon 9000 for >=windows 7. And no, Vista is not an option, reminds me of ME.

Can't wait for the next beta.

Cheers and Thanks

Dirk
__________________
LeaseOnLife is online now   Reply With Quote
Old 11-04-2012, 14:55   #822
Registered User

Join Date: Apr 2012
Posts: 8
Re: Beta Test / Technical

Well hello,

actually I shall develope a plug-in. But I'm not able to compile OpenCPN, because of several failures, which I don't want to mention now. I know, that opencpn.lib is necessary to build plugins. So my simple question is, whether someone can please upload or send me this file, so that I can work.
Would this be possible?
Thank you!

Best regards,
Philipp
__________________
Trip2k is offline   Reply With Quote
Old 22-04-2012, 02:41   #823
Registered User

Join Date: Apr 2012
Posts: 2
Re: Beta Test / Technical

Hello,
I hope for your help.
If I try to generate beta 2.6.1609 with CMake I got:
Could NOT find wxWidgets (missing: wxWidgets_FOUND)
Settings are:
mswud
C:/wxWidgets-2.8.12/lib/vc_dll
C:/wxWidgets-2.8.12
If I set:
C:/wxWidgets-2.8.12/lib/vc_lib
It will generate but I got several hundred error while compiling with Visual Studio 10 on Win7 64
In the past with Settings:
C:/wxWidgets-2.8.12/lib/vc_dll
everything was working well with Version 2.5.
What do I wrong here?

Best regards
Werner
__________________
wkmhv is offline   Reply With Quote
Old 22-04-2012, 02:49   #824
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 3,903
Re: Beta Test / Technical

Werner...
There are some changes in the build process in the 2.6 series, so if you didn't, please follow the steps in Compiling - Windows | Official OpenCPN Homepage exactly and your build should be smooth (I don't have any 64-bit Windoze machine to test, but there shouldn't be a problem).
If you will still get errors, post their exact text.

Pavel
__________________
nohal is online now   Reply With Quote
Old 22-04-2012, 04:26   #825
Registered User

Join Date: Apr 2012
Posts: 2
Re: Beta Test / Technical

Hello Pavel,
I think I have follow the steps in Compiling - Windows | Official OpenCPN Homepage exactly(I hope ).
The error is already in here:
Could NOT find wxWidgets (missing: wxWidgets_FOUND)
Settings are:
mswud
C:/wxWidgets-2.8.12/lib/vc_dll
C:/wxWidgets-2.8.12

i386
*** Staging to build opencpn 2.6.1609 ***
Found OpenGL...
Lib: glu32opengl32
Include:
CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
Could NOT find wxWidgets (missing: wxWidgets_FOUND)
Call Stack (most recent call first):
C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindwxWidgets.cmake:831 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
CMakeLists.txt:128 (FIND_PACKAGE)


Configuring incomplete, errors occurred!

Acording the manual this Settings are OK?
__________________

__________________
wkmhv is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta Marine Diesel michaelmrc Engines and Propulsion Systems 48 23-03-2016 14:44
Need some technical advice....antennas. Just a Tinch Marine Electronics 15 01-12-2007 16:57
Blue Sea Systems Technical Brief GordMay Electrical: Batteries, Generators & Solar 0 16-03-2007 05:16
technical difficulties witchcraft The Sailor's Confessional 1 30-05-2005 15:09
Dow Corning Technical Manual GordMay The Library 0 12-04-2005 17:25


Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 17:50.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.