Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 16-01-2019, 15:53   #2281
Registered User

Join Date: Feb 2011
Posts: 568
Re: Beta Test / Technical

I have a problem with the Newfoundland (Canada) tide stations. In Wtides they works correctly, but in OpenCpn they indicate 02:30 instead of 03:30.
The NewFoudland stardard time is 03:30 (NST).
Harmonic file:-
# ST JOHN'S_00905, Newfoundland 47d33.4'N 52d42.6'W
# METERS
# CHS DATA, TZ+03:30
# (ANALYSIS (7.9 YEARS) Chart Datum)
# !units: meters
# !longitude: -52.710134
# !latitude: 47.556022
ST JOHN'S, Newfoundland
-03:30 :America/St_Johns
0.8530 meters
J1 0.0044 97.04

Harmonic file.idx
TNAN:Can:NewF: -52.7101 47.5560 -3:30 ST JOHN'S, Newfoundland

Can you help to sort it out?
__________________

P_Dub is offline   Reply With Quote
Old 16-01-2019, 18:28   #2282
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 12,043
Re: Beta Test / Technical

I am going to use the Chartdownloader option everywhere.



Quote:
Originally Posted by rgleason View Post
In the wiki, when gshhs high res is needed, should we be linking to

https://launchpad.net/~opencpn/+arch....4.orig.tar.xz

or should we simply suggest to use ChartDownloader and to ADD the predefined basemap "GSHHG basemap" and to select "All GSHHG Basemaps"?


I would like to make the link consistent.
__________________

rgleason is offline   Reply With Quote
Old 17-01-2019, 06:05   #2283
Registered User

Join Date: Mar 2010
Location: QC, Canada
Boat: Kelt 8.50
Posts: 90
Re: Beta Test / Technical

Quote:
Originally Posted by P_Dub View Post
I have a problem with the Newfoundland (Canada) tide stations. In Wtides they works correctly, but in OpenCpn they indicate 02:30 instead of 03:30.
The NewFoudland stardard time is 03:30 (NST).
Can you help to sort it out?

There is a bug report on that problem. I has been corrected in a future version.


Jean-Marie
houlejm is offline   Reply With Quote
Old 17-01-2019, 08:36   #2284
Registered User

Join Date: Feb 2011
Posts: 568
Re: Beta Test / Technical

Who did confirm you the correction?
Also, what about the fact that many country do not keep Daylight saving times anymore, but the system keep on showing it!
Best Regards.
P_Dub is offline   Reply With Quote
Old 18-01-2019, 05:53   #2285
Registered User

Join Date: Mar 2010
Location: QC, Canada
Boat: Kelt 8.50
Posts: 90
Re: Beta Test / Technical

Quote:
Originally Posted by P_Dub View Post
Who did confirm you the correction?
I saw it on GitHub. I compiled to test and it was fixed.

Quote:
Originally Posted by P_Dub View Post
Also, what about the fact that many country do not keep Daylight saving times anymore, but the system keep on showing it!
Best Regards.
I do not know. I never used tides and currents in such a place, but I suppose it uses TZ info from the system. An up to date system will be correct.


JM
houlejm is offline   Reply With Quote
Old 18-01-2019, 05:58   #2286
Registered User

Join Date: Feb 2011
Posts: 568
Re: Beta Test / Technical

Thank you so much, at last it will done.
Have a good day.
P_Dub is offline   Reply With Quote
Old 30-01-2019, 16:39   #2287
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 12,043
Plugins converting to and using API 1.16

I notice that IACFLEET_pi
https://github.com/nohal/iacfleet_pi
by Pavel has an "include"


Switch to API 1.16 and render overlay only on the last canvas

notice, which is hugely helpful to those compiling plugins.

Is there some way to ensure that this notice is present in all plugins that are using API 1.16!

And can this notice be made easy to find?

Also, should we be converting over to wxWidgets 3.1.1 and set our plugin compile environment to the new API 1.16 now?

(I will keep one computer with the old environment for awhile.)

If so, I will move on to the new environment and stop compiling for v4.2.0 -4.8.8 unless there is a good reason to update a plugin.


Also does the new environment require changes and updates to most plugins for the new API 1.16, the MUI, etc? And does use of wxWidgets 3.1.1 require changes to some code in the Plugins due to deprecated calls, etc.?
rgleason is offline   Reply With Quote
Old 30-01-2019, 16:49   #2288
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,745
Re: Beta Test / Technical

Rick...

Most of all you should wait.

Pavel
nohal is offline   Reply With Quote
Old 31-01-2019, 07:00   #2289
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 12,043
Re: Beta Test / Technical

Ok, I'll wait.
rgleason is offline   Reply With Quote
Old 02-02-2019, 10:03   #2290
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 12,043
Re: Beta Test / Technical

I seem to always be behind. Is 4.99 -5.0 using wxWidgets v3.1.1 or v3.1.2?
Jon Gough seems to be using the later for Ocpn_draw. Does it matter?


Also I don't have the 4.99 -5.0 Development Environment on this tablet, so I can't compile, and I've found apveyor is now configured to not compile for windows so there is no install available there.


So where do I go to get the one we should be using? I suppose I could configure my Opencpn branch to run apveyor, but that seems a bit fruitless.


Is this ruthless linux channeling?
rgleason is offline   Reply With Quote
Old 02-02-2019, 11:54   #2291
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,186
Re: Beta Test / Technical

v.3.1.2 for 4.99/5.0
bcn is offline   Reply With Quote
Old 03-02-2019, 00:46   #2292
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,290
Re: Beta Test / Technical

Quote:
Originally Posted by rgleason View Post
...................
So where do I go to get the one we should be using? .....
This is up to date for V5:
https://opencpn.org/wiki/dokuwiki/do...piling_windows
The linked wx 3.1.2 is already built. When I run the build for release by the commands noted there by nohal nothing was added but the same for debug added some more but if needed or not I don't know.

Håkan
Hakan is offline   Reply With Quote
Old 03-02-2019, 13:42   #2293
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,745
Re: Beta Test / Technical

Quote:
Originally Posted by rgleason View Post
I seem to always be behind. Is 4.99 -5.0 using wxWidgets v3.1.1 or v3.1.2?
Jon Gough seems to be using the later for Ocpn_draw. Does it matter?


Also I don't have the 4.99 -5.0 Development Environment on this tablet, so I can't compile, and I've found apveyor is now configured to not compile for windows so there is no install available there.


So where do I go to get the one we should be using? I suppose I could configure my Opencpn branch to run apveyor, but that seems a bit fruitless.


Is this ruthless linux channeling?
Rick...

First of all, you don't have to build anything yourself at all.

Each and every commit to OpenCPN is built automatically at appveyor and you can download the binary from there.

All the documentation was updated with the correct links once we switched to wx3.1.2, so if you still for some reason must, just follow the documentation.

The plugins will follow as soon as we have time for them, where the developer himself has not already done it.

Pavel
nohal is offline   Reply With Quote
Old 09-02-2019, 05:50   #2294
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 12,043
Re: Beta Test / Technical

Thanks Paval, ...all squared away now.



I have just one ridiculous question about compiling standalone plugins, which is probably quite impossible. Can version 4.99-5.00 plugins be made by using my old standalone plugin compile setup, but using the new opencpn.lib for version 4.99-5.00 which is about 145kb?


Answer:
Quote:
C:\Users\..\GitHub\weather_routing_pi\build>cmake -T v12-_xp ..
CMake Error: Error: generator toolset: v12-_xp
Does not match the toolset used previously: v120_xp
Either remove the CMakeCache.txt file and CMakeFiles directory or choose a different binary directory.
It does not work. You need the fresh new compile dev environment as per Hakan and Pavel
Quote:
This is up to date for V5:
https://opencpn.org/wiki/dokuwiki/do...piling_windows
rgleason is offline   Reply With Quote
Old 09-02-2019, 05:54   #2295
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,745
Re: Beta Test / Technical

It is not possible. (What you posted is a simple typo, the real reasons are completely different, but it is not possible)
Again, you don't have to compile anything yourself - in fraction of the time you will burn on getting it done, every single plugin may have automatic builds on Appveyor running.
__________________

nohal is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta Marine Diesel michaelmrc Engines and Propulsion Systems 48 23-03-2016 14:44
Need some technical advice....antennas. Just a Tinch Marine Electronics 15 01-12-2007 16:57
Blue Sea Systems Technical Brief GordMay Electrical: Batteries, Generators & Solar 0 16-03-2007 05:16
technical difficulties witchcraft The Sailor's Confessional 1 30-05-2005 15:09
Dow Corning Technical Manual GordMay The Library 0 12-04-2005 17:25



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:22.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.