Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-06-2012, 19:24   #46
Registered User

Join Date: Jun 2007
Location: SW Florida
Boat: FP Belize, 43' - Dot Dun
Posts: 3,425
Re: Autopilot Track Following

Quote:
Originally Posted by George64 View Post
Just modified the ini-file and added


Checking the nmea sentences using the vdr-plugin, I did not get a --RMC sentence. I also tried by entering the sentence under the Autopilot section. No luck either.

Thanks in advance for your help!
What are you trying to do? Is your GPS outputting RMC?
__________________

__________________
DotDun is offline   Reply With Quote
Old 22-06-2012, 03:30   #47
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot Track Following

I was trying to achive to get the route info on my autopilot and Clipper GPS repeater.

After going through the logfile, I found out that the comm port for th AP fails to open:
Quote:
10:59:03: Setting Viewpoint Lat/Lon 51.4994, 1.9496
10:59:03: Setting Ownship Lat/Lon 51.3277, 1.4203
10:59:03: NMEA Data Source is....Serial:AIS Port (Shared)
10:59:03: AIS Data Source is....Serial:COM9
10:59:03: Using WVSChart datafile: C:\Program Files (x86)\OpenCPN\wvsdata\wvs43.dat
10:59:03: NMEA AutoPilot Port is....Serial:COM9
10:59:03: Autopilot output device open failed: COM9
I started a new post on this one.
__________________

__________________
George64 is offline   Reply With Quote
Old 08-10-2012, 19:24   #48
Registered User

Join Date: Jul 2009
Location: Washington, DC
Boat: Custom Gaff Ketch, Dory hulled, 26' LOD, 33' LOA
Posts: 13
Images: 1
Re: Autopilot Track Following

Sorry to resurrect an old post, but I too am struggling with the AP integration on OpenCPN. My autopilot is a NavMan G-Pilot 3100. It is pretty new, only 4-5 years old. I checked the manual and it says under the section on following a GPS course: "XTE (from APA, APB or XTE sentences) is required for the G-PILOT to use GPS mode".

I have tried to contact the current owners of the G-Pilot line and their take is that this is old hardware that they are no longer going to support.

So I'm going to need to provide one of those inputs; APa, APB or XTE. While I am reasonably computer savvy and can probably download the open source code and program it eventually, I am current underway to a big Schooner Race and cant do the work on this tablet!!

Any ideas of how I might get the autopilot and OpenCPN playing nice?

Paul
__________________
Paul_Carroll is offline   Reply With Quote
Old 08-10-2012, 21:23   #49
Registered User

Join Date: Jul 2011
Posts: 104
Re: Autopilot Track Following

no need to compile from source anything, OCPN will provide Autopilot sentence A and B in its RMB and RMC NMEA streams. first please make sure you hardware is correctly connected, most problems occur at this level. if you are not sure, provide an image or capture from the Gpilot 3100 connection manual section, so I can sort it out. also provide data on OS version , and how are you doing the physical link. most raymarine pilots work under this same requirements and I make them work every time I install one.
__________________
alex2035 is offline   Reply With Quote
Old 10-10-2012, 04:03   #50
Registered User

Join Date: Aug 2010
Location: Oz
Boat: EX prawn trawler 14m
Posts: 100
Re: Autopilot Track Following

I had the same problem trying to get RMB & RMC to run AP.
Mine (TMQ AP4) also requires APA or APB.
So I sat down and bastardized OPEN2.5.0 to suit my needs. (Windoz XP OS)
I really think this would be better served as a plugin as my less than handywork cannot be used on any upgraded versions of OPEN.(time has not allowed me to pursue this avenue)

The reason for my reply is to let you know that while connected to the RMB/C sentences nothing was happening yet as soon as I rejigered OPEN to output A&B sentences the AP drove the boat perfectly using the very same physical connection.

Whilst I was at it I also allowed BWC GLL VTG to output as well, these all give my radar navigational status, however bearing and distances need leading 0's as 39.0 NM is seen as 390 NM and 27.1 deg is seen as 271deg.(still more time needed)

Hence you can see what I did is far from being reliable enough to put out to the public.
But it works for me.

Thanks to all who have input to this wonderful program, I appreciate everyones time is precious.
__________________
redog is offline   Reply With Quote
Old 10-10-2012, 08:23   #51
GWB
Registered User

Join Date: Sep 2008
Location: Brookings, Oregon
Boat: Westsail 32
Posts: 296
Images: 1
Re: Autopilot Track Following

Quote:
Originally Posted by redog View Post
I had the same problem trying to get RMB & RMC to run AP.
Mine (TMQ AP4) also requires APA or APB.
So I sat down and bastardized OPEN2.5.0 to suit my needs. (Windoz XP OS)
I really think this would be better served as a plugin as my less than handywork cannot be used on any upgraded versions of OPEN.(time has not allowed me to pursue this avenue)

The reason for my reply is to let you know that while connected to the RMB/C sentences nothing was happening yet as soon as I rejigered OPEN to output A&B sentences the AP drove the boat perfectly using the very same physical connection.

Whilst I was at it I also allowed BWC GLL VTG to output as well, these all give my radar navigational status, however bearing and distances need leading 0's as 39.0 NM is seen as 390 NM and 27.1 deg is seen as 271deg.(still more time needed)

Hence you can see what I did is far from being reliable enough to put out to the public.
But it works for me.

Thanks to all who have input to this wonderful program, I appreciate everyones time is precious.
Redog, any chance you could post what the procedure was? I have done some machine programming and am reasonably confident that I could do what is needed with some guidance. Thanks for any help!
__________________

__________________
GWB is offline   Reply With Quote
Reply

Tags
autopilot

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beneteau Autopilot Failure pwhitburn Meets & Greets 18 18-04-2014 09:54
Want To Buy: Used Raymarine Autopilot (Complete System) mary buck Classifieds Archive 10 28-09-2011 14:56
Sending 'Go to Here' Active Route to an Autopilot Sail323 OpenCPN 11 01-08-2011 16:44
Creating Track / Route from Waypoints in OpenCPN sinbad7 OpenCPN 7 23-07-2011 09:15
Route Properties, Missing Functions James Baines OpenCPN 13 13-07-2011 05:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:47.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.