Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 22-06-2012, 03:23   #1
Registered User

Join Date: Aug 2010
Posts: 297
Autopilot Output Device Open Failed

Hi,

I was wondering why I did not get any route info on my Clipper GPS repeater. I went through the logfile and found that error message.

My setup:
- laptop running Windows 7
- OpenCPN 3.0
- USB connection to mulitplexer (38400bps)
- Multiplexer to Clipper GPS (and Autopilot) @ 4800bps

Attached the log file. Please rename to proper extension (.txt or so)

A part from the file:
Quote:
10:58:56: 2012-06-22
10:58:56: -------Starting opencpn-------
10:58:56: Version 2.5.0 Build 2011-07-26
10:58:56: MemoryStatus: mem_total: 8139 mb, mem_initial: 10 mb
10:58:56: SData_Locn is C:\Program Files (x86)\OpenCPN\
10:58:56: Using existing Config_File: C:\ProgramData\opencpn\opencpn.ini
10:58:56: Setting Viewpoint Lat/Lon 51.4994, 1.9496
10:58:56: Setting Ownship Lat/Lon 51.3277, 1.4203
10:59:03: System default Language: nl_NL
10:59:03: Opencpn language set to: nl_NL
10:59:03: Using s57data in C:\Program Files (x86)\OpenCPN\s57data
10:59:03: Using Tide/Current data from: C:\Program Files (x86)\OpenCPN\tcdata\
10:59:03: Setting Viewpoint Lat/Lon 51.4994, 1.9496
10:59:03: Setting Ownship Lat/Lon 51.3277, 1.4203
10:59:03: NMEA Data Source is....Serial:AIS Port (Shared)
10:59:03: AIS Data Source is....Serial:COM9
10:59:03: Using WVSChart datafile: C:\Program Files (x86)\OpenCPN\wvsdata\wvs43.dat
10:59:03: NMEA AutoPilot Port is....Serial:COM9
10:59:03: Autopilot output device open failed: COM9
10:59:03: PlugInManager searching for PlugIns in location C:\Program Files (x86)\OpenCPN\plugins
10:59:03: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/dashboard_pi.dll
10:59:03: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/findit_pi.dll
10:59:03: Error: Failed to load shared library 'C:\Program Files (x86)\OpenCPN\plugins/findit_pi.dll' (error 127: kan opgegeven procedure niet vinden.)
10:59:03: PlugInManager: Cannot load library: C:\Program Files (x86)\OpenCPN\plugins/findit_pi.dll
10:59:03: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/gecomapi_win32_pi15_v08_pi.dll
10:59:03: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/grib_pi.dll
10:59:03: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/logbookkonni_pi.dll
10:59:03: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/vdr_pi.dll
10:59:03: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/wmm_win32_pi15_v03_pi.dll
10:59:03: Warning: WMM model data file C:\Program Files (x86)\OpenCPN/plugins/WMM.COF can't be loaded, using the bundled data.
10:59:03: ChartDB Cache policy: Application target is 4069 MBytes
10:59:03: Loading chart db version: V016
10:59:03: Chartdb: Chart directory list follows
10:59:03: Chart directory #0: C:\Users\Gregor\Documents\CM93
10:59:03: GPS Watchdog Timeout is: 6 sec.
10:59:03: Initializing Chart C:\Users\Gregor\Documents\CM93\00300000\A\00300000 .A
10:59:03: CM93Composite Chart Root is C:\Users\Gregor\Documents\CM93\
10:59:03: Loaded CM93 Dictionary from C:\Users\Gregor\Documents\CM93\
10:59:03: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/C/04140000.C
10:59:07: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/C/04260000.C
10:59:26: EnumerateSerialPorts() Found Garmin USB Driver.
10:59:34: PlugInManager: Deactivating PlugIn: C:\Program Files (x86)\OpenCPN\plugins/dashboard_pi.dll
10:59:34: PlugInManager: Deactivating PlugIn: C:\Program Files (x86)\OpenCPN\plugins/gecomapi_win32_pi15_v08_pi.dll
10:59:34: PlugInManager: Deactivating PlugIn: C:\Program Files (x86)\OpenCPN\plugins/grib_pi.dll
10:59:34: PlugInManager: Deactivating PlugIn: C:\Program Files (x86)\OpenCPN\plugins/logbookkonni_pi.dll
10:59:34: PlugInManager: Deactivating PlugIn: C:\Program Files (x86)\OpenCPN\plugins/vdr_pi.dll
10:59:34: PlugInManager: Deactivating PlugIn: C:\Program Files (x86)\OpenCPN\plugins/wmm_win32_pi15_v03_pi.dll
10:59:34: opencpn::MyFrame exiting cleanly.
10:59:37: PlugInManager: UnLoading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/dashboard_pi.dll
10:59:37: PlugInManager: UnLoading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/gecomapi_win32_pi15_v08_pi.dll
10:59:37: PlugInManager: UnLoading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/grib_pi.dll
10:59:37: PlugInManager: UnLoading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/logbookkonni_pi.dll
10:59:37: PlugInManager: UnLoading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/vdr_pi.dll
10:59:37: PlugInManager: UnLoading PlugIn: C:\Program Files (x86)\OpenCPN\plugins/wmm_win32_pi15_v03_pi.dll
10:59:37: Stopping AIS Secondary Thread
10:59:38: Stopped in 1 sec.
10:59:38: LOGBOOK: 2012-06-22 08:59:38 UTC OFF: Lat 51.32772 Lon 1.42030 COG 11.00000 SOG 0.10
10:59:38: opencpn::MyApp exiting cleanly...
There is a plugin error too, however I don't mind that for now

Any help is highly appreciated because route information is not available at the helm, which is not very handy

Many thanks!!
Attached Files
File Type: doc opencpn.doc (8.8 KB, 41 views)
__________________

__________________
George64 is offline   Reply With Quote
Old 22-06-2012, 05:35   #2
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

Just checked, and saw the logfile refers to 2.5.5 instead of 3.0.0 However, the error is the same. Sorry for being not clear at first stage.

Quote:
13:40:47:


13:40:47: 2012-06-22
13:40:47: -------Starting opencpn-------
13:40:47: Version 3.0.0 Build 2012-06-03
13:40:47: MemoryStatus: mem_total: 8139 mb, mem_initial: 8 mb
13:40:47: SData_Locn is C:\Program Files (x86)\OpenCPN 3.0.0\
13:40:47: Using existing Config_File: C:\ProgramData\opencpn\opencpn.ini
13:40:47: Setting Viewpoint Lat/Lon 51.3619, 1.3253
13:40:47: Setting Ownship Lat/Lon 51.3277, 1.4203
13:40:49: System default Language: nl_NL
13:40:49: Opencpn language set to: nl_NL
13:40:50: ChartSymbols loaded from C:\Program Files (x86)\OpenCPN 3.0.0\s57data\chartsymbols.xml
13:40:50: Using s57data in C:\Program Files (x86)\OpenCPN 3.0.0\s57data
13:40:50: Setting Viewpoint Lat/Lon 51.3619, 1.3253
13:40:50: Setting Ownship Lat/Lon 51.3277, 1.4203
13:40:50: NMEA Data Source is....Serial:AIS Port (Shared)
13:40:50: AIS Data Source is....Serial:COM9
13:40:50: Using WVSChart datafile: C:\Program Files (x86)\OpenCPN 3.0.0\wvsdata\wvs43.dat
13:40:50: NMEA AutoPilot Port is....Serial:COM9
13:40:50: Autopilot output device open failed: COM9
13:40:50: PlugInManager searching for PlugIns in location C:\Program Files (x86)\OpenCPN 3.0.0\plugins
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/aisradar_pi18_v092_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/aisradar_pi18_v092_pi.dll Version detected: 108
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/dashboard_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/dashboard_pi.dll Version detected: 106
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/findit_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/findit_pi.dll Version detected: 106
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/grib_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/grib_pi.dll Version detected: 107
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/logbookkonni_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/logbookkonni_pi.dll Version detected: 106
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/ocpndebugger_win32_pi18_v01_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/ocpndebugger_win32_pi18_v01_pi.dll Version detected: 108
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/vdr_win32_pi16_v03_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/vdr_win32_pi16_v03_pi.dll Version detected: 106
13:40:50: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/wmm_win32_pi18_v06_pi.dll
13:40:50: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/wmm_win32_pi18_v06_pi.dll Version detected: 108
13:40:50: Warning: WMM model data file C:\Program Files (x86)\OpenCPN/plugins/WMM.COF can't be loaded, using the bundled data.
13:40:50: ChartDB Cache policy: Application target is 4069 MBytes
13:40:50: Loading chart db version: V016
13:40:50: Chartdb: Chart directory list follows
13:40:50: Chart directory #0: C:\Users\Gregor\Documents\CM93
13:40:50: GPS Watchdog Timeout is: 6 sec.
13:40:50: Initializing Chart C:\Users\Gregor\Documents\CM93\00300000\A\00300000 .A
13:40:50: CM93Composite Chart Root is C:\Users\Gregor\Documents\CM93\
13:40:50: Loaded CM93 Dictionary from C:\Users\Gregor\Documents\CM93\
13:40:50: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04230000.D
13:40:50: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04230003.D
13:40:51: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/C/04140000.C
__________________

__________________
George64 is offline   Reply With Quote
Old 22-06-2012, 07:44   #3
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,877
Re: Autopilot output device open failed

George64...

Do you see COM9 in the Control Panel->System->Device manager?

Dave
__________________
bdbcat is offline   Reply With Quote
Old 22-06-2012, 08:06   #4
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

Hi Dave,

Yes, I do see COM 9 and also set it to 38400,8,n,1

I also can select com9 as port for the autopilot, however this might be obvious to your question.

Thanks, George
__________________
George64 is offline   Reply With Quote
Old 22-06-2012, 08:16   #5
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,877
Re: Autopilot output device open failed

George64...

It seems that you have the AIS attached to COM9. So, it is unavailable for the autopilot. Is this your intention?

Dave
__________________
bdbcat is offline   Reply With Quote
Old 22-06-2012, 08:23   #6
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

Hi Dave,

My thought and interpretation of other posst is by having one USB-connection between my laptop and the multiplexer, AIS and all other nmea data goes over one port.

The AIS engine is connected to the multiplexer and therefor I assume it alo needs to be on port 9 in opencpn.

George
__________________
George64 is offline   Reply With Quote
Old 22-06-2012, 08:26   #7
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

Dave,

Did a quick test to disable AIS in opencpn (set it to None), and GPS as well as Autopilot to comm 9. The logfile shows the following info:
Quote:
16:28:49:


16:28:49: 2012-06-22
16:28:49: -------Starting opencpn-------
16:28:49: Version 3.0.0 Build 2012-06-03
16:28:49: MemoryStatus: mem_total: 8139 mb, mem_initial: 8 mb
16:28:49: SData_Locn is C:\Program Files (x86)\OpenCPN 3.0.0\
16:28:49: Using existing Config_File: C:\ProgramData\opencpn\opencpn.ini
16:28:49: Setting Viewpoint Lat/Lon 51.3278, 1.4203
16:28:49: Setting Ownship Lat/Lon 51.3278, 1.4203
16:28:52: System default Language: nl_NL
16:28:52: Opencpn language set to: nl_NL
16:28:52: ChartSymbols loaded from C:\Program Files (x86)\OpenCPN 3.0.0\s57data\chartsymbols.xml
16:28:52: Using s57data in C:\Program Files (x86)\OpenCPN 3.0.0\s57data
16:28:52: Setting Viewpoint Lat/Lon 51.3278, 1.4203
16:28:52: Setting Ownship Lat/Lon 51.3278, 1.4203
16:28:52: NMEA Data Source is....Serial:COM9
16:28:52: AIS Data Source is....None
16:28:52: Using WVSChart datafile: C:\Program Files (x86)\OpenCPN 3.0.0\wvsdata\wvs43.dat
16:28:52: OpenPD: 356, new_count = 1 for COM9
16:28:52: NMEA AutoPilot Port is....Serial:COM9
16:28:52: Re-OpenPD: 356, new_count = 2 for COM9
16:28:52: PlugInManager searching for PlugIns in location C:\Program Files (x86)\OpenCPN 3.0.0\plugins
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/aisradar_pi18_v092_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/aisradar_pi18_v092_pi.dll Version detected: 108
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/dashboard_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/dashboard_pi.dll Version detected: 106
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/findit_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/findit_pi.dll Version detected: 106
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/grib_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/grib_pi.dll Version detected: 107
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/logbookkonni_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/logbookkonni_pi.dll Version detected: 106
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/ocpndebugger_win32_pi18_v01_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/ocpndebugger_win32_pi18_v01_pi.dll Version detected: 108
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/vdr_win32_pi16_v03_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/vdr_win32_pi16_v03_pi.dll Version detected: 106
16:28:52: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/wmm_win32_pi18_v06_pi.dll
16:28:52: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/wmm_win32_pi18_v06_pi.dll Version detected: 108
16:28:52: Warning: WMM model data file C:\Program Files (x86)\OpenCPN/plugins/WMM.COF can't be loaded, using the bundled data.
16:28:52: ChartDB Cache policy: Application target is 4069 MBytes
16:28:52: Loading chart db version: V016
16:28:52: Chartdb: Chart directory list follows
16:28:52: Chart directory #0: C:\Users\Gregor\Documents\CM93
16:28:52: GPS Watchdog Timeout is: 6 sec.
16:28:52: Initializing Chart C:\Users\Gregor\Documents\CM93\00300000\A\00300000 .A
16:28:52: CM93Composite Chart Root is C:\Users\Gregor\Documents\CM93\
16:28:52: Loaded CM93 Dictionary from C:\Users\Gregor\Documents\CM93\
16:28:52: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04230000.D
16:28:52: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04230003.D
16:28:52: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04230006.D
16:28:53: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/C/04140000.C
16:29:00: EnumerateSerialPorts() Found Garmin USB Driver.
It seems that port 9 is opened without error. If that is the solution, is there no way to have GPS, Autopilot and AIS 'running' over the same USB port?

George
__________________
George64 is offline   Reply With Quote
Old 22-06-2012, 08:40   #8
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

In addition Dave, by checking the NMEA output, I don't see a --RMB sentence. This one is required for the Clipper GPS repeater to work. Based on another post I added:
Quote:
[Settings/NMEAAutoPilotPort]
Port=Serial:COM9
AutoPilot NMEA Sentence Out=RMB;RMC
I'm not sure if these are releated, just thought to let you know if it can be of any help.

George
__________________
George64 is offline   Reply With Quote
Old 23-06-2012, 00:43   #9
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

For a test I created a route in my Furuno GP-31, the one that is also connected to the Clipper GPS repeater via the multiplexer (Shipmodul). The display of the showed the route information.

It seems that there is a difference in nmea sentences sent by the Furuno, the output captured from the Multiplexer (is equal to what is sent to board network, no filtering or what so ever):
Quote:
$HCHDG,129.00,,,,*78
$GPVTG,,T,206,M,0.1,N,0.1,K*7A
$GPZDA,063058,23,06,2012,-2,0*69
$GPRMC,063057,A,5119.6654,N,00125.2174,E,0.1,211,2 30612,1,W*6E
$GPRMB,A,0.00,R,START ,LWST02,5117.107,N,00128.067,E,3.1,145,0.0,V*44
$GPGLL,5119.6654,N,00125.2175,E,063058,A*28
$GPGGA,063058,5119.6654,N,00125.2175,E,1,7,1.1,2,M ,46,M,,*77
$IIHDG,127.0,0,E,1.0,W*40
$IIDPT,2.3,-1.4,100.0*6A
$IIRMC,063056,A,5119.666,N,00125.217,E,0.0,215.0,, 1.0,W,A*17
$IIRMA,A,5119.666,N,00125.217,E,,,0.0,235.0,1.0,W, A*11
$IIMTW,14.7,C*11
$IIRMB,A,0.00,L,START ,LWST02,,,,,3.10,145.0,0.0,V,A*3B
$IIDBT,7.5,f,2.3,M,1.3,F*10
$IIVLW,1714.009,N,462.022,N*77
$IIVHW,125.0,T,127.0,M,0.0,N,0.0,K*57
$IIZTG,,,*65
$IIAPB,A,A,0.00,L,N,,,,M,LWST02,146.0,M,,,A*11
$PSMDOV,2
$IIVHW,127.0,T,129.0,M,0.0,N,0.0,
I do see an RMB sentence that contains the information of the waypoint I selected in the Furuno.

I know this is moving the context of this topic, however what I'm curious to is:
1) How can I can an output from Opencpn that contains the route information in a way that it will show on the Clipper display?
2) By sending the AIS-information to/through the multiplexer (the one that is connected with a USB cable to my laptop), can that be show in Opencpn or is that only possible if I use two separate connection, and thus opening two different comm port numbers?

Maybe it sounds like a cry for help, however being solo sailing at the moment this would really make life a lot easier when it comes to navigation in the aria I'm in

Thanks a lot for your time and help!

George
__________________
George64 is offline   Reply With Quote
Old 24-06-2012, 03:38   #10
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

Hello,

Anyone who can be of help to me??

Thnks in advance,
George
__________________
George64 is offline   Reply With Quote
Old 24-06-2012, 03:56   #11
Registered User

Join Date: Dec 2011
Boat: Catfisher 28
Posts: 149
Re: Autopilot output device open failed

have you tried just splitting your comport with one of those programs so they can have 2 different ports?
__________________
deepthought is offline   Reply With Quote
Old 24-06-2012, 05:38   #12
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

Quote:
Originally Posted by deepthought View Post
have you tried just splitting your comport with one of those programs so they can have 2 different ports?
That seems to work Deepthought. Thanks. I tried it earlier with NavMonPC, but I was not able to get that to work. Tried VSPE and that works.

One problem remains however, how can I get the Clipper GPS repeater showing the route information?? As far as I can see/understand, there is a RMB sentence required and I'm not able to pull that sentence out of Opencpn

Thanks, George
__________________
George64 is offline   Reply With Quote
Old 24-06-2012, 06:18   #13
Registered User

Join Date: Jun 2007
Location: SW Florida
Boat: FP Belize, 43' - Dot Dun
Posts: 3,424
I have to ask the obvious, have you set a 'goto' in OCPN? It won't put out RMB until you do.
__________________
DotDun is online now   Reply With Quote
Old 24-06-2012, 06:36   #14
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

Quote:
Originally Posted by DotDun View Post
I have to ask the obvious, have you set a 'goto' in OCPN? It won't put out RMB until you do.
No problem. I created a route and activated the route and set a point of the route active.

Thanks, George
Attached Thumbnails
Click image for larger version

Name:	OpenCPN-Route.gif
Views:	117
Size:	388.7 KB
ID:	42679  
__________________
George64 is offline   Reply With Quote
Old 26-06-2012, 04:43   #15
Registered User

Join Date: Aug 2010
Posts: 297
Re: Autopilot output device open failed

After spending another couple of hours searching why I'm not able to get the route info on the Clipper GPS, this is more a cry for help.

I activated a route and routepoint/waypoint. Coordinates:
050 54 29.682 N 000 58 59.287 E

I created a virtual com 10, based on the USB com 9 port. I monitored com 10. See enclosed attachment.

Opencpn's log file:
Quote:
12:34:31: 2012-06-26
12:34:31: -------Starting opencpn-------
12:34:31: Version 3.0.0 Build 2012-06-03
12:34:31: MemoryStatus: mem_total: 8139 mb, mem_initial: 8 mb
12:34:31: SData_Locn is C:\Program Files (x86)\OpenCPN 3.0.0\
12:34:31: Using existing Config_File: C:\ProgramData\opencpn\opencpn.ini
12:34:31: Setting Viewpoint Lat/Lon 50.9793, 1.136
12:34:31: Setting Ownship Lat/Lon 50.7919, 0.3258
12:34:35: System default Language: nl_NL
12:34:35: Opencpn language set to: nl_NL
12:34:38: ChartSymbols loaded from C:\Program Files (x86)\OpenCPN 3.0.0\s57data\chartsymbols.xml
12:34:38: Using s57data in C:\Program Files (x86)\OpenCPN 3.0.0\s57data
12:34:38: Setting Viewpoint Lat/Lon 50.9793, 1.136
12:34:38: Setting Ownship Lat/Lon 50.7919, 0.3258
12:34:38: NMEA Data Source is....Serial:COM1
12:34:38: AIS Data Source is....None
12:34:38: Using WVSChart datafile: C:\Program Files (x86)\OpenCPN 3.0.0\wvsdata\wvs43.dat
12:34:38: OpenPD: 336, new_count = 1 for COM1
12:34:38: NMEA AutoPilot Port is....Serial:COM10
12:34:38: OpenPD: 356, new_count = 1 for COM10
12:34:38: PlugInManager searching for PlugIns in location C:\Program Files (x86)\OpenCPN 3.0.0\plugins
12:34:38: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/aisradar_pi18_v092_pi.dll
12:34:38: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/aisradar_pi18_v092_pi.dll Version detected: 108
12:34:38: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/dashboard_pi.dll
12:34:38: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/dashboard_pi.dll Version detected: 106
12:34:38: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/findit_pi.dll
12:34:38: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/findit_pi.dll Version detected: 106
12:34:38: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/grib_pi.dll
12:34:38: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/grib_pi.dll Version detected: 107
12:34:38: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/logbookkonni_pi.dll
12:34:38: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/logbookkonni_pi.dll Version detected: 106
12:34:40: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/ocpndebugger_win32_pi18_v01_pi.dll
12:34:40: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/ocpndebugger_win32_pi18_v01_pi.dll Version detected: 108
12:34:40: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/vdr_win32_pi16_v03_pi.dll
12:34:40: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/vdr_win32_pi16_v03_pi.dll Version detected: 106
12:34:40: PlugInManager: Loading PlugIn: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/wmm_win32_pi18_v06_pi.dll
12:34:40: C:\Program Files (x86)\OpenCPN 3.0.0\plugins/wmm_win32_pi18_v06_pi.dll Version detected: 108
12:34:40: Warning: WMM model data file C:\Program Files (x86)\OpenCPN/plugins/WMM.COF can't be loaded, using the bundled data.
12:34:40: ChartDB Cache policy: Application target is 4069 MBytes
12:34:40: Loading chart db version: V016
12:34:40: Chartdb: Chart directory list follows
12:34:40: Chart directory #0: C:\Users\Gregor\Documents\CM93
12:34:40: GPS Watchdog Timeout is: 6 sec.
12:34:40: Initializing Chart C:\Users\Gregor\Documents\CM93\00300000\A\00300000 .A
12:34:40: CM93Composite Chart Root is C:\Users\Gregor\Documents\CM93\
12:34:40: Loaded CM93 Dictionary from C:\Users\Gregor\Documents\CM93\
12:34:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04200000.D
12:34:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04200003.D
12:34:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04230000.D
12:34:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/D/04230003.D
12:34:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03900000/C/04140000.C
12:35:32: LOGBOOK: 2012-06-26 10:35:32 UTC GPS Lat 50.79194 Lon 0.32580 COG 356.00000 SOG 0.00
12:36:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03901020/D/04201077.D
12:36:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03901020/D/04231077.D
12:36:40: Loading CM93 cell C:\Users\Gregor\Documents\CM93\03901020/C/04141068.C
12:36:41: EnumerateSerialPorts() Found Garmin USB Driver.
12:40:04: EnumerateSerialPorts() Found Garmin USB Driver.
Please have a look at the nmea log, made in NavMonPC and tell me what's missing, and how I (ot it) can be solved)

Thanks in advance for helping me out!
Attached Files
File Type: doc NmeaLog.txt.doc (6.2 KB, 63 views)
__________________

__________________
George64 is offline   Reply With Quote
Reply

Tags
autopilot

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:25.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.