Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-06-2019, 01:52   #1
Registered User
 
Sea Patroller's Avatar

Join Date: Mar 2019
Location: Germany, Port Hooksiel
Boat: Pedro Woudbloemkruiser 35
Posts: 10
Autopilot function blocking NMEA communication

Hi Folks,


I have been around the North Sea islands recently and had a chance to test my nav setup which mainly consists out of two RPis. One is running some network stuff incl. kplex (two TCP server, one UDP feeder, three serial interfaces [up to now and different speeds]). The other one runs a desktop with OpenCPN. I like OpenCPN as it can run the oesenc charts and displays my receiving AIS data. With this setup I am feeding the Marine Traffic and aishub btw. ;-)

I have encountered a problem while using the route function. When it is enabled OpenCPN floods XTE date via a TCP connection to kplex. On kplex my Raymarine ST6002 ist connected via serial line with 4800 baud. As soon as i connect to kplex via telnet for debugging I can see that a very fast stream of XTE data is coming out of the box. While having the route function enabled it does begin to give the correct data to the autopilot but shortly after, the position of my own ship starts to freeze for a while on the map, and the autopilot does not get the latest XTE (and other) data.

I am not sure if this is an issue with kplex and/or OpenCPN. But I feel it could be a great feature if there would be a setting for a frequency of transmitting autopilot/route data via the connection.
Or is t hiding from me??

Cheers

Nicholas
__________________

Sea Patroller is offline   Reply With Quote
Old 03-06-2019, 02:35   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,226
Re: Autopilot function blocking NMEA communication

Are you sure you don' t have a data loop in your setup. Sounds very much like you do.
__________________

nohal is offline   Reply With Quote
Old 03-06-2019, 02:40   #3
Registered User

Join Date: Dec 2015
Location: Germany, sailing: Northsea
Boat: Friendship 28
Posts: 208
Re: Autopilot function blocking NMEA communication

Hi,

You can try something:
Witch NMEA sentences sends OC to your AP? Only RMB or RMC too?
Try to set an output filter thats only sends OCRMB to the AP.
When OC sends RMC too there can be a problem with the NMEA streams.

Regards

Andreas
Andreas29 is offline   Reply With Quote
Old 03-06-2019, 04:49   #4
Registered User
 
Sea Patroller's Avatar

Join Date: Mar 2019
Location: Germany, Port Hooksiel
Boat: Pedro Woudbloemkruiser 35
Posts: 10
Re: Autopilot function blocking NMEA communication

Quote:
Originally Posted by nohal View Post
Are you sure you don' t have a data loop in your setup. Sounds very much like you do.
Hm, sounds possible to me. I will have to check on this.
Another reason to drive to the boat :-). I will debug it and reply. Might take a while. Thanks for pointing in that direction.
Sea Patroller is offline   Reply With Quote
Old 06-08-2019, 19:58   #5
Registered User
 
Sea Patroller's Avatar

Join Date: Mar 2019
Location: Germany, Port Hooksiel
Boat: Pedro Woudbloemkruiser 35
Posts: 10
Re: Autopilot function blocking NMEA communication

I owe an answer.
Yes, it has been a loopback problem.
Thanks for the support.
Sea Patroller is offline   Reply With Quote
Reply

Tags
autopilot, fun, nmea

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Imux NMEA communication error mkgsail OpenCPN 20 20-02-2019 09:35
"Avoid" function with OpenCPN and autopilot? prof_mariner OpenCPN 10 03-02-2015 17:36
Garmin 541s and Raymarine ST4000 Autopilot Communication Dulcesuenos Navigation 1 27-09-2011 16:40
Window Glass UV Blocking Films jkleins Construction, Maintenance & Refit 2 09-11-2009 13:12
Blocking users comments Agility Forum Tech Support & Site Help 45 05-03-2008 10:04



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 05:56.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.