Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-05-2019, 10:04   #1
Registered User

Join Date: May 2019
Posts: 8
AIS Raspi Ubuntu Mate - no AIS objects

Hello,

I have used Opencpn for years ona Raspi3+ with Ubuntu mate16.04.
With the OpenCPN 5.0. no AIS objects are shown !??

We had some Problems with the antenna. The antenna was broken and we installed a new antenna and I updated to OpenCPN 5.0.
Now, I can't see AIS obejects!

The AIS is transmitting correctly:
I can see the ship on marinetraffic.com and
other ships in harbour can see me.
But I can't see any AIS Objects on monitor.

The NMEA log shows this ( the external GPS is switch off to see the data of AIS).

I checked all connections, but all was ok.

Has anybody an idea where I should look for this problem.
What does it mean: "GNSS is in use"?

Thank you
Heiko
Attached Thumbnails
Click image for larger version

Name:	20190504_114958.jpg
Views:	53
Size:	288.4 KB
ID:	191391  
__________________

Heiko2 is offline   Reply With Quote
Old 04-05-2019, 10:11   #2
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,463
Re: AIS Raspi Ubuntu Mate - no AIS objects

Is the "screenshot" before or after the antenna repair?
First line says that the antenna is broken or not usable.
__________________

bcn is offline   Reply With Quote
Old 04-05-2019, 10:58   #3
Registered User

Join Date: May 2019
Posts: 8
Re: AIS Raspi Ubuntu Mate - no AIS objects

It's after repair!!!

Thats one point of the miracle. I understand the first line and thought the antenna is broken.
But I can see the boat in internet AIS and neighbours can see me as well.

I state, that the antenna is working.

But not recieving?
Heiko2 is offline   Reply With Quote
Old 04-05-2019, 11:04   #4
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,463
Re: AIS Raspi Ubuntu Mate - no AIS objects

At least it tells you that it can't use the antenna correctly.

Your device generates VDO (=ownship) sentences but any about targets (=VDM sentences).
Nothing OpenCPN can do about....
bcn is offline   Reply With Quote
Old 04-05-2019, 11:18   #5
Registered User

Join Date: May 2019
Posts: 8
Re: AIS Raspi Ubuntu Mate - no AIS objects

" Your device generates VDO (=ownship) sentences but any about targets (=VDM sentences).
Nothing OpenCPN can do about.... "

When I get it right, you mean that the device is sending (VDO), but did not deliver AIS objects to the raspi !? Why? recieving is much easier than sendinG, isn't it ?

(Opencpn is working correct)

The device is an Exnc 101 transponder Class B AIS Transponder > ExNC
It is no longer supported by the manufacturer!!?

Is it broken?
Heiko2 is offline   Reply With Quote
Old 04-05-2019, 11:25   #6
Registered User

Join Date: May 2019
Posts: 8
Re: AIS Raspi Ubuntu Mate - no AIS objects

Did I get it right?
You say the device is sending, but can't recieve data?

It is thus device:
Class B AIS Transponder > ExNC
It is no longer supported by the manufacturer.

Can the recieving part of the device break, but it is sending?
Last year the antenna was broken and we recognised it later, so that ist was trying to send without antenna. I thought the sending part might be broken, but it is sending today.
But no recieving????
Heiko2 is offline   Reply With Quote
Old 04-05-2019, 15:39   #7
Moo
Registered User

Join Date: Mar 2017
Posts: 407
Re: AIS Raspi Ubuntu Mate - no AIS objects

Quote:
Originally Posted by Heiko2 View Post
It's after repair!!!

Thats one point of the miracle. I understand the first line and thought the antenna is broken.
But I can see the boat in internet AIS and neighbours can see me as well.

I state, that the antenna is working.

But not recieving?

Marine traffic data could be very old. Check the report date.


Just because a nearby ship (or marine traffic station) can see your signal is not a reason to say that your antenna is working correctly.



Hi VSWR will damage your transmitter eventually that is why most radio transmitters these days monitor it and throttle the Tx power if the VSWR is high. Anyway a signal transmitted into a faulty antenna will still radiate a little bit.. on the other hand the received signal will have to be very strong for a faulty antenna to pick it up. I suggest you do a test with your emergency antenna connected as directly to the back of the AIS set as is possible. Your antenna may be OK but your coax cable could be damaged.



You can work out which part is faulty by a process of elimination, but better get a technician to check it out with a SWR meter, dummy load or reference antenna etc..
Moo is offline   Reply With Quote
Old 04-05-2019, 19:00   #8
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,628
Re: AIS Raspi Ubuntu Mate - no AIS objects

Heiko2...
"Did I get it right?
You say the device is sending, but can't recieve data?" (sic)

Correct.
When the device is receiving correctly, and sending NMEA data to to OpenCPN input port, and there are local stations within receive range, then you will see $AIVDM messages in the NMEA debug stream.
So, three things to check out.
Good Luck
Dave
bdbcat is offline   Reply With Quote
Old 05-05-2019, 02:59   #9
Registered User

Join Date: May 2019
Posts: 8
Re: AIS Raspi Ubuntu Mate - no AIS objects

I suggest you do a test with your emergency antenna connected as directly to the back of the AIS set as is possible. Your antenna may be OK but your coax cable could be damaged.


Its a new antenna from the manufacturer.
Its this device: http://www.exnc.at/upload/products/c...et_exnc101.pdf
Heiko2 is offline   Reply With Quote
Old 05-05-2019, 03:01   #10
Registered User

Join Date: May 2019
Posts: 8
Re: AIS Raspi Ubuntu Mate - no AIS objects

You can see the messages of the AIS device on top of this post
Heiko2 is offline   Reply With Quote
Old 05-05-2019, 03:12   #11
Moo
Registered User

Join Date: Mar 2017
Posts: 407
Re: AIS Raspi Ubuntu Mate - no AIS objects

Quote:
Originally Posted by Heiko2 View Post
I suggest you do a test with your emergency antenna connected as directly to the back of the AIS set as is possible. Your antenna may be OK but your coax cable could be damaged.


Its a new antenna from the manufacturer.
Its this device: http://www.exnc.at/upload/products/c...et_exnc101.pdf

And the coax is new too? correctly installed? Antenna correctly installed? Clear of all other conductors?


It is possible that your AIS transceiver is faulty and incorrectly reporting high VSWR but more likely an antenna fault ... It usually is
Moo is offline   Reply With Quote
Old 05-05-2019, 03:16   #12
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 1,944
Re: AIS Raspi Ubuntu Mate - no AIS objects

You should contact the manufacturer. As you have seen, nobody can help you because it is not a software problem of OpenCPN or any any other.


Du solltest den Hersteller kontaktieren. Hier kann Dir keiner helfen, da es kein Software Problem ist.
CarCode is offline   Reply With Quote
Old 05-05-2019, 03:29   #13
Registered User

Join Date: May 2019
Posts: 8
Re: AIS Raspi Ubuntu Mate - no AIS objects

Hi CarCode,

meanwhile Iam convinced that its a hardware problrem and not an opencpn problem!
Thank you!

But the manufacturer did bot support this device anymore. ****!!
Heiko2 is offline   Reply With Quote
Old 05-05-2019, 03:54   #14
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 1,944
Re: AIS Raspi Ubuntu Mate - no AIS objects

Quote:
Originally Posted by Heiko2 View Post
Hi CarCode,

meanwhile Iam convinced that its a hardware problrem and not an opencpn problem!
Thank you!

But the manufacturer did bot support this device anymore. ****!!
Do not buy in Austria?
Besser nicht so etwas in Österreich kaufen?
CarCode is offline   Reply With Quote
Old 05-05-2019, 03:56   #15
Registered User

Join Date: May 2019
Posts: 8
Re: AIS Raspi Ubuntu Mate - no AIS objects

Why not?
__________________

Heiko2 is offline   Reply With Quote
Reply

Tags
ais

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Displaying River Objects (Signs) in OpenCPN pyr OpenCPN 14 24-10-2010 04:39
What Are the Objects that Display . . . Gilletarom OpenCPN 47 08-09-2010 15:01
S-57: Add New Objects to CPN kasej OpenCPN 1 19-07-2010 05:55
Securing Objects to the Boat landonshaw Construction, Maintenance & Refit 6 28-05-2009 17:54
Fastening pictures, objects to wood bulkhead?? bstreep Construction, Maintenance & Refit 4 29-10-2008 11:52



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 17:53.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.