Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-07-2011, 19:22   #1
Registered User

Join Date: Apr 2008
Location: Houston
Boat: Pearson 303
Posts: 84
Send a message via Skype™ to PaulM
A Little Help Needed

Guys,
I use Opencpn at the helm for the first time last weekend. Very nice. Used with the autopilot to take us out to watch the 4th of July fireworks on the bay. I have a couple of questions.

On looking at the track properties afterwards I noticed the in there are no headers for the columns. How do I get those. I'm was running 2.3.1 on XP.

The second question is on ver, 2.4.628. I moved the "UserIcons" file with "ownship" icon to Application Data\opencpn, yet no change to "ownship".
Any thoughts on what I'm missing.

Thanks
Paul
__________________

__________________
PaulM is offline   Reply With Quote
Old 08-07-2011, 23:41   #2
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: A Little Help Needed

Quote:
Originally Posted by PaulM View Post
Guys,
etc...

The second question is on ver, 2.4.628. I moved the "UserIcons" file with "ownship" icon to Application Data\opencpn, yet no change to "ownship".
Any thoughts on what I'm missing.
....l
Paul,per the second question,more info needed:
Test?Can you use the other icons you have in the UserIcons folder for marks etc?that is,you have them "available" in the "mark" dialogue?If so you are shipshape on the location and the xpm format of these icons...so it must be the ownship.xpm that's the problem....
Can you post it here as ownship.doc (just change the ".xpm" to ".doc") and I'll try it.(My ownship works fine in '628)

in fact,why not try this one...

ownship.doc
__________________

__________________
HappySeagull is offline   Reply With Quote
Old 09-07-2011, 07:16   #3
Registered User

Join Date: Apr 2008
Location: Houston
Boat: Pearson 303
Posts: 84
Send a message via Skype™ to PaulM
Re: A Little Help Needed

Thanks HS,
My own ship has the correct extension (xpm). Tried your "ownship", same result. My icon works fine in ver 2.3.1. I have reloaded 2.4.628. Again same result.

Paul
__________________
PaulM is offline   Reply With Quote
Old 09-07-2011, 07:48   #4
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: A Little Help Needed

PaulM....

We seem to be fussy on the spelling of "UserIcons".

Note capital "I".

Dave
__________________
bdbcat is offline   Reply With Quote
Old 09-07-2011, 08:27   #5
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: A Little Help Needed

PaulM,
since 2.3 and 2.4.628 use the same ini and xml files to start up with,while the UserIcons folder is in a different place for each,try moving these two files out of the app data folder (XP example = "C:\Documents and Settings\All Users\Application Data") temporarily.You can just put em back when testing done...

...then restart 2.4.628.You'll get the new user greeting from OPCN and have to show it the charts...ie like a fresh install but now it should/could work with your ownship.

In fact,you should be getting the user greeting evry time you switch between the two versions...?
__________________
HappySeagull is offline   Reply With Quote
Old 09-07-2011, 14:27   #6
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: A Little Help Needed

PaulM...good point on the track properties ....are they buttons?Titles?I don't have anything in there either...never noticed them before!
__________________
HappySeagull is offline   Reply With Quote
Old 10-07-2011, 09:43   #7
Registered User

Join Date: Apr 2008
Location: Houston
Boat: Pearson 303
Posts: 84
Send a message via Skype™ to PaulM
Re: A Little Help Needed

HP,
Thanks again for the help. The two different versions are different computers. I did that to avoid and "cross contamination". So I don't think its a ver. issue. I'll try some other icons and see if they will work.

Bdbcat,
I have "UserIcons" as the file name w/ a capital "I". Is that correct?

Paul
__________________
PaulM is offline   Reply With Quote
Old 10-07-2011, 10:55   #8
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: A Little Help Needed

PaulM

Capital "I" is correct.

Dave
__________________
bdbcat is offline   Reply With Quote
Old 10-07-2011, 16:21   #9
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: A Little Help Needed

Paul M,
in my "opencpn.log",I always see "Error: XPM: Malformed pixel data!" It's right near the beginning of the log entry that is written every time you start OpenCPN.That said ,my homemade ownship (the same one I sent you)works fine just the same...but do you also have this phrase in your log?Maybe we've both got ownships that O doesn't like but mine works due to a difference in our computers?
__________________
HappySeagull is offline   Reply With Quote
Old 10-07-2011, 21:35   #10
Registered User

Join Date: Apr 2008
Location: Houston
Boat: Pearson 303
Posts: 84
Send a message via Skype™ to PaulM
Re: A Little Help Needed

HP.
I didn't find any error messages in the log. The "ownship" I have worked fine on this computer when it was still 2.3.1. I did install 2.4.780. Same issue.

Paul
__________________
PaulM is offline   Reply With Quote
Old 11-07-2011, 08:44   #11
Registered User

Join Date: Feb 2011
Posts: 490
Re: A Little Help Needed

How can you change the boat for an adjustable ship size (Lenght and breadth? I did try without success.
P_Dub
__________________
P_Dub is offline   Reply With Quote
Old 11-07-2011, 09:07   #12
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: A Little Help Needed

Quote:
Originally Posted by PaulM View Post
HP.
I didn't find any error messages in the log. The "ownship" I have worked fine on this computer when it was still 2.3.1. I did install 2.4.780. Same issue.

Paul
Forget 2.3.1.I get your icon worked there.Mine never did,by the way...blackspots all over ,but I digress...

bear with me.We are only talking the newer OpenCPN

You are double sure you have the UserIcons folder with all the icons you made, including ownship.xpm in the same folder that you have the logfile?

In XP it need be in here:C:\Documents and Settings\All Users\Application Data\opencpn
You are in XP?or not...?
In Win7,I can't remember but you know,because you found the log...
__________________
HappySeagull is offline   Reply With Quote
Old 11-07-2011, 09:08   #13
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: A Little Help Needed

Quote:
Originally Posted by P_Dub View Post
How can you change the boat for an adjustable ship size (Lenght and breadth? I did try without success.
P_Dub
how long?can you give a pixel length?I'll try and make one too.
__________________
HappySeagull is offline   Reply With Quote
Old 11-07-2011, 09:24   #14
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: A Little Help Needed

ownship.xpm.doc

here's a 100x20 pixel ship...yes it's bad but it's 5 minutes.
It should look like this..

Click image for larger version

Name:	ownshipSHIPtest.jpg
Views:	119
Size:	16.8 KB
ID:	29541

but no gps on so I can't see if it swings around and all.I'm needing coffee..
__________________
HappySeagull is offline   Reply With Quote
Old 11-07-2011, 10:52   #15
Registered User

Join Date: Feb 2011
Posts: 490
Re: A Little Help Needed

Quote:
Originally Posted by HappySeagull View Post
Attachment 29540

here's a 100x20 pixel ship...yes it's bad but it's 5 minutes.
It should look like this..

Attachment 29541

but no gps on so I can't see if it swings around and all.I'm needing coffee..
That is the objective, to replace the boat in the last version (2.4.708) by an adjustable ship size and moving also. I guest this will have to be done in the main program. I would appreciate it very much. Thanks for the help.
Bye
P_Dub
__________________

__________________
P_Dub is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Good Boat Needed ! Don1500 Monohull Sailboats 13 13-10-2011 13:51
Crew Wanted: Seattle to San Diego Captain Needed ccrdivers Crew Archives 7 09-08-2011 19:26
mechanic for volvo md2b in NMB , FL needed jeanlouis1905 Challenges 3 29-06-2011 22:10
Want To Buy: SOS :) 1985 Whaler Part Needed FLORIDA KURT Classifieds Archive 0 25-06-2011 07:25



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:07.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.