Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-02-2016, 22:03   #1
Registered User

Join Date: Nov 2009
Posts: 40
4.2 Plugin issues

I upgraded to 4.2 from 4.0 and really appreciate the speed. I am having two issues with plugins and hope others can help me.

Dashboard: Dashboard is MIA, it does not show up as an option under plug-ins.

Watchdog: Watchdog works, but the icon is transparent, see screen shot

I am running windows 7 on an Asus Eee PC Seashell!
Attached Thumbnails
Click image for larger version

Name:	opencpn screenshot.jpg
Views:	96
Size:	261.4 KB
ID:	119725  
__________________

__________________
StargazerWA is offline   Reply With Quote
Old 28-02-2016, 01:15   #2
Marine Service Provider

Join Date: Sep 2014
Posts: 14
Re: 4.2 Plugin issues

same issue with dashboard ....
__________________

__________________
Gyro is offline   Reply With Quote
Old 28-02-2016, 04:10   #3
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: 4.2 Plugin issues

Can't reproduce neither of the problems... Are you using the very latest version of watchdog? Can we see your logfile, please?

Thanks

Pavel
__________________
nohal is offline   Reply With Quote
Old 28-02-2016, 04:34   #4
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Re: 4.2 Plugin issues

Re: missing dashboard plugin

Are you absolutely certain that the DLL (dashboard_pi.dll) is in the active plugins directory? I've found that the installer is pretty good but not perfect. With multiple installations it is possible that the plugin directory isn't up to date for the active O installation. The active plugin folder should be in a path like "C:\Program Files (x86)\OpenCPN_Active_location\plugins" where "OpenCPN_Active_location" corresponds to the latest installation location so if you have multiple installations it may be "OpenCPN 4.2.0".
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 28-02-2016, 08:05   #5
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: 4.2 Plugin issues

Good question Bob, that would apply to watchdog_pi too.

Since the included plugins WMM, ChartDownloader, Dashboard, Grib are installed with OpenCPN, they are most likely installed properly, but it is worthwhile to check, particularly if the opencpn.log file does not find and list them.

In moving from 4.0 or 4.1 to 4.2, at a certain point after many many tests of plugins, I was having trouble and simply renamed my opencpn.ini file to opencpn.ini.old and let opencpn make a new one. That really helped. Then In copied my chart setttings from the old version and made the other changes under Options.

I always had my old opencpn.ini.old file to go back to, once I had figured out what was wrong. I think if I was Evans, I would check for plugin location. Then rename opencpn.ini and start O to see what happens. Then go back to the old opencpn.ini depending on what I find out.
__________________
rgleason is offline   Reply With Quote
Old 28-02-2016, 14:02   #6
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 121
Re: 4.2 Plugin issues

O 4.2 can't handle the waypoints in layers but I had no problem with O 4 or 4.1 it freeze and if I load more than 3000 waypoints O is running very slowly and is unusable. So i am back at O 4 again just wandering why O 4 could handle 30 000 waypoints and 4.2 not

Sent from my SM-G920F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 28-02-2016, 14:30   #7
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,016
Re: 4.2 Plugin issues

Ivanm...
As a test I have just loaded a layer with a few less than 58000 waypoints both as a layer and as normal waypoints and OpenCPN is as fast as with no waypoints at all in OpenGL mode. It starts to be slow at very small scale with OpenGL disabled and the display full of WPTs as on the attached screenshot because of the text rendering.
So can you give us some more details about your configuration and perhaps attach a problematic GPX file to try to reproduce your situation?

Thanks

Pavel
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2016-02-28 at 18.25.09.jpg
Views:	59
Size:	417.8 KB
ID:	119770  
__________________
nohal is offline   Reply With Quote
Old 28-02-2016, 14:45   #8
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 121
Re: 4.2 Plugin issues

I tried it on win7 and 10 and with Open gl on and off , I usualy work on a small scale will get to the gpx files tomorrow and test then one by one

Sent from my SM-G920F using Cruisers Sailing Forum mobile app
__________________
Ivanm is offline   Reply With Quote
Old 28-02-2016, 16:48   #9
Registered User

Join Date: Nov 2009
Posts: 40
Re: 4.2 Plugin issues

The dll file was missing for the dashboard plugin. I reinstalled 4.2 and that problem is resolved. As for Watchdog I did have an old version installed. I installed 1.9037 but the icon is still not visible. Not a big problem, ?I know it's there. Thanks for the help.

I like how Dashboard can be placed on an edge and the chart shrinks. How do I unpinned that if I want to move it?
__________________
StargazerWA is offline   Reply With Quote
Old 28-02-2016, 16:59   #10
Registered User

Join Date: Nov 2009
Posts: 40
Re: 4.2 Plugin issues

Update, if I switch to Journeyman the Watchdog icon becomes visible. It goes away when I switch back to traditional.
__________________
StargazerWA is offline   Reply With Quote
Old 28-02-2016, 20:03   #11
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,320
Re: 4.2 Plugin issues

Perhaps you are missing the non-journeyman icon?
Or perhaps that build is missing it?
__________________
rgleason is offline   Reply With Quote
Old 02-03-2016, 02:09   #12
Registered User
 
Ivanm's Avatar

Join Date: Jan 2015
Posts: 121
Re: 4.2 Plugin issues

Quote:
Originally Posted by Ivanm View Post
O 4.2 can't handle the waypoints in layers but I had no problem with O 4 or 4.1 it freeze and if I load more than 3000 waypoints O is running very slowly and is unusable. So i am back at O 4 again just wandering why O 4 could handle 30 000 waypoints and 4.2 not

Sent from my SM-G920F using Cruisers Sailing Forum mobile app
I downloaded the (O4.2.0-85501b9 after.exe) version from file thingie and it work just fine now no more problems with waypoints

Sent from my SM-G920F using Cruisers Sailing Forum mobile app
__________________

__________________
Ivanm is offline   Reply With Quote
Reply

Tags
plug

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN PlugIn Development bdbcat OpenCPN 78 29-07-2017 03:15
Plugin: DashBoard SethDart OpenCPN 470 24-08-2016 21:34
BSB 4 PlugIn bdbcat OpenCPN 93 20-02-2016 04:41
S63 plugin security issues with Chrome and Firefox barbara ann OpenCPN 4 27-01-2016 08:31
Writing Plugin for nv.digital Map Format ? Netsurfer OpenCPN 7 17-08-2010 17:09



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:50.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.