Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-03-2013, 13:41   #1
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
3.2 crashes repeatedly

I posted this in the development thread and again in the 3.2 launch thread but nobody seems to be paying attention to me. I have done 4 extended cruises using 3.2 and have had 4 crashses. For a while I thought it was related to running Konni logbook but yesterday I did an extended cruise without starting Konni and sure enough, O crashed again. I suppose it still could be Konni related because the plugin is still loaded even if its not active. The next time I go out I will unload the plugin completely. However, that makes 4 successive extended trips and 4 crashes. The only common factor I can see is extended run time. The problem doesn't appear until after several hours of operation. Yesterday it was about 6 hours into the trip, just before 4:00

The symptoms are that the dashboard starts to flash the position data. The position data is still updated and appears to still be accurate. That may go on indefinitely as long as I don't attempt to pan or zoom. However if I pan or zoom and then select an individual chart I get a crash. Yesterday it locked my screen up, usually it just very politely apologises and says it has to close. This is beyond my paygrade to solve but I'm convinced it is a bug.
Attached Files
File Type: doc opencpn.doc (55.0 KB, 57 views)
__________________

__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 16-03-2013, 14:20   #2
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,758
Re: 3.2 crashes repeatedly

Hi Bob,

what OS are you using?
What happens with OpenGL enabled/disabled?

I had crashes (Win7) after several hours too (sometimes earlier) and it showed up that the OpenGL driver was eating up the memory after some while. You can check this monitoring memory usage. If it creeps up under OpenGL you might have to live without it on your system (if you don't find an improved driver)

Hubert
__________________

__________________
bcn is online now   Reply With Quote
Old 16-03-2013, 14:31   #3
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Sorry. I should have included that this is W7. I'll have to put Google to work to figure out the OpenGL thing - you might as well be speaking Latin for all I know about that. Thanks for the help - I've got some things to try now.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 16-03-2013, 14:39   #4
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,758
Re: 3.2 crashes repeatedly

Bob,

you find this at settings (the wrench) --> Display |x| use accelerated graphics (OpenGL)

Take your beer/wine/tea/coffee/water(??) and observe how memory usage goes in either case
__________________
bcn is online now   Reply With Quote
Old 16-03-2013, 19:32   #5
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Re: 3.2 crashes repeatedly

Well it turns out I haven't been using accelerated graphics on either computer. So there goes that theory but thanks for the thought.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 16-03-2013, 20:25   #6
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,883
Re: 3.2 crashes repeatedly

bob...

Sorry you are having trouble. Not meaning to ignore you, just taking a little internet break. Good for the soul occasionally....

Several things:

1. I do not understand what you mean when you say the dashboard position "flashes". More?

2. Does it crash after some hours when you are just sitting at a dock? Or do you need to be moving?

3. Does it crash if you remove all PlugIns except BSB4?

4. Does it crash with all PlugIns (including BSB4) removed?

Thanks
Dave
__________________
bdbcat is offline   Reply With Quote
Old 16-03-2013, 21:16   #7
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Re: 3.2 crashes repeatedly

I will try while sitting at the dock - hadn't thought about doing that. I don't have any extended cruises planned for a while now but if I can get a crash here at the dock I should be able to answer your other questions.

"Flashing position" in the dashboard means that the highlighted portion in the attached image flashes. Not sure how else to describe it. The position information text, including the heading text "Position" appears and disappears at a rate of about 2 times per second. I think it flashes faster the longer I leave it running but that could be my imagination.
Attached Thumbnails
Click image for larger version

Name:	20130316_210920.jpg
Views:	102
Size:	80.0 KB
ID:	57181  
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 17-03-2013, 03:48   #8
Registered User

Join Date: Feb 2011
Location: uk
Posts: 75
Re: 3.2 crashes repeatedly

I tried the konni log book with a sony lap top and win 7, though with one of the later development versions of OCPN.

It also crashed, by freezing in both gl and non gl versions. As I was "on voyage", and trying out my new ais class B unit at the time, I removed Konni, and had no further problem.

I haven't tried konni with 3.2, as the record daily tracks is sufficient for me.

Ps the frezes happened 3 times after between half hour and 1 hour underway, & 300 + ais targets (in the Rotterdam area)

Interestingly, without any plugins running and an observed ais target count of up to 750, while underway there were no further issues on a 10 day cruise.
__________________
yachtman is offline   Reply With Quote
Old 17-03-2013, 08:55   #9
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: 3.2 crashes repeatedly

...bobothenorth, if you suspect a plugin is giving trouble, try "removal"
removal means taking it out of the plugins folder entirely, not just "disabling" it in the plugins manager....
__________________
HappySeagull is offline   Reply With Quote
Old 17-03-2013, 10:36   #10
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Re: 3.2 crashes repeatedly

It looks like I need to be underway to get the crash. O has been running over 12 hours now in the slip. I'll be here for roughly another week so I'll leave it run just in case.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 18-03-2013, 08:47   #11
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Re: 3.2 crashes repeatedly

The plot thickens .......

Last night I realized that when I'm underway in addition to the autopilot and O running I also have my radio turned on. It didn't seem to me that it could possibly be related but my radio does receive the GPS coordinates from the autopilot so last night I left the radio on. When I got up this morning O had crashed. I've got it restarted now and I'll watch for the flashing position information but in the case of the crash last night it occurred without any zoom or pan because I was asleep when it happened.

So just to be clear:
- O runs on a W7 64 bit laptop with a USB GPS puck plugged into it.
- O is outputting to my autopilot on COM1. COM1 is a 2-way port so that O can receive mag heading information from my autopilot
- my radio is connected directly to my autopilot on one of the autopilot's output ports.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 18-03-2013, 09:26   #12
cruiser

Join Date: Mar 2013
Posts: 59
Re: 3.2 crashes repeatedly

I am using OCPN since day one from xp to 7 ultimate. on the speed boat as well as on the sailing boar.ever never come close to crashing. stop messing around just because you can get it for free. if you paid couple of hundred of dollars or pounds for it you would not mess around with the files, experimenting or start deleting or adding files. or it is not set up properly with other "instruments".I "tested" it crossing Biscay few times, sailing from Croatia to Malta and back, crossing Adriatic from Croatia to Italy I can not even remember how many times, never had slightest issue with OCPN, so stop blaming "O".

my only "rant" is that I would like to have 45, 50kts on the speedometer, not maximum 12, because I am using it on my motor boat also and my cruising speed is 32kts, (wot 40).

P.S I forgot to mention that I never installed koni logbook or other similar crap. I am still keeping paper logbook.
__________________
transformer is offline   Reply With Quote
Old 18-03-2013, 09:41   #13
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Re: 3.2 crashes repeatedly

Thank you for your input Transformer. You use O reliably because guys like me help test it and the code guys fix the problems that we find. And I didn't "get it for free" - maybe you should pony up a donation to help the developers as well. This thread was started with a goal of resolving the specific issue that is causing this crash. If you don't have something useful to contribute perhaps you should just read it.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 18-03-2013, 16:00   #14
cruiser

Join Date: Mar 2013
Posts: 59
Re: 3.2 crashes repeatedly

Quote:
Originally Posted by bobofthenorth View Post
Thank you for your input Transformer. You use O reliably because guys like me help test it and the code guys fix the problems that we find. And I didn't "get it for free" - maybe you should pony up a donation to help the developers as well. This thread was started with a goal of resolving the specific issue that is causing this crash. If you don't have something useful to contribute perhaps you should just read it.

I can but do not have/wont to donate anything because I do not need ocpn, and I am not using it in the real world navigation. that is for those who wont free lunch everywhere they go (sail). I wrote in my post above that I just TESTED it. My main navigation software is Maptech chart pro and Euronav's seapro professional.
Actualy OpenCPN is useles for me, simply because i am using euronav's Livecharts (mostly) and UKHO S57 (63) charts that ocpn does not support.

actually apart usa cruisers, for every one else OCPN is literary useful. usa cruisers can get those free charts, in Europe and elsewhere in the world your choice is only 3 years old pirated cm93 or even older (some are dated from 1995) bsb charts downloaded from the internet.
I wonder how many of you have up to date charts on the ocpn. probably on the raster charts last update was in the 2001.

even if you wont to buy charts ocpn does not support it
__________________
transformer is offline   Reply With Quote
Old 18-03-2013, 16:10   #15
Registered User
 
Tar34's Avatar

Join Date: Dec 2011
Posts: 291
Re: 3.2 crashes repeatedly

Quote:
Originally Posted by bobofthenorth View Post
Thank you for your input Transformer. You use O reliably because guys like me help test it and the code guys fix the problems that we find. And I didn't "get it for free" - maybe you should pony up a donation to help the developers as well. This thread was started with a goal of resolving the specific issue that is causing this crash. If you don't have something useful to contribute perhaps you should just read it.
I wish someone could help me....Am I mistaken and CPN isn't Mac compliant?
Looked for 3.0.2 but I think it is no longer available for download,,, currently
MacBook Pro... OSX 10.8.3
__________________

__________________
Tar34 is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 12:13.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.