Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 13-04-2015, 05:47   #1
Registered User

Join Date: May 2014
Location: British Colombia Canada
Boat: Corbin 39
Posts: 7
Wind instrument problem

Is there anyone who can help me determine how to fix the the wind indicator speed, mine does not start rotating when everyone else's start. Any input would be appreciated.

Thanks
MBorg
__________________

__________________
MalteseFalcon is offline   Reply With Quote
Old 14-04-2015, 05:45   #2
Registered User
 
r.furborough's Avatar

Join Date: Oct 2008
Location: Norfolk, VA
Boat: Freedom 32 (Hoyt)
Posts: 223
Re: Wind instrument problem

The shaft is binding or the bearing is failing. Your masthead unit either needs rebuilding or replacing. Sometimes you can extend its life by using WD40 or a similar product to release and lubricate the shaft, best done on off the mast so the unit can be held inverted to allow the lube to get gravity assistance penetrating the shaft.

On some masthead units the bearing is sometimes a part of a circuit board, given the space for soldering the wiring, not an easy task.


Sent from my iPhone using Cruisers Sailing Forum
__________________

__________________
------------------------------------------------
the memories of a man in his old age, are the dreams of a man in his prime
Pink Floyd - 'Free Four'
r.furborough is offline   Reply With Quote
Old 14-04-2015, 08:43   #3
Registered User

Join Date: Jan 2015
Location: Surrey, British Columbia
Boat: C&C 34
Posts: 5
Re: Wind instrument problem

Quote:
Originally Posted by MalteseFalcon View Post
Is there anyone who can help me determine how to fix the the wind indicator speed, mine does not start rotating when everyone else's start. Any input would be appreciated.

Thanks
MBorg
I have an older Raymarine (ST50) vane and it cost me $500.00 to get the motor replaced and the unit serviced. It was bad bearings all around. Next time I will purchase a new unit.

Dennis
__________________
Truemettle42 is offline   Reply With Quote
Old 14-04-2015, 08:54   #4
Moderator
 
nigel1's Avatar

Cruisers Forum Supporter

Join Date: Oct 2009
Location: Manchester, UK
Boat: Beneteau 473
Posts: 5,194
Re: Wind instrument problem

Can you advise make and model.
I rebuilt a B&G unit, which just needed two new bearings, and total cost was about $5.
__________________
Nigel
Beneteau 473
Manchester, UK
nigel1 is online now   Reply With Quote
Old 14-04-2015, 09:33   #5
Registered User

Join Date: May 2010
Location: Elsewhere on the Water
Posts: 571
Re: Wind instrument problem

Does anyone have experience with repair or replacement of a Simrad IS-11 wind vane?
__________________
St. Elsewhere is offline   Reply With Quote
Old 14-04-2015, 12:39   #6
Registered User

Join Date: May 2014
Location: British Colombia Canada
Boat: Corbin 39
Posts: 7
Re: Wind instrument problem

Quote:
Originally Posted by nigel1 View Post
Can you advise make and model.
I rebuilt a B&G unit, which just needed two new bearings, and total cost was about $5.
It's a Datamarine Link 3000
__________________
MalteseFalcon is offline   Reply With Quote
Old 15-04-2015, 02:55   #7
Moderator
 
nigel1's Avatar

Cruisers Forum Supporter

Join Date: Oct 2009
Location: Manchester, UK
Boat: Beneteau 473
Posts: 5,194
Re: Wind instrument problem

Not a unit I know, but maybe these links might help

Wind Speed Indicator Repair

Replacing masthead unit for Datamarine Wind instrument
__________________
Nigel
Beneteau 473
Manchester, UK
nigel1 is online now   Reply With Quote
Old 15-04-2015, 03:30   #8
Registered User
 
ErikFinn's Avatar

Join Date: Feb 2011
Location: Malaysia, Thailand
Boat: Beneteau Oceanis 430
Posts: 832
Re: Wind instrument problem

No punch intended, but are these expensive and fragile instruments even necessary for a non-racer cruiser? Seems like they cost an arm and a leg, don't last particularly long anyways. Yea I can gather is nice to see the knots number and a tidy dial, but seriously..?
__________________
ErikFinn is offline   Reply With Quote
Old 15-04-2015, 06:26   #9
Registered User

Join Date: May 2014
Location: British Colombia Canada
Boat: Corbin 39
Posts: 7
Re: Wind instrument problem

Quote:
Originally Posted by ErikFinn View Post
No punch intended, but are these expensive and fragile instruments even necessary for a non-racer cruiser? Seems like they cost an arm and a leg, don't last particularly long anyways. Yea I can gather is nice to see the knots number and a tidy dial, but seriously..?
Hi Erik,
I understand what you are saying but I like to have my boat in tip top shape so I try and prevent many bad things to happen and fix all the things that break. If I was of the same mindset as you I would probably dislike my boat very much an move on to better pastures.
.
__________________
MalteseFalcon is offline   Reply With Quote
Old 15-04-2015, 08:10   #10
Registered User
 
ErikFinn's Avatar

Join Date: Feb 2011
Location: Malaysia, Thailand
Boat: Beneteau Oceanis 430
Posts: 832
Re: Wind instrument problem

Quote:
Originally Posted by MalteseFalcon View Post
Hi Erik,
I understand what you are saying but I like to have my boat in tip top shape so I try and prevent many bad things to happen and fix all the things that break. If I was of the same mindset as you I would probably dislike my boat very much an move on to better pastures.
.
Nothing wrong with that.
I have tried to find reasons to assure myself I should get this equipment but have been unsuccessful.
__________________

__________________
ErikFinn is offline   Reply With Quote
Reply

Tags
men, rum, wind

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Want To Buy: Raymarine ST60 Wind & Close Hauled Wind instrument jphillips48 Classifieds Archive 4 20-09-2013 04:07
Problem With B&G Instrument System sailing_norway Marine Electronics 4 02-09-2012 07:34
Raymarine ST60+ wind instrument problem PetenSuz Marine Electronics 7 28-06-2011 08:27



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 09:06.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.