Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-06-2012, 15:51   #1
Registered User
 
bgallinger's Avatar

Join Date: Feb 2010
Location: Jupiter, FL
Boat: Hunter 340
Posts: 350
Images: 10
Send a message via AIM to bgallinger
Tacktick Troubles

I have been using a Tacktick wind direction/speed indicator for 3 years and it has performed flawlessly until this spring. The display unit shows wind speed and direction then suddenly quits showing data. Battery strength is full but I wired it up to 12 volt ship power and still no improvement.
Has anyone experienced this problem?
__________________
bgallinger is offline   Reply With Quote
Old 03-06-2012, 18:22   #2
Senior Cruiser
 
DeepFrz's Avatar

Cruisers Forum Supporter

Join Date: Mar 2006
Location: Winnipeg
Boat: None at this time
Posts: 7,930
Re: Tacktick Troubles

Do a search on "tacktick" on the forum and you will find a number of threads with similar problems.
__________________
DeepFrz is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:21.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.