Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 30-08-2016, 11:01   #1
Registered User
 
COLINFLTENG's Avatar

Join Date: Aug 2011
Location: COMOX
Boat: CS 40
Posts: 223
ST 60 WIND

Has any one replaced ST 60 WIND mine needs to be replaced not working

Sent from my SM-G935W8 using Cruisers Sailing Forum mobile app
__________________

__________________
COLINFLTENG is offline   Reply With Quote
Old 30-08-2016, 11:28   #2
Registered User
 
jstevens's Avatar

Join Date: May 2006
Location: On board Sarah, currently lying in Jacksonville, FL
Boat: Pearson, 424, 42', Sarah
Posts: 561
Images: 4
Re: ST 60 WIND

Used Raymarine ST60 instruments are commonly available on eBay. I've replaced the control module for my AP, Wind and speed with used ones off eBay. What part of the ST 60 wind needs replacing? The masthead unit is often damaged by birds, and a used replacement can be difficult to find without having to buy the base and cable.
If you are considering replacing one component with new I suggest you discuss that with Raymarine to insure what you buy is compatible with the components you do not replace.

John
__________________

__________________
jstevens is offline   Reply With Quote
Old 30-08-2016, 11:48   #3
Moderator
 
Pete7's Avatar

Cruisers Forum Supporter

Join Date: Aug 2009
Location: Solent, England
Boat: Moody 31
Posts: 7,766
Images: 14
Re: ST 60 WIND

Mine keeps me quite fit, climbing up and down the mast on a regular basis. Which reminds me I must take the spare one in for repair
__________________
Moody 31 - April Lass
Pete7 is offline   Reply With Quote
Old 30-08-2016, 17:01   #4
Registered User
 
COLINFLTENG's Avatar

Join Date: Aug 2011
Location: COMOX
Boat: CS 40
Posts: 223
Re: ST 60 WIND

Masthead needs replacement, can I not use a new one? I am thinking of using a lift bucket boat on land in Oct 65' high mast

Sent from my SM-G935W8 using Cruisers Sailing Forum mobile app
__________________
COLINFLTENG is offline   Reply With Quote
Old 30-08-2016, 17:16   #5
Registered User
 
Andrew G's Avatar

Join Date: Feb 2012
Location: Melbourne, Australia
Boat: Van deStadt 34
Posts: 80
Re: ST 60 WIND

The vane and rotor are available as a spare kit from Raymarine (about Au$50). There are two designs so specify the right one. The two sets of bearings on the rotor are standard (stainless steel) ones and are not hard to replace (a good bearing shop). All this might involve two trips up the mast . . . Cheers, Andrew
__________________
Andrew G is offline   Reply With Quote
Old 30-08-2016, 18:06   #6
Guy
Registered User

Join Date: Feb 2013
Location: So. Oregon
Boat: Seafarer36c
Posts: 3,956
Re: ST 60 WIND

[QUOTE=COLINFLTENG;2201087]Has any one replaced ST 60 WIND mine needs to be replaced not working

Make sure it's not the indicator. I used all my brain power to decide that it was our indicator that was inop. I sent it to Raymarine and they said it works fine but it's about to quit .
__________________
Guy is offline   Reply With Quote
Old 30-08-2016, 18:26   #7
Registered User
 
Andrew G's Avatar

Join Date: Feb 2012
Location: Melbourne, Australia
Boat: Van deStadt 34
Posts: 80
Re: ST 60 WIND

Hi again. There have been a number of posts here describing how to check if it is the mast-head gear or the instrument. With the power on the voltage will vary as described by one:

"You may want to call Raymarine technical support to doublecheck, but this is what they told me when I had a similar problem:
Measure voltage at the back of the display. If the values are:
o Between Silver and Red around 8V
o Between Silver and Blue 2-6V
o Between Silver and Green 2-6V BUT DIFFERENT THAN SILVER AND BLUE
o Between Silver and Yellow 0-5V
then the masthead assembly is OK and it is the display that is faulty. "

(the colours refer to the connectors)
You may need to search the forum and www for more??

Here is one which describes how to replace the bearings.

Raymarine wind speed slowing down

Cheers, Andrew
__________________
Andrew G is offline   Reply With Quote
Old 30-08-2016, 21:01   #8
Registered User
 
COLINFLTENG's Avatar

Join Date: Aug 2011
Location: COMOX
Boat: CS 40
Posts: 223
Re: ST 60 WIND

Has any one change to wireless T101

Sent from my SM-G935W8 using Cruisers Sailing Forum mobile app
__________________
COLINFLTENG is offline   Reply With Quote
Old 01-09-2016, 12:38   #9
Registered User

Join Date: Jan 2008
Location: SF Bay Area (Boat in La Paz)
Boat: Valiant V40
Posts: 364
Re: ST 60 WIND

Don't forget to look for a possible splice or connector perhaps near the base of the mast. Common to have corrosion and a poor connection there.
__________________
jamhass is offline   Reply With Quote
Old 01-09-2016, 19:30   #10
Registered User
 
COLINFLTENG's Avatar

Join Date: Aug 2011
Location: COMOX
Boat: CS 40
Posts: 223
Re: ST 60 WIND

Will do

Sent from my SM-G935W8 using Cruisers Sailing Forum mobile app
__________________
COLINFLTENG is offline   Reply With Quote
Old 01-09-2016, 21:05   #11
Registered User
 
Capt.Don's Avatar

Join Date: Aug 2010
Location: Altadena, CA
Boat: Tartan 3500
Posts: 576
Images: 1
Re: ST 60 WIND

I have to spray my wind speed and direction servos every year or two with electrical contact cleaner. Also have replaced the cups and feather as Andrew suggested. I hope to keep mine working!
Don
__________________
Capt.Don is offline   Reply With Quote
Old 02-09-2016, 20:30   #12
Registered User
 
COLINFLTENG's Avatar

Join Date: Aug 2011
Location: COMOX
Boat: CS 40
Posts: 223
Re: ST 60 WIND

You go up mast very 2 years?

Sent from my SM-G935W8 using Cruisers Sailing Forum mobile app
__________________
COLINFLTENG is offline   Reply With Quote
Old 06-09-2016, 11:43   #13
Registered User

Join Date: May 2009
Location: Livin' aboard
Boat: Cape Dory 40, 40 feet
Posts: 7
Send a message via Skype™ to restless.cd40
Re: ST 60 WIND

I added a ultrasonic wind sensor from Maretron. It uses only NMEA 2000 for communications. After a bumpy start, it works flawlessly. my analog datamarine 30 yrs old started working again after checking the wiring. Go figure!


Sent from my iPad using Cruisers Sailing Forum
__________________

__________________
restless.cd40 is offline   Reply With Quote
Reply

Tags
wind

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLD] Davis Wind Wizard Wind Speed Indicator SailorHarry Classifieds Archive 0 21-12-2013 10:24
Want To Buy: Raymarine ST60 Wind & Close Hauled Wind instrument jphillips48 Classifieds Archive 4 20-09-2013 03:07
How Much Wind is Too Much Wind ? Andrei123 General Sailing Forum 18 13-08-2012 08:59


Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 15:46.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.