Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 03-04-2009, 05:47   #16
Registered User

Join Date: Apr 2007
Posts: 718
Originally Posted by 7tiger7 View Post
What brand / model connector is that? I will try to find something like that to splice the cable on my installation of a C80 plotter and radome on my catalina 30 (I am the friend C2C was talking about...)
It is a Walcom connector but I don't have a part number for you. I'm home for a few weeks recovering from surgery and all my info is at work. Just do a google search for rectangular connectors. Walcom, Molex, and AMP are good sources for these.


fairbank56 is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:50.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.