Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-04-2017, 10:21   #1
Registered User

Join Date: Jan 2014
Boat: Xc-45 2018
Posts: 23
Raymarine ST70+ display, not powering off.

I have a bit of a puzzle, at least for me.
Our instrument displays where changed during winter storage, (as our old ST70+ faded during usage). No cabling changed. Switching the instruments on via the fuse panel below,works fine, but when turning them of via the fuse panel ( dedicated switch ) they remain on!?
Have tried to connect them to a different switch, but with same result. If I turm the main batteri off/on, then they remain off (if the panel swiitch is off). They can also be turned off via the key pad control at the helm.

In rhe past the instruments could be turned off via the panel switch.
( turning on/off autopilot via its dedicated panel switch works fine).
Any suggestions?

Best regards - Colin
__________________

Colin Oslo is offline   Reply With Quote
Old 08-04-2017, 10:51   #2
Registered User

Join Date: Jun 2013
Location: canada
Posts: 2,669
Re: Raymarine ST70+ display, not powering off.

Get a voltmeter and figure out where the power is coming from

Often the gauges are feed from the pilot power.
__________________

smac999 is offline   Reply With Quote
Old 08-04-2017, 11:01   #3
Registered User

Join Date: Jan 2014
Boat: Xc-45 2018
Posts: 23
Re: Raymarine ST70+ display, not powering off.

Yes, the instruments and autopilot have the same swith on the panel ( and plotter a seperate one ).

?
Colin
Colin Oslo is offline   Reply With Quote
Old 08-04-2017, 13:47   #4
Registered User
 
Cavalier's Avatar

Join Date: Dec 2010
Location: Houston, TX
Boat: Beneteau 461 47'
Posts: 926
Images: 1
Re: Raymarine ST70+ display, not powering off.

Quote:
Originally Posted by Colin Oslo View Post
Yes, the instruments and autopilot have the same swith on the panel ( and plotter a seperate one ).



?

Colin


Are you running a SeatalkNG network? Is this powered off the autopilot/instrument breaker or the chartplotter breaker? ST70+ displays typically have their own dedicated power, whereas ST60/ST70 instruments power directly off the NG backbone.



My guess is that when you had the ST70+ switched out during the winter, they're now powered off another circuit, perhaps the chartplotter circuit?

Sent from mTalk
__________________
"By day the hot sun fermented us; and we were dizzied by the beating wind. At night we were stained by dew, and shamed into pettiness by the innumerable silences of stars."
Cavalier is offline   Reply With Quote
Old 09-04-2017, 07:08   #5
Registered User

Join Date: Jan 2014
Boat: Xc-45 2018
Posts: 23
Re: Raymarine ST70+ display, not powering off.

Hi,
Thanks reply.
Not sure what fixed it, but its working now. There was on/off switch in the apx computer. Turned this off, then all is back to normal
Colin Oslo is offline   Reply With Quote
Old 09-04-2017, 10:38   #6
Registered User

Join Date: Dec 2016
Posts: 744
Re: Raymarine ST70+ display, not powering off.

Aside: Be careful with autopilot and other sea talk devices on the same breaker. They typically have very different fusing requirements. Mine are on the same breaker, but I had to put an in-line fuse between the pilot and the instruments.
toddster8 is offline   Reply With Quote
Old 09-04-2017, 22:25   #7
Registered User

Join Date: Jan 2014
Boat: Xc-45 2018
Posts: 23
Re: Raymarine ST70+ display, not powering off.

Thanks for the tip - Colin
__________________

Colin Oslo is offline   Reply With Quote
Reply

Tags
marine, raymarine

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raymarine ST70+ Display problems Colin Oslo Marine Electronics 3 08-09-2016 02:25
Cannot read Raymarine ST70 wind transducer pod data from B&G MFD mbartosch Marine Electronics 19 23-06-2016 15:41
For Sale: Raymarine ST70 autopilot head (E12196) rja Classifieds Archive 2 27-02-2014 22:50
Raymarine ST6002 Vs. ST70 AP Heads SS Little-Devil Marine Electronics 6 14-08-2013 08:49
Raymarine ST60 v ST70 hoppy Marine Electronics 3 11-07-2011 10:56

Advertise Here


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 21:21.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×

ShowCase vBulletin Plugins by Drive Thru Online, Inc.