Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 14-05-2014, 07:50   #1
Registered User

Join Date: Aug 2012
Location: New York
Boat: Topper Hermanson H44
Posts: 24
Raymarine radar problems

Good morning all.
We have a circa 2007 Raymarine package which includes a C70 display and a 2kw scanner. All works well most of the time but maybe one time in four the radar shows nothing. To me there is nothing obviously wrong with the info from the diagnostics pages, its as if there's just no signal from the scanner, but there is. If I turn the gain right up I can see all the 'noise', but no targets. Occasionally if I leave it running like this it will sort it self out, but usually not. Anyone got any ideas or suggestions?
__________________

__________________
simio47 is offline   Reply With Quote
Old 14-05-2014, 08:02   #2
Senior Cruiser
 
DeepFrz's Avatar

Cruisers Forum Supporter

Join Date: Mar 2006
Location: Winnipeg
Boat: None at this time
Posts: 7,929
Re: Raymarine radar problems

Sounds like a dirty relay/switch contact.
__________________

__________________
The Blue Dot Campaign. This Changes Everything.
DeepFrz is offline   Reply With Quote
Old 14-05-2014, 08:46   #3
Registered User

Join Date: Apr 2013
Posts: 227
Re: Raymarine radar problems

I think I've read that Raymarine are helpful with advice so maybe call them?
Probably shouldn't go much beyond checking every pin/socket of the connectors at both ends of the scanner cable yourself - power cable disconnected for safety.
Not just a quick look but a thorough inspection with a powerful magnifier - looking for corrosion or poor contact. Visual scan of boards can sometimes find problems. Heat damage, corrosion, leaked electrolytics are all fairly easy to spot.
Magnetron seems a strong possibility though.
__________________
bornyesterday is offline   Reply With Quote
Old 14-05-2014, 13:20   #4
Registered User

Join Date: Aug 2012
Location: New York
Boat: Topper Hermanson H44
Posts: 24
Re: Raymarine radar problems

Yes, think I will have to give them a call. And thoroughly check all connections. Just strange that its so intermittent.
__________________
simio47 is offline   Reply With Quote
Reply

Tags
marine, radar, raymarine

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radar Problems Sergy Marine Electronics 8 02-06-2010 12:52
Raymarine Problems Paolo Marine Electronics 31 11-11-2009 07:02
Raymarine E Series Problems rabend Marine Electronics 41 17-06-2009 19:00
Raymarine 425 Chart plotter problems. sailvi767 Marine Electronics 0 11-10-2007 05:52



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:13.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.