Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-02-2015, 00:55   #1
Registered User

Join Date: Mar 2014
Location: Lake Macquarie
Boat: Lagoon 420
Posts: 40
Raymarine C90w not starting up properly

I have a 2012 C90W connected to AIS and GPS and the usual ST70 tridata instruments and autopilot (ST6002) which has worked perfectly for the last two years. Suddenly it has decided on startup to display the Raymarine logo screen as normal but when it would normally ask for agreement the display goes dark. I suspect it may be still on as to recover the welcome screen I need to hold the power button down for 5 seconds (normal shutdown procedure) and then press the on button for the same result earlier described, Any help would be appreciated.
__________________

__________________
peterwilliam is offline   Reply With Quote
Old 08-02-2015, 05:26   #2
Registered User
 
r.furborough's Avatar

Join Date: Oct 2008
Location: Norfolk, VA
Boat: Freedom 32 (Hoyt)
Posts: 223
Re: Raymarine C90w not starting up properly

Probably just a software hiccup.

Do a hard reset

From off, hold the left soft key and keep it held while powering on, you should get a ' Factory Reset' message and count down 3, 2, 1.

You will loose all your waypoints and user settings, but probably will recover the use of the mfd.


Sent from my iPhone using Cruisers Sailing Forum
__________________

__________________
------------------------------------------------
the memories of a man in his old age, are the dreams of a man in his prime
Pink Floyd - 'Free Four'
r.furborough is offline   Reply With Quote
Old 08-02-2015, 12:13   #3
Registered User
 
Greggegner's Avatar

Join Date: Nov 2010
Posts: 406
Re: Raymarine C90w not starting up properly

If that doesn't work I would disconnect everything from it and restart. Let us know


Greg S/V Sweet Dreams
Pearson P385 out of Racine Wisconsin
__________________
Greggegner is offline   Reply With Quote
Old 08-02-2015, 22:31   #4
Registered User

Join Date: Mar 2014
Location: Lake Macquarie
Boat: Lagoon 420
Posts: 40
Re: Raymarine C90w not starting up properly

Thanks, the hard reboot was all that was required, lost the waypoints etc but didn't affect the integrated maps. Your advice was really appreciated.
__________________
peterwilliam is offline   Reply With Quote
Reply

Tags
marine, raymarine, rope

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My Raymarine E7 is not picking up my PB200 properly, and it used to......help!! mlydon Marine Electronics 1 26-08-2013 22:19
Raymarine C90W, You Have a Problem J Ventura Marine Electronics 22 17-09-2011 07:07
Raymarine A70 vs C70 and C90W corona Navigation 9 12-09-2011 01:31
For Sale: Raymarine A62132 Trunion Mount for C90W and E90W Display dennisjay Classifieds Archive 2 18-05-2011 06:59
Raymarine C80 vs C90W SV Demeter Marine Electronics 2 09-03-2011 16:48



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:00.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.