Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 14-07-2012, 19:04   #1
Registered User
 
ricktara's Avatar

Join Date: May 2012
Location: NH and Maine
Boat: 2000 Mainship 390
Posts: 46
old signet smartpak issues

I am a new owner of a Watkins 29 that has been stored for a while. In trying to get everything working, I have come across 2 issues (they may be related). The boat has an original Signet Smartpak depth and speed display as well as a Signet analog wind speed and direction. The wind speed stays on 00 and the wind direction never moves on the display. I assume we messed up when connecting wires when stepping the mast, but we are in the water now so I can't go backward there.
I wonder if there is room to get another cable down the mast?

Also the depth and speed display doesn't work, stating that it can't locate a sensepak, but I have traced all wiring and it looks good. Does anyone have any ideas short of buying a Tacktick and tossing signet stuff?
__________________

__________________
ricktara is offline   Reply With Quote
Old 15-07-2012, 07:36   #2
Moderator Emeritus
 
GordMay's Avatar

Join Date: Mar 2003
Location: Thunder Bay, Ontario - 48-29N x 89-20W
Boat: (Cruiser Living On Dirt)
Posts: 31,577
Images: 240
Re: old signet smartpak issues

Signet Manuals, Wiring Diagrams & Troubleshooting Tips:
Signet Marine
__________________

__________________
Gord May
"If you didn't have the time or money to do it right in the first place, when will you get the time/$ to fix it?"



GordMay is offline   Reply With Quote
Old 15-07-2012, 07:45   #3
Registered User
 
ricktara's Avatar

Join Date: May 2012
Location: NH and Maine
Boat: 2000 Mainship 390
Posts: 46
Re: old signet smartpak issues

Quote:
Originally Posted by GordMay View Post
Signet Manuals, Wiring Diagrams & Troubleshooting Tips:
Signet Marine
thanks, we'll see if I have any luck with the info
__________________
ricktara is offline   Reply With Quote
Old 03-11-2013, 17:06   #4
Registered User
 
BoonMcGee's Avatar

Join Date: Oct 2013
Location: Raleigh NC
Boat: O'Day 272 LE
Posts: 12
Re: old signet smartpak issues

Just going through this forum discussion. If you still have the signet display head I certainly be interested in it. Mine needs new LEDs and signet has no more to work with. If you're interested in ditching it let me know. I'm sure we can agree on something. Thanks, Boon
__________________
BoonMcGee is offline   Reply With Quote
Old 03-11-2013, 18:56   #5
Registered User
 
ricktara's Avatar

Join Date: May 2012
Location: NH and Maine
Boat: 2000 Mainship 390
Posts: 46
Re: old signet smartpak issues

Thanks for offering. After I posted that I actually sent them in to the company and had them gone through, so I am using them now.
Thanks again for the offer.
__________________
ricktara is offline   Reply With Quote
Old 03-11-2013, 19:02   #6
Registered User
 
BoonMcGee's Avatar

Join Date: Oct 2013
Location: Raleigh NC
Boat: O'Day 272 LE
Posts: 12
Re: old signet smartpak issues

Ricktara, thanks anyway. The guys at signet are great to work with, aren't they? They just don't have the parts available anymore. I'm keeping on looking. Maybe something will turn up. Someone has a Signet SL 80 sitting around unused. Boon.
__________________

__________________
BoonMcGee is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 15:19.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.