Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 01-09-2014, 02:27   #1
Registered User

Join Date: Jul 2011
Posts: 5
Mast head wind speed transducer not spinning

Mast head wind speed transducer is 3 years old. A Furuno FI5001 and has just stopped spinning. Removed same tried to spray lube and whilst it spins it is obviously not free enough to spin in the wind. Any tips on how to loosen it up to get it spinning again. A new one is over AUD$600


Sent from my iPad using Cruisers Sailing Forum
__________________
Caprice is offline   Reply With Quote
Reply

Tags
head, mast, wind

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A Transducer is a Transducer, Correct? Herbseesmoore Marine Electronics 3 22-06-2013 06:23
Prop Shaft Spinning when Sailing bruadair Propellers & Drive Systems 73 01-09-2011 09:18
Anemometer Not Spinning Herbseesmoore Construction, Maintenance & Refit 8 07-08-2011 23:40
Want To Buy: Raymarine Rotary Rudder Transducer and Fluxgate Transducer Kristian Classifieds Archive 0 22-02-2010 04:09
Silva 400 Mast Head Transducer mikewebb Marine Electronics 2 19-01-2010 20:54



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:33.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.