Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 22-10-2012, 14:32   #1
Registered User

Join Date: Apr 2011
Posts: 2,063
Garmin Airmar triducer, no speed reading

I have a Garmin Airmar DST800 triducer, (NMEA 2000 version) and the speed / knotlog function is not working.

The symptom was that over a few months it took longer and longer to start working each time I sailed. Now it's taking a few hours to come to life. It under-reads significantly, although the extent to which it does that gets less over the hours.

I have tried spinning the paddle, and it spins very freely. I added lubricant and it spins even more freely, but still doesn't work for a few hours.

Any idea what can go wrong?
MarkSF is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:37.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.