Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 23-11-2008, 20:47   #1
Registered User
 
rocou's Avatar

Join Date: Nov 2008
Location: Ottawa-Gatineau,Canada
Boat: ALBIN 43 Sundeck-PUREFOLIE
Posts: 2
FURUNO RADAR M821 RADOME

I am looking for a used radome for a Furuno Radar Model M821( 17" radome,2KW,24N.M,5.7 deg bandwith). Mine does still turn but doesnt send any signal to the LCD screen.( magnetron, signal cable?) . If anyone has had a similar problem I would appreciate receiving your comments.
However if somebody has a working one lying around or know where i could possibly find one please advise.
Thanks in advance.
__________________
rocou is offline   Reply With Quote
Old 24-11-2008, 02:18   #2
Registered User
 
Hampus's Avatar

Join Date: May 2008
Location: Sweden
Boat: Between boats
Posts: 463
Images: 6
Send a message via MSN to Hampus
Hey!

You should receive an alarm on the display if there are any signals missing. If the magnetron is shot the echoes just won't show up but there is no alarm. If you listen to the radome while it's on and in TX-mode, you should here a high pitched sound, like an old CRT-TV starting up. If you don't, chanses are that the magnetron is busted. It's easy to change though. Just keep in mind that there could also be other errors, like a busted modulator board causing the magnetron to fail. Just hand it in to your local dealer and they can check it for you in 15 minutes, or ask them if you could borrow a used megnetron for testing.

Good luck!

/Hampus
__________________
http://adventureswithsyingeborg.blogspot.com/
On the way back to Sweden.
Hampus is offline   Reply With Quote
Old 24-11-2008, 17:27   #3
Registered User
 
rocou's Avatar

Join Date: Nov 2008
Location: Ottawa-Gatineau,Canada
Boat: ALBIN 43 Sundeck-PUREFOLIE
Posts: 2
Good day Hampus,

Many thanks for your comments. There is no alarm signal and the magnetron, when in TX mode, does not emit any pitching-type sound. So I presume, as you suggest, that it could well be the magnetron that is at fault. I will have it checked and keep you posted about the results.
have a nice day, Rocou
__________________
rocou is offline   Reply With Quote
Reply

Tags
radar

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furuno Radar searcher Marine Electronics 9 23-04-2013 18:16
Radar, Furuno 1621 SkiprJohn Marine Electronics 8 07-01-2007 11:04
best aft mount for small radome? Latitude9.5 Marine Electronics 11 22-07-2006 12:43



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:19.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.