Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-02-2014, 17:10   #1
Registered User
 
leftbrainstuff's Avatar

Join Date: May 2011
Location: San Francisco and Australia
Boat: Liberty 458
Posts: 1,978
Furuno 1715 Radar Issues

Hi Guys and gals

Pop quiz.

I have a Furuno 1715 radar. The array is spinning during TX as noticed with the cover off but no targets are visible on screen. When I run a scanner test sometimes array rpm is correct other times it reads 0 rpm.

I've conducted the Furuno troubleshooting and the unit shows no errors. Any hints on what to check next?

(PS: I'm an engineer and mechanic so you won't scare me with technical detail)
__________________

__________________
leftbrainstuff is offline   Reply With Quote
Old 28-02-2014, 06:56   #2
Registered User
 
S/V Alchemy's Avatar

Join Date: May 2008
Location: Toronto
Boat: Custom 41' Steel Pilothouse Cutter
Posts: 4,576
Re: Furuno 1715 Radar Issues

I'm trying to resurrect a 1720 myself (it's too cold in the garage today, however), but I would suggest an intermittent signal may indicate a corroded or poorly connected lead.

How is the unit connected up, via the original connector or via a terminal block?

This is only the start of course; it could be one of a hundred problems. But poor connections are where I would start, particularly as you are clearly getting SOME feedback from the radome.
__________________

__________________
Can't sleep? Read www.alchemy2009.blogspot.com for fast relief. Can't read? Avoid www.volumesofsalt.blogspot.com, because it's just personal reviews of sea books.
S/V Alchemy is offline   Reply With Quote
Old 28-02-2014, 07:55   #3
Registered User
 
leftbrainstuff's Avatar

Join Date: May 2011
Location: San Francisco and Australia
Boat: Liberty 458
Posts: 1,978
Re: Furuno 1715 Radar Issues

I'm using the original cables and connectors which are in food visual condition. There is no corrosion visible.

I'll give furuno a call.

Sent from my GT-I9300 using Cruisers Sailing Forum mobile app
__________________
leftbrainstuff is offline   Reply With Quote
Old 28-02-2014, 07:56   #4
Registered User
 
leftbrainstuff's Avatar

Join Date: May 2011
Location: San Francisco and Australia
Boat: Liberty 458
Posts: 1,978
Re: Furuno 1715 Radar Issues

Oops meant good not food.

Sent from my GT-I9300 using Cruisers Sailing Forum mobile app
__________________
leftbrainstuff is offline   Reply With Quote
Old 28-02-2014, 09:35   #5
Registered User
 
S/V Alchemy's Avatar

Join Date: May 2008
Location: Toronto
Boat: Custom 41' Steel Pilothouse Cutter
Posts: 4,576
Re: Furuno 1715 Radar Issues

I thought we were discussing Martha Stewart for a minute.

I would still suspect if there's any age on the unit that one of the pins is loose. There's a lot of pins...that's why I've decided that the one I salvaged with a cut cable was an opportunity of sorts to do a trim of all those 22 ga. wires...
__________________
Can't sleep? Read www.alchemy2009.blogspot.com for fast relief. Can't read? Avoid www.volumesofsalt.blogspot.com, because it's just personal reviews of sea books.
S/V Alchemy is offline   Reply With Quote
Reply

Tags
furuno, radar

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:13.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.