Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-09-2009, 18:05   #1
Registered User
 
Knowazark's Avatar

Join Date: Jun 2009
Location: Auckland, New Zealand
Boat: Davidson 46, 14m LOA
Posts: 159
Images: 3
Flickering TV

We have a Majestic brand 12V LCD TV installed in the yacht we've recently bought and it suffers from intermittent flickering. It will show images perfectly for a few minutes and then start flickering and after 4 or 5 minutes it will return briefly to a perfect image before flickering again. Doesn't matter if you're playing a DVD or tuning in to local TV signals.

It seems like its caused by some sort of interference, however, we've tried switching things (like the electric fridge, battery charger, VHF, SSB, nav electronics, etc) off and it doesn't seem to make a difference.

Does anyone have any ideas as to what we should be looking at to identify and isolate any interference issues beyond the obvious stuff that we've already done (check that all plugs and connections are tight and clean, etc)?

Just a thought, we've only tried the TV while connected to shore power sitting in the marina berth. Could we be getting electrical interference from another boat, the shore power system, etc? (should probably try the TV while we're out on the water, but have generally got plenty of entertainment at that time anyway )
__________________
The problem with doing nothing all day is that you're never sure when you're actually finished.
Knowazark is offline   Reply With Quote
Old 16-09-2009, 20:04   #2
Senior Cruiser
 
senormechanico's Avatar

Cruisers Forum Supporter

Join Date: Aug 2003
Boat: Dragonfly 1000 trimaran
Posts: 5,834
Probably the TV itself.
Try another one to prove.

Steve B.
Former TV/VCR repair guy.
__________________
senormechanico is offline   Reply With Quote
Old 16-09-2009, 20:31   #3
Registered User
 
speciald@ocens.'s Avatar

Join Date: Apr 2008
Location: On the boat - Carib, Chesapeake
Boat: 58 Taswell AS
Posts: 1,139
Do you have an inverter? That could be the problem.
__________________
speciald@ocens. is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amp meter flickering... avazquez Electrical: Batteries, Generators & Solar 1 11-06-2007 09:07



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:24.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.