Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 29-08-2013, 14:05   #1
Registered User

Join Date: May 2011
Location: New Smyrna Beach, Fl
Posts: 105
E120 Raymarine antenna issue

Lately I have noticed when I turn on my 2 E120s I don't get the ships position for several minutes. These units are approx. 7 yrs old. I was informed it is probably the Raystar RS125 antenna going bad. Checked the little blinking light and it is amber which indicates its probably going bad. Okay decide to order one and find out RM doesn't make that one anymore. The new one is a RS 130 GPS antenna so I'm going to order it.
Does anyone know if the new antenna will fit using the existing cable or will I have heartache and pain and have to pull a new one. Nothing is ever easy on a boat.
__________________
C Skip R is offline   Reply With Quote
Reply

Tags
antenna, marine, raymarine

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 11:01.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.