Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 13-04-2017, 19:02   #1
Registered User

Join Date: Jun 2007
Location: Rio Dulce
Boat: 48' Alu Cat
Posts: 170
Broadband 4G trouble shooting

4G Radar problem.
I have a 2.5 y.o. Broadband 4G radar connected to a Lowrance HDS7. The radar has been working great for the past 2.5 years until last night. A message on the display came up, "No Spoke Data", next "No Radar", & that was it.
I re-started the unit and within a few minutes the same fault occurred.
I turned the unit off over night and on re-start within approx. 3 hours the same problem. Since then I noticed that when the unit warms up the radar will not work.
I assume a component is breaking down when at operating temperature.
Can anybody help?
__________________

Seman is offline   Reply With Quote
Old 13-04-2017, 19:21   #2
Senior Cruiser
 
DeepFrz's Avatar

Cruisers Forum Supporter

Join Date: Mar 2006
Location: Winnipeg
Boat: None at this time
Posts: 8,204
Re: Broadband 4G trouble shooting

Have you done a google search?
__________________

DeepFrz is offline   Reply With Quote
Old 18-08-2017, 03:29   #3
Registered User

Join Date: Jun 2007
Location: Rio Dulce
Boat: 48' Alu Cat
Posts: 170
Re: Broadband 4G trouble shooting

Well, I have taken the 4G radar to the local Navico service agent, Dahlberg, here in Mallorca.
There is a faulty circuit board in the radar dome.
Navico don't sell parts.

1800 EURO for a new replacement radar!

Doing some searches on the internet,I came to the conclusion that the 3 & 4G radars from Navico are unreliable & factory support for their products are non existent.

Unfortunately I have the Lowrance HDS Chart plotter.

Would it be possible to connect a Furuno or other manufacturer radar dome to it?
Seman is offline   Reply With Quote
Old 18-08-2017, 05:21   #4
Registered User

Join Date: Aug 2016
Location: Becalmed in the Med
Boat: Prout Snowgoose 35
Posts: 991
Re: Broadband 4G trouble shooting

I've seen many complaints about the Simrad/B&G/Lowrance radars but mostly in relation to target tracking.

I'm running Simrad gear, and an older 3G radar but it appears to be working ok.

One of the reasons I chose Raymarine for my autopilot was because of the tech support, but I now have a mixture of brands on the boat which isn't ideal, but they all talk to each other for the most part.

Prices in the Balearics are crazy. Often items are several hundreds cheaper ordering from the UK and having them sent next day DHL express.
mikedefieslife is offline   Reply With Quote
Old 18-08-2017, 06:58   #5
Marine Service Provider

Join Date: Dec 2016
Location: Toronto On Canada
Boat: Bristol 45.5
Posts: 739
Re: Broadband 4G trouble shooting

This is not a good thing to hear, I have a Simrad 4G radar and love it , hope it doesn't crap out like yours ,
Fingers crossed

Regards John.
Typhoon is offline   Reply With Quote
Old 27-09-2017, 07:26   #6
Registered User

Join Date: Jun 2007
Location: Rio Dulce
Boat: 48' Alu Cat
Posts: 170
Re: Broadband 4G trouble shooting

Quote:
Originally Posted by Seman View Post
Well, I have taken the 4G radar to the local Navico service agent, Dahlberg, here in Mallorca.
There is a faulty circuit board in the radar dome.
Navico don't sell parts.

1800 EURO for a new replacement radar!

Doing some searches on the internet,I came to the conclusion that the 3 & 4G radars from Navico are unreliable & factory support for their products are non existent.

Unfortunately I have the Lowrance HDS Chart plotter.

Would it be possible to connect a Furuno or other manufacturer radar dome to it?

Ok, paid Euro 1800 & had new 4G dome, R10 & cables installed.
All good for 3 weeks.

Now Zone alarm becomes unreliable & sometimes radar will not start up.
NO RADAR!
We are now in Italy, contacted support here.
They suggested that if a software update on my HDS7 will not rectify my intermittent problem, they will replace the 4G.
The update made no difference, still intermittent.
That's the last I heard from Service IT.
I have written 4 emails in the past week, no response.
Written to Navico Germany, they refer me back to Italy.

Great service, this unit is 4 weeks old & covered by a 2 year warranty.

Where do I go from her?
__________________

Seman is offline   Reply With Quote
Reply

Tags
broadband

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Webasto TSL 17 Trouble shooting Stubop Liveaboard's Forum 2 13-01-2013 15:27
Need help trouble shooting an Inverter Shack Electrical: Batteries, Generators & Solar 15 20-03-2011 17:22
TankWatch4 Trouble-Shooting bobsadler Plumbing Systems and Fixtures 1 31-08-2010 09:12
Class on Diesel Marine Repair and Trouble Shooting Duckwheat Engines and Propulsion Systems 5 21-07-2010 07:07
Cold plate trouble shooting? Janny Plumbing Systems and Fixtures 10 26-12-2007 21:22



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:56.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.