Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 18-10-2011, 21:03   #1
DRS
Registered User
 
DRS's Avatar

Join Date: Jun 2009
Location: Vancouver BC
Boat: Lagoon 380
Posts: 351
Images: 7
Autopilot Fix - Need Ideas

So heres the situation. B&G auto pilot is not working. The control unit compass counts down from 360 constantly. I've had the brain and compass out to a local shop they tested ok but sent them to B&G who tested them ok as well. The units were reinstalled and the installer can't get it to work. Powers up but the brain is not seeing the compass or rudder position. Continuity of the wires checks out ok.

Where do we look next? Any ideas are greatly appreciated.
__________________

__________________
You can sail anywhere on the planet and never be more than 7 miles from land - it might be straight down, but its never more than seven miles
DRS is offline   Reply With Quote
Old 18-10-2011, 21:10   #2
Registered User

Join Date: Aug 2008
Posts: 275
Re: Auto Pilot Fix - Need Ideas

Spray all the plugs and other connections with Caig Deoxit ,or similar product.
__________________

__________________
nonam is offline   Reply With Quote
Old 18-10-2011, 21:23   #3
Senior Cruiser
 
Lancerbye's Avatar

Cruisers Forum Supporter

Join Date: Mar 2007
Location: Ladysmith,BC, Vancouver Island , Canada
Boat: Lancer 44 Motorsailer
Posts: 1,757
Images: 32
Re: Auto Pilot Fix - Need Ideas

Programming error, wrong mode?
__________________
The basis of accomplishment is in never quitting
Mengzi Meng-tse
Lancerbye is offline   Reply With Quote
Old 20-10-2011, 19:36   #4
Registered User
 
phantomracer's Avatar

Join Date: Aug 2010
Location: Boston, MA
Boat: 1968 Ohlson 38 Sloop
Posts: 773
Images: 9
Send a message via Yahoo to phantomracer
Re: Auto Pilot Fix - Need Ideas

what fluxgate are you using? having the same problem with my KVH (2 have done this). Having them repaired at the moment.. Not sure what is causing this either.
__________________
phantomracer is offline   Reply With Quote
Old 21-10-2011, 08:44   #5
Senior Cruiser

Cruisers Forum Supporter

Join Date: Aug 2009
Location: between the devil and the deep blue sea
Boat: a sailing boat
Posts: 17,314
Re: Autopilot Fix - Need Ideas

Get a similar fluxgate from another boat and you will know whether it is the fluxgate or the unit.

Measure the fluxgate - it will deliver something if it is OK - B&G will tell you what to expect.

b.
__________________
barnakiel is offline   Reply With Quote
Old 21-10-2011, 09:09   #6
Senior Cruiser
 
Lancerbye's Avatar

Cruisers Forum Supporter

Join Date: Mar 2007
Location: Ladysmith,BC, Vancouver Island , Canada
Boat: Lancer 44 Motorsailer
Posts: 1,757
Images: 32
Re: Autopilot Fix - Need Ideas

Since you are not getting the information from either the rudder positioning feedback or the fluxgate compass there has to be a common link between the two. The only link I can think of is the voltage to the system. Check the voltage at the control head and also going to these two independant system components at the component. A bad conection will still show continuity but can drop the useable voltage below the required amount at the component.
__________________
The basis of accomplishment is in never quitting
Mengzi Meng-tse
Lancerbye is offline   Reply With Quote
Old 21-10-2011, 09:26   #7
Senior Cruiser

Cruisers Forum Supporter

Join Date: Mar 2007
Location: Santa Cruz
Boat: Boatless Again
Posts: 4,315
Re: Autopilot Fix - Need Ideas

Quote:
Originally Posted by Lancerbye View Post
Since you are not getting the information from either the rudder positioning feedback or the fluxgate compass there has to be a common link between the two. The only link I can think of is the voltage to the system. Check the voltage at the control head and also going to these two independant system components at the component. A bad conection will still show continuity but can drop the useable voltage below the required amount at the component.
a big +1 on this advice, especially if things check out at the shop (where there is enough power). OTOH, I have heard of B&G pilot compass failures...I have also seen similar problems when the compass is mounted near a magnet.
__________________
donradcliffe is online now   Reply With Quote
Old 21-10-2011, 09:59   #8
Senior Cruiser
 
Lancerbye's Avatar

Cruisers Forum Supporter

Join Date: Mar 2007
Location: Ladysmith,BC, Vancouver Island , Canada
Boat: Lancer 44 Motorsailer
Posts: 1,757
Images: 32
Re: Autopilot Fix - Need Ideas

Quote:
Originally Posted by donradcliffe View Post
a big +1 on this advice, especially if things check out at the shop (where there is enough power). OTOH, I have heard of B&G pilot compass failures...I have also seen similar problems when the compass is mounted near a magnet.
Also a big plus on the magnet close to fluxgate compass. The only time I ever had a problem with my system was when my late wife ordered and installed a magnetic mattress pad on our bed. She was a sucker for a good sales pitch. The fluxgate compass is installed at the foot of the bed and was about a foot away from the magnetic pad. This caused a bit of head scratching until I discovered what had happened.
__________________
The basis of accomplishment is in never quitting
Mengzi Meng-tse
Lancerbye is offline   Reply With Quote
Old 27-10-2011, 18:10   #9
DRS
Registered User
 
DRS's Avatar

Join Date: Jun 2009
Location: Vancouver BC
Boat: Lagoon 380
Posts: 351
Images: 7
Re: Autopilot Fix - Need Ideas

So here's the update. We hired another "expert" who looked at the system and declared the connections were not up to ABYC standards. Re-did the conections and the pilot is working
__________________
You can sail anywhere on the planet and never be more than 7 miles from land - it might be straight down, but its never more than seven miles
DRS is offline   Reply With Quote
Old 27-10-2011, 22:44   #10
Senior Cruiser

Cruisers Forum Supporter

Join Date: Mar 2007
Location: Santa Cruz
Boat: Boatless Again
Posts: 4,315
Re: Autopilot Fix - Need Ideas

Thanks for sharing that with us. Yet another case where corroded connections are the root cause--something you can look for before you call in the $expert$.
__________________

__________________
donradcliffe is online now   Reply With Quote
Reply

Tags
autopilot

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autopilot Track Following RobbieW OpenCPN 50 10-10-2012 08:23
Dodgy Autopilot Question stevensuf Engines and Propulsion Systems 9 10-10-2011 18:50
Autopilot Options Rakuflames Navigation 13 20-09-2011 23:15
Sending 'Go to Here' Active Route to an Autopilot Sail323 OpenCPN 11 01-08-2011 16:44
Route Properties, Missing Functions James Baines OpenCPN 13 13-07-2011 05:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:49.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.