Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 27-02-2014, 16:34   #1
Registered User

Join Date: Dec 2013
Posts: 16
Autohelm st4000 tiller

I have a Cal 34 with the Autohelm st4000 tiller that works fine. The small screen on the bulkhead sometimes reads fine, then becomes unreadable.
Sometimes if I manipulate the screen, it will go back to compass readout, then back to random figures.
Has anyone had this problem?
Is there anyone that repairs the head unit on these old systems.
Is it possible it's a poor connection on the back of the unit?
I'm not electronically inclined, but I'm open to suggestions to troubleshoot.
Thanks in advance for your help,
930chef is offline   Reply With Quote

autohelm, helm

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 00:21.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.