Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 12-12-2017, 13:41   #1
Registered User

Join Date: Dec 2017
Posts: 1
Auto Helm Problem

Hi everyone, I have a Raymarine ST 2000 Autohelm, it is operational, even thou the compass readout on the screen is incorrect, it continually sounds a high pitch alarm when in use, is anyone aware of what my problem could be, any info would be appreciated
Regards Brad
Adelaide
South Australia
__________________
Brad Fehring is offline   Reply With Quote
Reply

Tags
helm

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
raymarine auto helm problem. hunter36e Our Community 1 25-02-2017 13:06
For Fun: Helm Steer or Helm Tiller ? GaryMayo General Sailing Forum 57 15-05-2016 09:15
Auto Helm 4000st Help amosrad Marine Electronics 0 06-07-2010 06:30
Ray Marine auto helm resistor info needed Stress Knot Meets & Greets 2 05-08-2008 18:20
Windvane or auto-helm? kingfish General Sailing Forum 8 27-08-2004 09:15



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:40.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.