Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 10-10-2011, 22:02   #1
Registered User

Join Date: Oct 2011
Posts: 2
Plumbing or Electronic Problem ?

Recently bought a yacht ...everything worked fine then the main head stopped working...checked the macerator on the car battery and it's working... Now the pump out is unresponsive too. We've checked and replaced all fuses and are laymanly stumped...don't know whether to get in an electrician or a plumber...any ideas anyone?

amy3libras is offline   Reply With Quote
Old 10-10-2011, 22:18   #2
Registered User
svBeBe's Avatar

Join Date: Sep 2008
Location: from Houston, TX; currently berthed in Barcelona, headed west
Boat: Amel SM 53 - BeBe
Posts: 946
Re: plumbing or electronic problem?

Sort of difficult to give you any advice because you do not give specific info. Assuming you have a Jabsco 37072-0094 or similar which is mounted on the side of the toilet...

These last about 2-3 years before the seal starts leaking. In 4 out of 5 tries, replacing the seal did not work because the damage was already done.

If this is the type of mascerator pump you have, and you plan to keep the boat more than 3 years, it would not hurt to buy a spare. If you do not need to install it now, you will withing 3 years.

Before removing the old pump pump out all the water in the may need a shop vac to do this. Place a 20% solution of Clorox/water in the toilet for 30 minutes, then pump that out. When removing the pump, be prepared for about 1/4-1/2 cup of water which you did not get out. Place the now removed pump in a bucket and take it to where you can first clean it with Clorox/water then inspect it. The blades on these pumps are problematic as well as the seal. If the nut holding the blade is stripped, not much you can do, but replace the entire pump. When re-installing use some silicone grease on the O ring and tighten, but do not over-tighten the pump. It is sometimes difficult to align this O ring and get the proper may take several tries before it seals without check for leaking you will have to add water...if it leaks, start over again. Be careful that you do not reverse polarity, because reversing polarity reverses the motor and blade...The pump will not work properly with polarity reversed.

Hope this helps.


svBeBe is offline   Reply With Quote
Old 10-10-2011, 22:30   #3
Sponsoring Vendor
HopCar's Avatar

Community Sponsor
Cruisers Forum Supporter

Join Date: May 2011
Location: Miami Florida
Boat: Ellis Flybridge 28
Posts: 2,783
Re: Plumbing or Electronic Problem ?

I think the folks on this Forum will need more details in order to make useful suggestions. Are you saying that you have an electric toilet with a built in macerator pump that won't run when connected to the boats electrical system but will run if you connect it directly to a battery? "Now the pump out is unresponsive too." Do you mean that you have a second pump to empty the holding tank that's not working or you can't empty the tank through the deck fitting?
The short answer to your question is you need someone who is both an electrician and a plumber, that's a good boat repair guy or gal (Hi Peggie Hall).
Hopkins-Carter Marine Supplies & Fishing Tackle
What You Need, at the Price You Want...with Service!
HopCar is offline   Reply With Quote
Old 10-10-2011, 22:35   #4
Registered User

Join Date: Oct 2011
Posts: 2
Re: Plumbing or Electronic Problem ?

Thank you both... When i get home I'll get those details
amy3libras is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Raytheon ST5000+ Problem Capt.Don Marine Electronics 13 21-10-2013 13:31
Electronic Navigation Chart Plotting Technology Mariners Navigation 2 29-09-2011 10:25
Plumbing Help ! mbird59 Plumbing Systems and Fixtures 12 25-07-2011 19:36
Computer Problem ... Salt and Moisture canucksailor Marine Electronics 7 08-07-2011 19:20
Problem Since 2.2.918 - Garmin Won't Work MarkJ OpenCPN 28 29-06-2011 17:40

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:47.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.