Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 27-05-2018, 05:48   #1
Registered User

Join Date: May 2018
Posts: 1
Multiple pumps running

I have had a leak that triggered a bilge pump that triggered an overheating alarm when it run dry for a while.
The problem I encounter is that all four bilge pumps on my Phantom 50 are running and overheating even if all switches seem to work properly.
I have disconnected the one that triggered the others but when I put the power back on, all 3 start to run dry and trigger the alarm.
Any suggestions on how to solve this problem ?
Giacomo52 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple propane devices, multiple solenoids? jpendoley Plumbing Systems and Fixtures 18 03-04-2017 20:18
Pumps, pumps and more pumps. Winf Plumbing Systems and Fixtures 13 07-03-2016 08:43
Raw water intake to multiple pumps? Captndan714 Plumbing Systems and Fixtures 9 26-03-2013 20:06
Multiple Batteries, Multiple Banks, Single Charger dakno Electrical: Batteries, Generators & Solar 3 06-06-2010 10:45



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:05.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.