Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 22-08-2011, 14:34   #1
Registered User

Join Date: Jul 2010
Location: Antigonish, Nova Scotia
Boat: Mirage 32
Posts: 45
Standard Horizon CP300 I Screen Went Blank

My screen on my CP-300 chart plotter went black. The unit is powering up and I can hear it beeping as I go through the functions, but the screen is blank, ie black. Anyone have any ideas?
__________________

__________________
Gerry Connolly is offline   Reply With Quote
Old 22-08-2011, 15:46   #2
Registered User
 
sded's Avatar

Join Date: May 2006
Location: San Diego
Boat: J40 #33 since 1987
Posts: 228
Re: Standard Horizon CP300 I Screen Went Blank

Does turning it on and off a few times help? Using the red button instead of power on/off also seems to make some difference. I have occasionally been having a similar problem with a CP180 (out of warranty, of course ). In any case SH seems to have very fast and responsive technical support at Welcome to StandardHorizon.com
__________________

__________________
sded is offline   Reply With Quote
Old 23-08-2011, 10:38   #3
Registered User

Join Date: Aug 2006
Posts: 37
Re: Standard Horizon CP300 I Screen Went Blank

Same thing happened to mine. On several occasions especially when zooming in and out. I talked to tech support and he didn't have any answers. On my installation the power connections hit a couple terminal strips. I went through all the power connections and tightened them. That seems to have cured my problem. I believe a poor connection created a high resistance open, when zooming, the processor in the unit draws more current, causing an excessive voltage drop across the poor connection and causing things to shut down. Then it would reboot automatically all by itself.
On this same issue of connections on my boat I add a dab of dielectric anti corrosive grease to the matting surfaces of the spade and lug terminals. When tightened the grease forms a hermetic seal around the points of contact and will maintain a corrosion free connection. This is especially important using non tinned wire or connectors. If using non tinned wire, before you crimp, dip the end of the bare wire into the grease. This method will maintain the integrity of your boat wiring.
__________________
saben is offline   Reply With Quote
Old 23-08-2011, 12:27   #4
Registered User

Join Date: Jul 2010
Location: Antigonish, Nova Scotia
Boat: Mirage 32
Posts: 45
Re: Standard Horizon CP300 I Screen Went Blank

Thanks, that's very interesting and I'll have to try and beef up the electrical connections. The location of the plotter connection is easily bumped. Just started out of the blue. The plotter came with a new to us boat we bought last fall, though our previous boat had a CP180. (no problems) I 'm also attempting to get a diagnosis from SH at their help website.
Thanks all.

Gerry
__________________
Gerry Connolly is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: VHF / AIS Standard Horizon GX2100 GerardCBourque Classifieds Archive 8 27-09-2011 14:55
Want To Buy: Standard Horizon WS50 Wind System sunodyssey Classifieds Archive 1 19-07-2011 13:45



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:31.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.