Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 03-07-2016, 14:26   #1
Registered User

Join Date: Apr 2013
Posts: 80
westerbeke problems

own a westerbeke gen set after it over heated and auto shut down the temp gauge stayed at 220 and will not return to 0 changed out the temp sensor but no help.
roberthowell is offline   Reply With Quote
Old 03-07-2016, 18:12   #2
Registered User

Join Date: Feb 2013
Location: Lago de Izabal, Guatemala
Boat: Seafarer36c
Posts: 4,371
Re: westerbeke problems

It's probably the stupid gage, it has a switch inside that has failed.
Ecos is offline   Reply With Quote
Reply

Tags
westerbeke

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Westerbeke/Universal Diesel Engine Problems... Stowe18 Engines and Propulsion Systems 11 08-05-2016 06:35
Westerbeke 44B starter problems AnnOMalleys Engines and Propulsion Systems 19 17-09-2015 18:33
Westerbeke 4.0bcd Problems jrelaford Electrical: Batteries, Generators & Solar 0 15-08-2011 07:10
Westerbeke Generator problems Capt. Rich Electrical: Batteries, Generators & Solar 3 07-06-2011 14:24
Westerbeke Generator and Battery Charger Problems SAIL23692 Electrical: Batteries, Generators & Solar 0 30-01-2011 08:31



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 03:27.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.