Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 20-07-2017, 02:52   #1
Registered User

Join Date: Apr 2011
Posts: 33
Selden batten car problem

Hi

I'm having an issue with the lugs releasing from the batten cars. There is a U shaped pin that locates the lugs and I think they are working up and releasing the lug. The system has behaved itself for the last 18 months of ownership and this has now happened twice in 3 days. The only thing I've done to upset it was application of maclube a week ago to make it all drop in the bag more freely as the cars were getting a bit sticky.
Any ideas?, the pins all look fine.
Williamp is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Selden in Mast Furler Problem patprice Deck hardware: Rigging, Sails & Hoisting 7 02-06-2016 20:50
410: Headboard Batten car ozsailer Lagoon Catamarans 3 01-11-2014 02:16
Selden mast car to Forespar Whisker pole? nofacey Deck hardware: Rigging, Sails & Hoisting 1 19-05-2014 01:36
Want To Buy: Fredrickson Mainsail Batten Car PBChappell Classifieds Archive 0 10-06-2011 19:33



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 09:57.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.