Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 18-09-2012, 00:30   #1
Registered User

Join Date: Sep 2012
Location: Renwick N Z
Boat: Lotus 9.2
Posts: 1
Question Water not getting to bowl from pump

Hi, I cannot get raw water from from my pump to the bowl. If I put my hand over outlet there is wateer there pushing my hand off but when I replace the pipe the water doesn't go through. I have checked the pipe and poured water dowm it and it goes into the toilet. If I manualy fill the bowl it pumps away nicely. The brand is an older one possible Jasco.
any idea?
Capt Kirk
Capt Kirk is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:32.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.