Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-05-2019, 09:52   #1
Registered User

Join Date: Jul 2017
Posts: 203
Pressure Water Pump

The Pressure Water Pump in my boat seems to not be working.
When I winterize the boat for winter, the pump was working fine. To winterize, I emptied the water system and poured three or four gallons of antifreeze (the one for water systems), then run it through the lines.

As I am now trying to de-winterize and flush the antifreeze out, I can hear the Pressure Water Pump working, but there is very little pressure (I filled the tank again), just a little more than a trickle, albeit constant.

I am really not familiar with water pumps, so I am not even quite sure where to start. Does it sound like the pump is gone? The pump is almost new. What can it be the problem? Can pumps be fixed or is it common to simply replace them when they start showing issues?

Thank you!
__________________

FabioC is offline   Reply With Quote
Old 05-05-2019, 09:59   #2
Registered User
 
AndyEss's Avatar

Join Date: Dec 2016
Location: Sea of Cortez/northern Utah/ Wisconsin/ La Paz, BCS
Boat: Hans Christian 38 Mk II
Posts: 360
Images: 1
Re: Pressure Water Pump

It sounds like you have an air locked pump. Try priming it by disconnecting the input hose, fill the pump with water, and put the hose back on.
You might have to repeat this process several times.
__________________

AndyEss is offline   Reply With Quote
Old 05-05-2019, 10:01   #3
Registered User

Join Date: Nov 2012
Location: Long Beach, CA
Boat: Tayana Vancouver 42
Posts: 2,229
Re: Pressure Water Pump

If you have an in-line filter it may be clogged. If so open it and change the filter.
Tayana42 is offline   Reply With Quote
Old 05-05-2019, 18:18   #4
Registered User

Join Date: Mar 2017
Location: Richmond, VA
Boat: Carver 356
Posts: 198
Re: Pressure Water Pump

Quote:
Originally Posted by Tayana42 View Post
If you have an in-line filter it may be clogged. If so open it and change the filter.
2nd that. If you have an inline filter, most likely it will be between the tank and pump.
Have you checked the bilge to make sure you don't have a leak in the line somewhere?
Also, any chance your vent is clogged? An easy test, just take off the water tank fill cap and if the water runs better, you have a vent issue.
Chuck34 is offline   Reply With Quote
Reply

Tags
pump, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressure water system wonít hold pressure, runs continuously chuck g Plumbing Systems and Fixtures 19 05-08-2018 17:51
Send Over-Pressure Shore Water Over the Side with Pressure Valve ? sdowney717 Plumbing Systems and Fixtures 7 28-06-2018 17:45
Pressure water pump overpowers hot water tank NorthPacific Plumbing Systems and Fixtures 18 11-11-2014 00:14
For Sale: Brand New Whale AP0816 Agri-Pump 12VDC Water Pressure Sprayer Pump v62cobra Classifieds Archive 0 15-12-2012 10:41
Three-Prong Oil Pressure Switch and Electric Fuel Pump - Is a Fuel Pump Relay Needed? sdowney717 Electrical: Batteries, Generators & Solar 4 29-09-2011 07:06



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 06:06.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.