Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 30-01-2019, 20:09   #1
Registered User

Join Date: Jan 2019
Posts: 2
No flow from Spectra Newport 400 water maker

Hi guys,

I have a new to me, 2004 Riviera 40with a Spectra Newport 400 water maker fitted. The unit shows 185hr of operation in total and I am unsure of what usage or maintenance the unit has had.

I have changed the pre filters and cleaned the sea strainer but cannot get the unit to pump sea water. Seacock is open, pressure relief valve open and pump making noise. I do get water flowing via the brine discharge when doing a fresh water flush so I don't think it is a pump priming issue.

I suspect the flow when fresh water flushing is due to the main house sea water pump rather than the pump from the water maker.

Can anyone shed any light on this? It would seem to be a problem with the pump although it does sound to be running normally.

AB
__________________

aquabogan is offline   Reply With Quote
Old 30-01-2019, 20:23   #2
Senior Cruiser

Cruisers Forum Supporter

Join Date: Jul 2005
Location: Bellingham
Boat: Outbound 44
Posts: 7,270
Re: No flow from Spectra Newport 400 water maker

Try doing the fresh water pressurized flush with the pump running. You should hear it get primed. Then with it running turn the valve back to seawater. See if this starts the prime. Probably need the high pressure release open too.
__________________

__________________
Paul
Paul L is offline   Reply With Quote
Old 04-02-2019, 05:16   #3
Sponsoring Vendor
 
Tellie's Avatar

Community Sponsor

Join Date: Oct 2007
Location: Hollywood, Fl.
Boat: FP Athena 38' Poerava
Posts: 3,322
Re: No flow from Spectra Newport 400 water maker

Quote:
Originally Posted by aquabogan View Post
Hi guys,

I have a new to me, 2004 Riviera 40with a Spectra Newport 400 water maker fitted. The unit shows 185hr of operation in total and I am unsure of what usage or maintenance the unit has had.

I have changed the pre filters and cleaned the sea strainer but cannot get the unit to pump sea water. Seacock is open, pressure relief valve open and pump making noise. I do get water flowing via the brine discharge when doing a fresh water flush so I don't think it is a pump priming issue.

I suspect the flow when fresh water flushing is due to the main house sea water pump rather than the pump from the water maker.

Can anyone shed any light on this? It would seem to be a problem with the pump although it does sound to be running normally.

AB



Sounds like you feed pump is decoupling. When this happens your feed pump motor will still run but it will not turn the pump.
Tellie is offline   Reply With Quote
Old 05-02-2019, 05:11   #4
Registered User

Join Date: Jan 2019
Posts: 2
Re: No flow from Spectra Newport 400 water maker

Hi guys thanks for the reply.

The pump was decoupling. It is a Procon Pump head PL-PMP140175E. The brass coupling tang is broken with bits stuck in the pump head and motor. Pump head looks to be seized. I am in Tasmania, Australia and I suspect finding a local replacement will be difficult. I also suspect this is an older style pump. Is there a new motor/pump which would be a bolt in replacement or should I try to chase down a new pump head and tang and extra the brass coupling (looks like it won't be easy!)

Thanks again,

AB
aquabogan is offline   Reply With Quote
Old 05-02-2019, 06:56   #5
Registered User

Join Date: Dec 2018
Posts: 11
Re: No flow from Spectra Newport 400 water maker

Hi. You can source parts and advice from Southern Seas Marine. Australian distributor for Spectra.
STELLA31 is offline   Reply With Quote
Old 06-02-2019, 03:21   #6
Sponsoring Vendor
 
Tellie's Avatar

Community Sponsor

Join Date: Oct 2007
Location: Hollywood, Fl.
Boat: FP Athena 38' Poerava
Posts: 3,322
Re: No flow from Spectra Newport 400 water maker

This may be a tough nut to crack finding a replacement pump. Spectra long ago discontinued the use of this type of drive on it's pumps and no longer supports it's replacement. You have a direct drive pump now, the replacement would be a new magnetic drive pump. This would mean the replacement of both the feed pump and the motor. But it will bolt in as a direct replacemnt for your current pump and motor.
Tellie is offline   Reply With Quote
Reply

Tags
newport, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
400: Lagoon 400 Spectra water maker cape horn installation katsumi Lagoon Catamarans 3 17-09-2017 03:31
Want To Buy: Spectra Newport 400 mk11 Clarke pump Overlord Classifieds Archive 1 02-02-2015 12:16
Spectra Watermaker Newport 400 sailnbyu Plumbing Systems and Fixtures 9 06-01-2014 07:28
For Sale: Spectra Newport 400 12V Watermaker $4500.obo whatever Classifieds Archive 2 29-10-2013 07:08
Spectra Watermaker Newport 400 whatever Classifieds Archive 0 20-08-2013 06:13



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 17:57.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.