Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 27-02-2019, 08:31   #1
Registered User

Join Date: Aug 2012
Posts: 132
Newport 400 vane pump noise and low flow.

I have an older NP 400 that sat for many years. I replaced the clark pump o rings and membrane. The system has made water for 6 months. Recently the Vane pump has been making more noise. I have checked for leaks and replaced the filters.

Now the pump is making a lot of noise. I have disconnected the vane pump the motor makes normal noise. I have the direct drive vane pump which is rusty inside.

Has anyone rebuilt or taken the direct drive apart?

How does one reach Tellie? Does he have a contact number?

Off in Mex.

Thanks

Gavin
canadian cat is offline   Reply With Quote
Old 27-02-2019, 17:14   #2
Sponsoring Vendor
 
Tellie's Avatar

Community Sponsor

Join Date: Oct 2007
Location: Hollywood, Fl.
Boat: FP Athena 38' Poerava
Posts: 3,336
Re: Newport 400 vane pump noise and low flow.

I'm here, but the news I'm afraid isn't great. The direct drive pump heads haven't been used for years and are no longer supported. You would need to replace the pump and motor to upgrade your system to a Mag drive system. But just in case you haven't checked, look for any air ingress leaks from bad clamps, bad fittings, etc. from the intake thru hull to the input of the feed pump. These pumps will make a lot of racket if air gets into them. They sound like a coffee can full of nuts and bolts. But once the air ingress is resolved they will quiet right down.


You can always PM me as well.
Tellie is offline   Reply With Quote
Old 28-02-2019, 06:09   #3
Registered User

Join Date: Aug 2012
Posts: 132
Re: Newport 400 vane pump noise and low flow.

Hi Tellie

Thanks for responding. I have the procon vane pump apart and 3 of the 4 vanes were loose inside. Hence the low flow. I am going to clean it up and try the pump and see what happens. If not I will see if I can get a rebuild kit. A new pump is not terrible at $313.00 from Edco
I also have two Sureflow 125PSI pumps on their way as I didn't trust the vane pump after sitting for so long.

Question for you Tellie will my MPC 5000 run the Sureflow pumps or will I need to run in manual?
canadian cat is offline   Reply With Quote
Reply

Tags
newport, noise, pump

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No flow from Spectra Newport 400 water maker aquabogan Plumbing Systems and Fixtures 5 06-02-2019 03:21
[SOLD] newport 400 spectra pump LornaS General Classifieds (no boats) 4 15-11-2016 15:52
Low Flow Water Circulation Pump Suggestions chouliha Plumbing Systems and Fixtures 1 21-09-2016 13:41
Want To Buy: Spectra Newport 400 mk11 Clarke pump Overlord Classifieds Archive 1 02-02-2015 12:16
High air flow / low battery consumption? Doghouse General Sailing Forum 28 15-05-2006 12:33



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 21:34.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.