Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 19-10-2014, 07:40   #1
Registered User

Join Date: Sep 2014
Location: Conquerall Bank Nova Scotia
Boat: Catalina 30
Posts: 60
Newbie error

Hello all
I recently purchased my 1978 C30 and hauled it out for winter , I thought the PO had pumped the black water tank out before I bought it but to my dismay Ive discovered its full. My question is how to go about emptying this. The system has a macerator installed, is this what pumps it o/b?
Many Thanks
Peter
__________________
Peters Wet is offline   Reply With Quote
Old 19-10-2014, 08:06   #2
Moderator
 
HappyMdRSailor's Avatar

Cruisers Forum Supporter

Join Date: May 2008
Location: North Mississippi
Boat: 48 Wauquiez Pilot Saloon-C22 Chrysler Sunpiper- 19 Potter-Preparing to cruise w/my girl
Posts: 5,980
Re: Newbie error

Quote:
Originally Posted by Peters Wet View Post
Hello all
I recently purchased my 1978 C30 and hauled it out for winter , I thought the PO had pumped the black water tank out before I bought it but to my dismay Ive discovered its full. My question is how to go about emptying this. The system has a macerator installed, is this what pumps it o/b?
Many Thanks
Peter
Oh man... is this ever a shi**y situation!

Uh-yep... But pumping with the macerator is going to leave you juggling a bucket or barrel under the thruhull.... I couldn't imagine how fun that would be...

I'd ask around at the yard... Can't be the first time this happened there... Worst case, I'd call one of the porta toilet guys and see if you can get them to come by...

***google the freezing point and properties***
__________________
In the harsh marine environment, something is always in need of repair...

Mai Tai's fix everything...
HappyMdRSailor is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello Newbie Here with Newbie Questions tbc0460 Cruising News & Events 1 23-05-2011 15:15
Error uploading to photo gallery knottybuoyz Forum Tech Support & Site Help 2 16-08-2007 11:23
Run-Time Error Messages Entlie Forum Tech Support & Site Help 17 13-12-2006 06:21



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 09:12.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.