Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 29-12-2013, 12:05   #1
Registered User

Join Date: Sep 2011
Location: Toronto
Boat: Viking 44
Posts: 183
jabsco electric head problems

We have a Jabsco electric head and it does not seem to flush properly, I put a new motor on it, cleaned out the joker value, but when you pee in it, the pee seems to just recycle itself and stay in the bowl even though water is going in and out of the unit. Anyone know if a solution to this problem.
__________________

__________________
edbulmer is offline   Reply With Quote
Old 29-12-2013, 14:21   #2
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Albany Ga.
Boat: Island Packet 38
Posts: 17,037
jabsco electric head problems

May be a stupid question, but you sure the water isn't pee colored? Food coloring would tell for sure
__________________

__________________
a64pilot is offline   Reply With Quote
Old 29-12-2013, 14:31   #3
Registered User

Join Date: Sep 2011
Location: Toronto
Boat: Viking 44
Posts: 183
Re: jabsco electric head problems

no we have tried colored water, it just recycles in the bowl.
__________________
edbulmer is offline   Reply With Quote
Old 29-12-2013, 14:41   #4
Registered User

Join Date: May 2008
Location: daytona beach florida
Boat: csy 37
Posts: 2,844
Images: 1
Did you put the joker valve in facing the right direction?
__________________
Take two at low eight
onestepcsy37 is offline   Reply With Quote
Old 29-12-2013, 14:46   #5
Registered User

Join Date: Sep 2011
Location: Toronto
Boat: Viking 44
Posts: 183
Re: jabsco electric head problems

yes, it can only go one way
__________________
edbulmer is offline   Reply With Quote
Old 29-12-2013, 14:48   #6
Registered User

Join Date: Jan 2011
Location: Geelong, Victoria, Australia
Boat: Hunter 40 Legend
Posts: 169
Re: jabsco electric head problems

When you say you put a new motor on it, did that include a pump set?

It sounds like the seal between the raw water suction pump (the rubber impeller one) and the discharge pump (with the macerator) is faulty. It is only a small flat rubber washer. It wears on the shaft and leaks between the two pumps. This leakage prevents raw water being sucked up to flush the bowl and just recycles the bowl contents.
__________________
Regards Craig
40 South is offline   Reply With Quote
Old 29-12-2013, 15:50   #7
Sponsoring Vendor
 
HopCar's Avatar

Community Sponsor
Cruisers Forum Supporter

Join Date: May 2011
Location: Miami Florida
Boat: Ellis Flybridge 28
Posts: 3,157
Re: jabsco electric head problems

Jabsco makes several electric toilets, but assuming yours is the common 37010 series toilet, Craig is right. About the only way urine could recirculate is if the seal between the intake pump and discharge pump has failed. Following is a link to the owners manual for that toilet. If you scroll down to the parts list, the seal in question is number 19 on the drawing.
http://www.xylemflowcontrol.com/file...43000-0612.pdf
__________________
Hopkins-Carter Marine Supplies & Fishing Tackle
What You Need, at the Price You Want...with Service!
HopCar is online now   Reply With Quote
Old 29-12-2013, 16:08   #8
Registered User

Join Date: Sep 2011
Location: Toronto
Boat: Viking 44
Posts: 183
Re: jabsco electric head problems

Bingo, you guys are awseome. Now where can I find one? Would I just goole Jabsco suppliers?
__________________
edbulmer is offline   Reply With Quote
Old 29-12-2013, 16:21   #9
Sponsoring Vendor
 
HopCar's Avatar

Community Sponsor
Cruisers Forum Supporter

Join Date: May 2011
Location: Miami Florida
Boat: Ellis Flybridge 28
Posts: 3,157
Re: jabsco electric head problems

Send me an email through my website, hopkins-carter.com, with your address and I ask my friend at Jabsco if she can just mail you one.
__________________
Hopkins-Carter Marine Supplies & Fishing Tackle
What You Need, at the Price You Want...with Service!
HopCar is online now   Reply With Quote
Old 29-12-2013, 17:01   #10
Registered User

Join Date: Sep 2011
Location: Toronto
Boat: Viking 44
Posts: 183
Re: jabsco electric head problems

I'm clicking on your website on contact us but nothing is happening.
Also the intake and discharge unit on my toilet the 37100 series are one unit and this whole unit was replaced last year. Would it still be this washer?
__________________
edbulmer is offline   Reply With Quote
Old 29-12-2013, 18:32   #11
Senior Cruiser
 
DeepFrz's Avatar

Cruisers Forum Supporter

Join Date: Mar 2006
Location: Winnipeg
Boat: None at this time
Posts: 7,930
Re: jabsco electric head problems

It works for me. The site asked how I want to send the email, I chose gmail and it brought up my account and a new email with the address filled in. Using FF.
__________________
The Blue Dot Campaign. This Changes Everything.
DeepFrz is offline   Reply With Quote
Old 29-12-2013, 19:43   #12
Registered User

Join Date: Sep 2011
Location: Toronto
Boat: Viking 44
Posts: 183
Re: jabsco electric head problems

still can't get it to work. I will send you a pm.
__________________
edbulmer is offline   Reply With Quote
Old 29-12-2013, 20:26   #13
Senior Cruiser
 
Captain Bill's Avatar

Cruisers Forum Supporter

Join Date: Apr 2008
Location: On the boat
Boat: Endeavourcat Sailcat 44
Posts: 2,313
Re: jabsco electric head problems

This is occurring on one of our heads right now, but we know that the hose to the holding tank is mostly clogged with deposits and needs to be changed. It's on this week's todo list..... The fun just never seems to end.
__________________
Captain Bill is offline   Reply With Quote
Old 29-12-2013, 22:39   #14
Sponsoring Vendor
 
HopCar's Avatar

Community Sponsor
Cruisers Forum Supporter

Join Date: May 2011
Location: Miami Florida
Boat: Ellis Flybridge 28
Posts: 3,157
Re: jabsco electric head problems

Lets try this, hopcar marine at yahoo dot com. Take out the spaces and put in the little @ thing.

Ed I don't know the 37100. It's not in my catalog. Are you sure yours isn't a 37010?
The 37010 has one motor with a long shaft that drives a rubber impeller intake pump, a centrifugal discharge pump and a set of chopper blades. It's the seal between the discharge pump and the rubber impeller pump that we think might be your problem.

Capt. Bill brings up a good point. If there is back pressure caused by a clogged discharge line, it would try to push sewage past the seal in question. You should check that the discharge hose is clear all the way to the tank. Check the tank vent as well. That might be what caused the seal to fail.
__________________
Hopkins-Carter Marine Supplies & Fishing Tackle
What You Need, at the Price You Want...with Service!
HopCar is online now   Reply With Quote
Old 30-12-2013, 18:12   #15
Registered User

Join Date: Sep 2011
Location: Toronto
Boat: Viking 44
Posts: 183
Re: jabsco electric head problems

I put on a new pump/motor that I was going to put in another head and still the same problem. So I now know it's not the seal. Could it be a blockage that would do this. I do see swirling and it looks like it's trying to flush but nothing seems to be going anywhere. Could I use a snake on it? I just bought a powered one.
__________________

__________________
edbulmer is offline   Reply With Quote
Reply

Tags
electric, head, jabsco

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 22:45.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.