Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-11-2011, 14:39   #1
Registered User

Join Date: Nov 2011
Posts: 3
I Need Help !

I have a 42 foot lagoon catamaran. The toilet was leaking so I took the motor off and replaced the O ring. After I replaced the O ring it flushed 2-3 times and I'm guessing a fuse blew, but I can't find it for the life of me. All of the other toilets on board work and the fuse from the masorator toilet does not seem to be blown. I must be missing a fuse. Can Anyone help? Please!!!!!
__________________

__________________
damienmerk859 is offline   Reply With Quote
Old 16-11-2011, 14:41   #2
Sponsoring Vendor
 
Tellie's Avatar

Community Sponsor

Join Date: Oct 2007
Location: Hollywood, Fl.
Boat: FP Athena 38' Poerava
Posts: 3,046
Re: I need help!!

Do you have a multi meter?
Tellie is offline   Reply With Quote
Old 16-11-2011, 14:52   #3
Registered User

Join Date: Nov 2011
Posts: 3
Re: I need help!!

Yes I do. There is no positive power running into the toilet but I do believe their is a ground. What else is strange is that everything else in the head seems to be working, the lights and suck. somewhere from the panel to the toilet something is breaking the circuit. I'm lost. I've been working on this all day on the water. Literally I'm covered in ****. I'm sure if I was in anyone else's shoes I would find humor in this.
__________________
damienmerk859 is offline   Reply With Quote
Old 16-11-2011, 14:52   #4
Registered User

Join Date: Nov 2010
Location: Lafayette, Louisiana
Boat: Ketch, Hardin 45
Posts: 440
Images: 6
Re: I need help!!

There may be a fuse you blew... But when I had similar problem, I found that there was a spade connector buried under the deck and had accidently pulled it apart. An easy fix, just pushed it back together.
So if there is any tape on the wires remove said tape and see why it is there.
__________________
boasun is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 05:32.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.