Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-06-2016, 06:45   #1
Registered User
 
Mayhemdog75's Avatar

Cruisers Forum Supporter

Join Date: Oct 2015
Location: Where ever the wind and tides take us!!!
Boat: 1968 Pearson P35
Posts: 40
Frigibar evaporator unit won't stay running

The system was working fine until yesterday and now the compressor tries to start up but quickly shuts off. We have plenty of battery power so I don't think the batteries are the issue. Anybody have any ideas to point me in the right direction to get it operating again?


Sent from my iPhone using Cruisers Sailing Forum
__________________

__________________
Mayhemdog75 is offline   Reply With Quote
Old 21-06-2016, 07:05   #2
Registered User
 
Mahaila's Avatar

Join Date: May 2011
Location: Los Angeles
Boat: C&C 38
Posts: 47
Re: Frigibar evaporator unit won't stay running

I had a very similar problem. Turned out to be too much resistance or something like that through the breaker or wiring. Didn't trip the breaker but suddenly the compressor wouldn't run more than a few seconds. Hooked power to another 12v source and all was good again.


Sent from my iPad using Cruisers Sailing Forum
__________________

__________________
Mahaila is offline   Reply With Quote
Old 21-06-2016, 07:23   #3
Registered User
 
Mayhemdog75's Avatar

Cruisers Forum Supporter

Join Date: Oct 2015
Location: Where ever the wind and tides take us!!!
Boat: 1968 Pearson P35
Posts: 40
Re: Frigibar evaporator unit won't stay running

Did you hook it up to a different breaker or different battery?
__________________
Mayhemdog75 is offline   Reply With Quote
Old 21-06-2016, 07:29   #4
Registered User
 
Mahaila's Avatar

Join Date: May 2011
Location: Los Angeles
Boat: C&C 38
Posts: 47
Re: Frigibar evaporator unit won't stay running

I simply ran a jumper wire from the power connection at the compressor to the battery bank. Since that worked I ran an independent wire from a 12v distribution lug with a fuse in the line. I haven't replaced the breaker yet so don't know if that was the problem but suspect it was.


Sent from my iPad using Cruisers Sailing Forum
__________________
Mahaila is offline   Reply With Quote
Old 21-06-2016, 07:32   #5
Registered User
 
typhoon's Avatar

Join Date: Feb 2007
Location: Toronto Canada
Boat: Bristol 45.5
Posts: 945
Images: 1
Re: Frigibar evaporator unit won't stay running

Sounds electrical. These little Danfoss compressors draw a great deal of current for a few milliseconds at startup , if during that startup period the control unit senses to much of a voltage drop it will shut down the the compressor.
You may have a bad connection that has corroded somewhere. Get a good piece of over sized wire and run it directly from your battery bank to the compressor + side and make a good ground on the - side bypassing all electrical components and try to start it up again , if it works , you know there is some thing wrong in your electrical hook up .

Regards
typhoon is offline   Reply With Quote
Old 21-06-2016, 07:48   #6
Registered User
 
Mayhemdog75's Avatar

Cruisers Forum Supporter

Join Date: Oct 2015
Location: Where ever the wind and tides take us!!!
Boat: 1968 Pearson P35
Posts: 40
Re: Frigibar evaporator unit won't stay running

Thanks guys. I will give it a go and see what happens. It makes the first mate very happy when we don't have to use ice for anything other than drinks!!
__________________
Mayhemdog75 is offline   Reply With Quote
Old 21-06-2016, 07:54   #7
Marine Service Provider
 
SV THIRD DAY's Avatar

Cruisers Forum Supporter

Join Date: Aug 2006
Location: La Paz, Mexico
Boat: 1978 Hudson Force 50 Ketch
Posts: 3,653
Re: Frigibar evaporator unit won't stay running

You should always run the power for your refrigeration compressor right from the unit to the positive and negative terminals of the battery, preferably battery terminals that DO NOT have anything else connected to them, like alternators, battery chargers, inverters or other heavy loads. The No 1 troubleshooting issue is electrical on these Danfoss units so do everything you can to eliminate it. Also...don't skimp on the electrical wiring in 14 or 16ga wire....ahhh...I wouldn't use anything below 10GA wire even for the shortest of runs. You want to shoot for less than 5% voltage drop when you consult the wiring size vs length chart.

Here is an electrical troubleshooting video and even if you have a different brand of unit, the troubleshooting for electrical is the same. At the 3:35 minute mark the error light discussion starts. At the 11:50 time mark, the 3-flash error code is explained along with troubleshooting for it.

__________________
Rich Boren Goodbye Morro Bay...Hello La Paz, Mexico and the owner of:
Cruise RO Water High Output Water
Technautic CoolBlue Refrigeration
SV THIRD DAY is offline   Reply With Quote
Old 21-06-2016, 21:08   #8
Registered User

Join Date: Aug 2010
Location: Hervey Bay Australia
Boat: Beneteau Oceanis 40
Posts: 25
Re: Frigibar evaporator unit won't stay running

Check your cooling fan. Had similar problem,
small computer like fan was not working and after replacing it all fine.
__________________

__________________
Australis is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone Have Experience with Frigibar? alanperry Plumbing Systems and Fixtures 7 02-06-2015 19:37
5 HP Yamaha won't stay running landonshaw Auxiliary Equipment & Dinghy 41 24-11-2014 10:02
Any Reviews on Frigibar Refrigeration ? oldbeachcomber Plumbing Systems and Fixtures 4 15-10-2012 08:17
For Sale: Frigibar Deck Freezer daddyo Classifieds Archive 0 20-10-2011 07:04
Frigibar Anyone? NorthPacific Plumbing Systems and Fixtures 1 17-10-2011 09:08



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 08:40.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.