Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-02-2008, 01:22   #1
Registered User

Join Date: Jan 2008
Location: Crete, Greece
Boat: Neptunian Ketch Calloo
Posts: 30
Eberspacher problem

Has anyone come across this one? We have an Eberspacher heater which when you turn it on it won't fire up. If you turn it on to blow for ventilation for a few seconds and then turn it to heat it lights up fine. I've checked connections. Anyone any ideas please?

Chris
__________________

__________________
Capt Hook is offline   Reply With Quote
Old 08-02-2008, 01:57   #2
Registered User
 
sundown's Avatar

Join Date: Sep 2005
Posts: 108
does it have a 'flame detector'? The detector is a photo sensor that can malfunction if it gets covered with soot/carbon residue. When the detector buggers up the furnace tries to fire-up - runs for a few seconds then shuts down.
__________________

__________________
sundown is offline   Reply With Quote
Old 08-02-2008, 04:47   #3
Registered User

Join Date: Apr 2006
Posts: 4,413
My experience with the old D3L is that they get sooted up inside and then the will not function. They need to be regularly taken apart and cleaned, apparently or they fail and heed the whole blower assembly replaced. They have all sorts of monitors and if the parameters are not met they won't fire up or will shut down.
__________________
Sandero is offline   Reply With Quote
Old 08-02-2008, 05:27   #4
Registered User

Join Date: Jan 2008
Location: Crete, Greece
Boat: Neptunian Ketch Calloo
Posts: 30
Ok thanks. I'll start with a stripdown and clean I think.

Chris
__________________
Capt Hook is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Serious problem bottleinamessage Electrical: Batteries, Generators & Solar 19 26-08-2007 11:39
Rudder Problem Perithead Monohull Sailboats 12 16-03-2007 16:31
Pump problem! h20nutt Plumbing Systems and Fixtures 0 24-10-2006 09:36



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 05:27.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.