Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 29-03-2009, 14:45   #16
Registered User

Join Date: Mar 2009
Posts: 2
Mac daddy email

Quote:
Originally Posted by mrfordsr View Post
I have a 2001 50' Gibson with two separate cruisair a/c units. The cooling water outflow on one has decreased to about 60% of the other one. The unit with the lower flow runs briefly and cycles off, shows a "high pressure" message on the control panel, cycles two more times with the same message and then shuts down. I have cleaned the strainer. That did not improve the outflow. Do I have an impeller problem? If so, can I replace the impeller or should I order a replacement pump? I am a novice large boat owner. I would appreciate any advice. This is my first post.

mwf7079@yahoo.com
__________________

__________________
macdaddy is offline   Reply With Quote
Old 30-03-2009, 18:48   #17
Registered User

Join Date: Nov 2007
Location: South East Asia
Boat: 122 year old Historical Sailing vessel
Posts: 121
Loads of good advice here this is a great thread. There are several possible sources of problems here. yes you could need an impeller change which is easy enough just do remember to lub the new impeller before you install it. The inlet and outlet hoses can be blocked with growth even inside the boat. I have had that problem happen where it almost completely blocked hoses. The outside strainer on the thru hull could be blocked. and lastly you could have growth inside the actual heat exchanger coils on the unit. I would first confirm that the ubit is properly gassed up, then start at the inlet and verify each step the water takes. and good luck I hope it is a crab that has taken up house keeping in the strainer.
__________________

__________________
H/V Vega is offline   Reply With Quote
Reply

Tags
cruisair

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yanmar 3QM30F Serial Number location? Raw Water Pump Problem... JohnnyB Engines and Propulsion Systems 14 27-06-2008 04:13
Problem with Water Tank Vents ssullivan Plumbing Systems and Fixtures 0 19-06-2008 15:26
Water pressure pump problem sneuman Construction, Maintenance & Refit 7 22-02-2008 09:10
Cruisair Question stuffinbox Plumbing Systems and Fixtures 7 16-11-2007 13:26
Pressurised Water System Problem Daymo Plumbing Systems and Fixtures 9 03-04-2007 11:08



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 23:02.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.