Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 27-06-2010, 20:42   #1
Registered User

Join Date: Jun 2010
Location: Kent Island Maryland / Chesapeake Bay
Boat: 1996 Crusier Yacht 3375 Esprit 37' LOA - Luv Shack
Posts: 1
Cruisair Air Conditioner / Heater Problems

Hello All,

I'm having an issue with my Cruisair AC system, after dropping the boat in the water this year the system will not work properly! I have the Cruisair SX-16 system, with the SMX II microprocessor air conditioning control! The problem when I turn the system on the control panel read 99 degrees, when I push cool and lower the temp to 75 the system kicks on, I have a good flow of water being pumped off the boat, within a few mintes the system shuts down, continues to blows air, stops pumping water and the display control unit runs back up to 99 dgrees!!!! Help!!! I talked with a Cruisair tech but was not that helpful, he thought it might be the SMX II microprocessor air conditioning control board but didn't make sense since the system would work then sut down..... Has anybody had a similar problem, any and all help is greatly appriciated!!
__________________

__________________
Irish Cruiser is offline   Reply With Quote
Old 01-07-2010, 16:53   #2
Senior Cruiser
 
osirissail's Avatar

Cruisers Forum Supporter

Join Date: Feb 2009
Location: A real life Zombie from FL
Boat: Gulfstar 53 - Osiris
Posts: 5,416
Images: 2
Unit shutdown with the pump and fan still working can be a compressor overheat problem due to an airblock or problem with the compressor heat sensor. Under normal conditions an inadequate waterflow could cause the problem.
- - Unless you have a duplicate system available to you so you can test the controller module, send it back to the manufacturer for testing. Micro-electronics are fancy and subject to failures or failure to function right out of the box. Having eliminated the controller as a problem make sure your water flow is reasonably dramatic by disconnecting the overboard hose if you cannot see the outside through-hull. A good steady stream should be coming out of the unit. If not, check your pump - they are typically centrifugal paddle type which are extremely inefficient at pushing water but not subject to burnout by pump jams. I recently went through 3 of them to get one to pump adequately.
- - Having eliminated controller and cooling water flow that leaves the unit itself with a fault somewhere. Which means removal and shipping back to the factory.
__________________

__________________
osirissail is offline   Reply With Quote
Old 29-05-2013, 22:52   #3
Registered User

Join Date: May 2013
Posts: 2
Re: Cruisair Air Conditioner / Heater Problems

I have a similar problem. After winterizing her and missing all of last year and trying the AC for the first time this year (and the heat too) I turn on the breaker, the LED quickly runs to 99 nad at first did nothing, Next time after 5 minutes the fan turned on, but not controls (Air, heat, fan speed, etc.) Last time same thing, thermo runs up to 99, fan came on immediatley, but no compressor, no controls, no output of water, nothing, just circulating the air. Please help. First boat with air and it is expected to be in the 90s Thursday-Sunday and me and the misses took the weekend off to enjoy. Thanks in advance
__________________
Dontbsme is offline   Reply With Quote
Old 30-05-2013, 01:38   #4
Registered User

Join Date: Jan 2013
Location: Puerto Vallarta, Mexico
Boat: Sovereign/28
Posts: 1
Re: Cruisair Air Conditioner / Heater Problems

Hi Dontbsme, I am trying to track down the particular Cruisair model that you have. Irish Cruiser indicated a SX-16, but it could be a RX-16, indicating that it has a SMX II micro-processor. What model is yours?
__________________
Fresco is offline   Reply With Quote
Old 30-05-2013, 03:42   #5
Registered User

Join Date: Sep 2010
Posts: 793
Re: Cruisair Air Conditioner / Heater Problems

I had a problem with similar symptoms, but it was a while ago and I forget the exact details. Also, it's an Emerald system with a Passport Elite control system, so there are enough differences to warrant taking my whole experience with a gain of salt.

Anyway, one of my temp control panels would walk up to a ridiculously high temp and the zone would stop working. I tried swapping in one of the other controls (there are three in my boat) and the problem went away, so I bought a replacement control.

Replaced the control and the problem reoccurred. Finally started digging into the control box on the compressor and discovered one of the phone-cord-like plugs for the controllers has a messed up contact. I don't remember if it was bent over or just jammed, but it was clearly not right. I got it straightened out and working properly and everything came back to life and has worked fine ever since.

This problem surfaced around year 3 of ownership.

So I'd suggest getting in there and checking all those plug-in connectors. You will need good eyes, good light, and a little itty bitty screw driver or pick to test each contact to be sure it's free and springy like it should be.
__________________
twistedtree is offline   Reply With Quote
Old 30-05-2013, 07:28   #6
Registered User

Join Date: May 2013
Posts: 2
Re: Cruisair Air Conditioner / Heater Problems

My exact model number is SXR10-M20 Thanks for the quick response... going down in 20 hoping for something 95 today and tomm. !!!
__________________
Dontbsme is offline   Reply With Quote
Old 30-05-2013, 12:00   #7
Registered User
 
mayball's Avatar

Join Date: Jul 2008
Location: Puerto Vallarta, Mexico & Denver, Colorado
Boat: Sovereign, 28
Posts: 47
Re: Cruisair Air Conditioner / Heater Problems

As I remember the function of the SMX II processor, it should display the ambient temp when you turn it on and remember the settings by the owner from the last time it was turned on. So the 99 degree display when it comes on does not sound right, unless this is a temporary display before ambient. The compressor and the pump should come on together, but only if the high and low pressure cut-outs and the timer are satisfied. Since the pump also is not coming on (no overboard water), it could be that you have a leak to the extent that the low pressure cut-out is open. If you have a leak, it is most likely at the service valve tap, where the rotolock is not securely back seated. This is usually evidenced by oil in the cap where you attach the hose. Since the low pressure cut-out opens before a vacuum is reached, there is no danger of air and moisture being pulled into the system, but the system needs to be charged with the required refrigerant to a suction pressure of 55 psig for it to cool.
__________________
mayball is offline   Reply With Quote
Old 02-08-2013, 22:25   #8
Registered User
 
Wench'sCaptain's Avatar

Join Date: Oct 2011
Location: On the Boat
Boat: Hunter Helsen 470
Posts: 132
Re: Cruisair Air Conditioner / Heater Problems

Since there seems to be a few of you that know something about ac, I have a problem and need some help. My water flow has become restricted with some algea or moss. What is the best way to clear this up. I am cleaning the strainer twice a week to keep it clean. I have tried adding Bromine to the strainer and that has kept it running but the flow is not what it was a week ago. Any advise or assistance is welcome.

Tom
__________________
Wench'sCaptain is offline   Reply With Quote
Old 03-08-2013, 02:05   #9
Senior Cruiser
 
osirissail's Avatar

Cruisers Forum Supporter

Join Date: Feb 2009
Location: A real life Zombie from FL
Boat: Gulfstar 53 - Osiris
Posts: 5,416
Images: 2
Re: Cruisair Air Conditioner / Heater Problems

First thing make sure that the hoses that are attached to it are opaque, that is, light cannot penetrate to the interior of the hoses. Light promotes the growth of algae, etc.

Beyond that, certain areas are biologically prolific which means organics grow rapidly due to fertilizer pollution and other factors. So the only way to reduce your problem is to move to an area where sea growth is much less/slower. Generally that is not practical so you are just stuck with the problem.

If your strainer and fittings are non-metallic, you can periodically add muriatic acid to the strainer to kill/dissolve the growth. But this is rather dramatic and can have a negative effect on the other parts of the a/c system. Some folks drop a swimming pool "chlorine" tablet into their strainer to help reduce the sea growth. But again be careful if you have a metallic strainer, etc.
__________________
osirissail is offline   Reply With Quote
Old 04-08-2013, 20:04   #10
Registered User
 
mayball's Avatar

Join Date: Jul 2008
Location: Puerto Vallarta, Mexico & Denver, Colorado
Boat: Sovereign, 28
Posts: 47
Re: Cruisair Air Conditioner / Heater Problems

My suggestion on the removal of algae and grass from the salt water side of the condenser circuit is to fill the strainer with muriatic acid, close the strainer, and immediately pump the acid through the circuit and overboard. Any system that is designed to handle salt water on a constant basis, can handle a brief visit by some muriatic acid mixed with salt water. I worked on one large boat that had four Cruseair air conditioner units with poor heat transfer due to algae. One unit was so bad that it was tripping the high pressure cutout. When the engineer flushed this unit with muriatic acid, it immediately became the best performing unit.
__________________
mayball is offline   Reply With Quote
Old 15-09-2015, 12:55   #11
Registered User

Join Date: Mar 2011
Location: fl- various marinas
Boat: morgan O/I 33' sloop
Posts: 1,100
Re: Cruisair Air Conditioner / Heater Problems

if strainer gets clogged clean it and add a short piece of copper pipe to the bowl (supposed to kill barnacles) and reassemble. before restarting reverse flush your system by inserting a garden hose nozzle in the water outlet (make sure you open your water intake petcock first). cannot hurt. costs nothing and worked for me.
__________________
Dave22q is offline   Reply With Quote
Old 15-09-2015, 13:23   #12
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Albany Ga.
Boat: Island Packet 38
Posts: 17,050
Re: Cruisair Air Conditioner / Heater Problems

Quote:
Originally Posted by Wench'sCaptain View Post
Since there seems to be a few of you that know something about ac, I have a problem and need some help. My water flow has become restricted with some algea or moss. What is the best way to clear this up. I am cleaning the strainer twice a week to keep it clean. I have tried adding Bromine to the strainer and that has kept it running but the flow is not what it was a week ago. Any advise or assistance is welcome.

Tom
While a brief shot of muratic may work, I once a yr take a 5 gl bucket and fill it about half way with water and muratic acid, about a 30% mix and circulate this mix through the whole system for a few minutes. Can't do it too long as it heats up rather quickly.
I put a couple of gallons of cool fresh water in the bucket and start it circulating, then add the acid. It's amazing while it's just water its clear water circulating, but the second acid is added, it turns a dark green with all the algae.
__________________

__________________
a64pilot is online now   Reply With Quote
Reply

Tags
cruisair

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Air Conditioner choices rnjpinz Product or Service Reviews & Evaluations 9 28-07-2015 09:09
Flagship Air Conditioner pas63 Plumbing Systems and Fixtures 25 07-07-2013 20:32
Air Conditioner Condensate Curtis Electrical: Batteries, Generators & Solar 15 01-08-2012 22:46
Air Conditioner Maintenance Bill Lee Construction, Maintenance & Refit 3 15-04-2010 18:38
Air Conditioner Question JusDreaming Plumbing Systems and Fixtures 3 27-09-2009 08:39



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 20:35.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.